Roteadores HP 6600 – MPLS L2VPN com Martini através de um Túnel GRE

O script abaixo permite a extensão de um domínio de Broadcast através de uma rede IP utilizando o protocolo MPLS sobre um Túnel GRE sem a utilização de BGP em um roteador HP 6600.

Utilizei o cenário durante uma demanda para a extensão de um domínio de Broadcast entre 2 Data Centers Pares em quem o link dedicado para o Serviços de Computação em Nuvem sofreu atraso. O sincronismo dos Serviços  utilizando a camada de enlace (camada 2 do modelo OSI) foi estabelecido com a solução abaixo, visto que haviam restrições para configurar o mesmo serviço com MP-BGP por políticas de roteamento.

A solução permite o trânsito de quadros tagueados com 802.1q.

Obs: Antes de estabelecer o túnel GRE, certifique que as interfaces Loopback estejam acessíveis via Roteamento.

MPLS L2VPN Martini atraves de GRE

Espero ter sido útil. 🙂

Utilizando sub-interfaces nos Rotadores HP MSR’s, 8800 e 6600

A utilização de sub-interfaces em Roteadores permite a multiplexação/divisão de um único link físico em múltiplos links lógicos.

Como exemplo nos cenários abaixo, o Roteador poderá atuar tanto como Gateway para roteamento entre as VLANs X e Y no cenário A para casos em que o Roteador possua possua poucas portas disponíveis, por exemplo; como também em casos para rotear pacotes sem que as redes X e Y tenham acesso uma a outra com a utilização de VRFs , chamadas de VPN-Instance nos Roteadores HPN ( para o cenário B).

Subinterfaces no MSR

Para configurar uam sub-interface em um Roteador 8800, utilize o “.”(ponto) + o id da VLAN após o numero indicativo da porta em uma interface no modo routed.

[Roteador]interface Ten-GigabitEthernet 2/1/1.?

#

Segue um exemplo da configuração para o cenário A

interface Ten-GigabitEthernet 2/1/1.30
description VLAN_X
ip adress 192.168.20.1 255.255.255.0
quit
#
interface Ten-GigabitEthernet 2/1/1.31
description VLAN_Y
ip adress 192.168.30.1 255.255.255.0
quit
#

Em alguns modelos de Roteadores como a Serie 6600 será necessário configurar o VLAN ID, com a configuração do vlan-type dot1q vid [id da vlan] dentro da sub-interface, isto em razão do SO do Roteador não entender que é explicito o ID da VLAN no número da sub-interface. Roteadores Cisco funcionam da mesma forma.

interface Ten-GigabitEthernet 2/1/1.30
description VLAN_X
ip adress 192.168.20.1 255.255.255.0
vlan-type dot1q vid 30
quit
#
interface Ten-GigabitEthernet 2/1/1.31
description VLAN_Y
ip adress 192.168.30.1 255.255.255.0
vlan-type dot1q vid 31
quit
#

… então como as sub-interfaces estão diretamente conectadas, as rotas são adicionadas à tabela de roteamento, o equipamento fará  o roteamento de pacotes.

Já para o segundo cenário, a mesma configuração é válida, bastando apenas configurar a sub-interface com a configuração da vpn-instance antes de configurar o endereço IP.

#Criando a VRF para o cliente X
ip vpn-instance clientex
 route-distinguisher 65000:1
 vpn-target 65000:1 export-extcommunity
 vpn-target 65000:1 import-extcommunity
#
#Criando a VRF para o cliente Y
ip vpn-instance clientey
 route-distinguisher 65000:2
 vpn-target 65000:2 export-extcommunity
 vpn-target 65000:2 import-extcommunity
#
interface Ten-GigabitEthernet 2/1/1.30
description 
ip binding vpn-instance clientex
ip adress 192.168.20.1 255.255.255.0
quit
#
interface Ten-GigabitEthernet 2/1/1.31
description VLAN_Y
ip binding vpn-instance clientey
ip adress 192.168.30.1 255.255.255.0
quit
#
# as configurações do compartimento WAN de cada VRF foram omitidas
#

 obs: Uma rede não será roteada para outra a menos que estejam na mesma VRF.

Já para a configuração do Switch basta apenas configurar a interface como trunk permitindo as vlans correspondente. Se o Roteador for da Serie 6600 a configuração vlan-type dot1q vid … também será necessária (para o segundo cenário).

Um grande abraço e a Paz! 🙂

Alterando a distância administrativa para as rotas estáticas para Switches e Roteadores baseados no Comware.

Eu já escrevi alguns post sobre a atenção que deve ser dada para a integração entre Switches e Roteadores 3Com, H3C e HPN quando há a necessidade de compartilhar o roteamento dinâmico.

Como no exemplo abaixo, podemos ver que por padrão, toda rota estática é atribuída com o valor 60 para a distância administrativa. De forma didática, faço a comparação nas duas saídas do comando “display ip routing-table” da escolha da tabela de Roteamento pela rota aprendida com a menor distância adminstrativa (no primeiro quadro via rota estática e no segundo exemplo via OSPF).

[HPN] ip route-static 192.168.10.0 255.255.255.0 192.168.12.2
[HPN]
[HPN] display ip routing-table
Routing Tables: Public
        Destinations : 5        Routes : 5

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0
127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0
192.168.10.0/24     Static 60   0            192.168.12.2    Eth0/0/0
192.168.12.0/30     Direct 0    0            192.168.12.1    Eth0/0/0
192.168.12.1/32     Direct 0    0            127.0.0.1       InLoop0

Com a rota aprendida dinâmicamente via OSPF (e a estática ainda configurada), percebam que o roteador insere apenas a rota com a menor distância administrativa (valor 10 para o OSPF).

[HPN]display ip routing-table
Routing Tables: Public
        Destinations : 5        Routes : 5

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0
127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0
192.168.10.0/24     OSPF   10   2            192.168.12.2    Eth0/0/0
192.168.12.0/30     Direct 0    0            192.168.12.1    Eth0/0/0
192.168.12.1/32     Direct 0    0            127.0.0.1       InLoop0

Apesar da rota aprendida dinâmicamente “tomar” o lugar da rota estática e possuir o mesmo next-hop (no caso 192.168.12.2, interface Eth0/0/0), em redes mais complexas, o roteamento poderia escolher um caminho menos desejado pelo administrador de rede, visto que em equipamentos de outros fabricantes as rotas estáticas são atribuídas com a distâncias administrativa 1 ( e isso pode passar desapercebido ).

O comando “ip route-static default-preference 1” ajuda aqueles que estão acostumados a trabalhar com ambos roteamento dinâmico e estático, permitindo que as novas rotas configuradas possuam a distância adminstrativa 1 (nesse caso, melhor que todos os protocolos de Roteamento Dinâmico).

[HPN] ip route-static default-preference 1

Caso você prefira escolher manualmente o peso que cada rota terá, basta adicionar o “preference” no final de cada rota.

[HPN] ip route-static 192.168.20.0 255.255.255.0 192.168.12.2  preference ?
  INTEGER  Preference value range

Abração

Alterando a distancia administrativa para os protocolos de Roteamento em Switches e Roteadores HPN (Comware)

Há alguns posts atrás comentamos sobre a diferença da Distância Administrativa para as rotas aprendidas dinâmicamente em Switches e Roteadores dos fabricantes Cisco e HPN (H3C/3Com) e a atenção que deve ser dada em ambientes com Protocolos de Roteamento que possuem Switches e Roteadores  de ambos fabricantes

http://www.comutadores.com.br/distancia-administrativa-em-switches-l3-e-roteadores-h3c3comhp-serie-a/

A Distância Administrativa possui apenas função local e não é compartilhada pelo protocolo de roteamento.

Como por exemplo, em um Roteador utilizando o OSPF (como IGP) e o BGP para aprender as “rotas externas”, se uma mesma rota fosse aprendida via OSPF e BGP, o comportamento para escolha do melhor caminho seria diferente em Rotadores Cisco (a distancia administrativa para o OSPF é 110 e o  eBGP é 20) e HPN ( o OSPF é 10 e o eBGP é 255). Lembrando que para prefixos iguais aprendido por diferentes protocolos o Roteador escolhe a rota com menor distância administrativa.

Uma coisa bacana do Comware é poder alterar o valor da distância administrativa  baseado no processo de Roteamento, por exemplo, se tivermos 2 processos OSPF rodando no Router/Switch é possível alterar a distancia administrativa em um dos processos sem afetar o outro ( muito útil quando se utiliza VRFs [ vpn-instance] em um mesmo roteador) .

Para redes que utilizam MP-BGP, tambem é possível alterar a distância administrativa no address-family do cliente.

Veja o exemplo abaixo para a tabela de roteamento Global (eBGP e iBGP com a distância adminstrativa em 255) e a tabela de roteamento da vpn-instance cliente-A (com o eBGP como 7 e o iBGP como 100).

<Router>display ip routing-table
Routing Tables: Public
Destinations : 18177     Routes : 18177

Destination/Mask    Proto  Pre  Cost         NextHop         Interface
0.0.0.0/0           BGP    255  0            10.180.226.197  GE3/1/6.100
192.168.9.0/24      BGP    255  0            10.180.226.197  GE3/1/6.100
192.168.10.0/24     BGP    255  0            10.180.226.197  GE3/1/6.100
192.168.11.0/24     BGP    255  0            10.180.226.197  GE3/1/6.100
<saída omitida>

<Router>display ip routing-table vpn-instance cliente-A
Routing Tables: cliente-A
Destinations : 1789      Routes : 1789
Destination/Mask    Proto  Pre  Cost         NextHop         Interface
1.1.1.1/32          BGP    7    0            192.168.176.217  GE9/1/7
2.2.2.0/29          BGP    7    0            192.168.176.217  GE9/1/7
192.168.80.0/30     BGP    100  0            192.168.229.193  NULL0
10.1.1.1/32         BGP    7    0            192.168.176.217  GE9/1/7
<saída omitida>

Para configurar a distancia administrativa dentro processo BGP ou dentro do processo “ipv4-family vpn-instance [nome da vrf]” no BGP use a sintaxe:

[Router-bgp]preference ?
INTEGER<1-255>  External preference
!Distancia administrativa para rotas aprendidas via eBGP

[Router-bgp]preference 7 ?
INTEGER<1-255>  Internal preference
!Distancia administrativa para rotas aprendidas via iBGP

[Router-bgp]preference 7 100 ?
INTEGER<1-255>  Local preference
!Distancia administrativa para rotas aprendidas via iBGP (locais)

[Router-bgp]preference 7 100 9 

Para o OSPF  utilize o commando preference para alterar a distância administrativa de rotas OSPF e OSPF ASE:

[Router-ospf-1]preference ?
INTEGER<1-255>  Preference value
ase             AS external link states

[Router-ospf-1]preference ase ?
INTEGER<1-255>  Preference value

Até logo!

OSPF – Roteador Designado (DR) e Roteador Designado de Backup (BDR)

Para o estabelecimento de uma adjacência no OSPF os Roteadores vizinhos devem se reconhecer para trocarem informações, encaminhando e recebendo mensagens Hello nas Interfaces participantes do OSPF; no endereço de Multicast 224.0.0.5.

Durante estabelecimento da Adjacência, serão trocadas informações dos Roteadores da Rede como a informação da área, prioridade dos Roteadores, etc. Após a sincronizarem as informações, os Roteadores da área terão a mesma visão da Topologia e rodarão o algoritmo SPF para escolha do melhor caminho para chegar ao Destino.

Os Roteadores (já) Adjacentes encaminharão mensagens Hellos ( verificação da disponibilidade), mensagens LSA com as atualizações da rede e mensagens a cada 30 minutos de refresh de cada LSA para certificar que os a tabela OSPF (LSDB) esteja sincronizada.

Durante a falha de um Link, a informação é inundada (flooded) para todos os Roteadores Adjacentes da Área. 

Em ambientes Multiacesso como redes Ethernet, os Roteadores OSPF elegem um Roteador Designado (DR) para formar Adjacência e encaminhar os LSA’s somente para ele. O Roteador DR reencaminha os updates recebidos por um vizinho para os outros Roteadores na mesma LAN.

Há também a eleição de um Roteador Desingnado de Backup (BDR) para assumir em caso de falha do DR.

O método de eleição do DR e BDR é bastante efetivo e confiável para estabelecimento de Adjacências e mensagens trocadas para manutenção do OSPF, economizando assim recursos conforme o crescimento da Topologia.

Atualização DR e BDR

 

Quando ocorre uma mudança na topologia o Roteador/Switch encaminha uma mensagem em Multicast para o endereço 224.0.0.6 que é destinada a todos Roteadores OSPF DR/BDR.

Após o recebimento do Update, o Roteador DR confirma o recebimento (LSAck) e reencaminha a mensagem para os demais roteadores da rede no endereço de Multicast 224.0.0.5; após o recebimento da atualização todos os roteadores deverão confirmar a mensagem ao Roteador Designado (LSAck), tornando o processo confiável.

Se algum Roteador estiver conectado à outras redes, o processo de flood é repetido!

Obs: O BDR não efetua nenhuma operação enquanto o DR estiver ativo!

Como é feita a eleição do DR e BDR? 

Durante o processo de estabelecimento de Adjacência é verificado o campo Priority na troca de mensagens Hello. O Roteador com maior valor é eleito o DR e o Roteador com segundo maior valor é eleito o BDR ( em cada segmento).

O valor default da prioridade de todos os Roteador é 1, no caso de empate, é escolhido o valor do ID do Roteador para desempate. Vence quem tiver o maior valor!

OSPF DR Priority

 

Obs: Se a prioridade for configurada como 0, o dispositivo nunca será um DR ou BDR. Nesse caso ele será classificado com DROther ( não DR e não BDR) 

Configurando
O valor da prioridade deverá ser configurado na Interface VLAN ou física (Ethernet, GigabitEthernet, etc) dos Switches/Roteadores com o processo de OSPF ativo:

interface Vlan-interface1
ip address 192.168.0.26 255.255.255.0
ospf dr-priority 3
!Configurando a Prioridade para eleição do DR/BDR com o valor 3

Porém….

A prioridade do DR e do BDR não é preemptiva, isto é, para manter a estabilidade da topologia se um dispositivo for eleito como DR e BDR, o mesmo não perderá esse direito até ocorrer algum problema no link ou no dispositivo eleito.

Conforme comando display abaixo, o Switch configurado com a prioridade 3 perde a eleição (de tornar-se o DR) para dispositivo com a prioridade 4 ( pelo fato de ser inserido na topologia posteriormente a eleição do DR/BR).

[7500]display ospf peer
OSPF Process 100 with Router ID 192.168.0.5
Neighbor Brief Information

Area: 0.0.0.0
Router ID Address Pri Dead-Time Interface State

192.168.0.13 192.168.0.13 0 38 Vlan1 Full/DROther
192.168.0.14 192.168.0.14 1 31 Vlan1 Full/DROther
192.168.0.20 192.168.0.20 1 34 Vlan1 Full/DROther
192.168.0.21 192.168.0.21 4 30 Vlan1 Full/DR
!Roteador DR com a prioridade 4
192.168.0.26 192.168.0.26 5 31 Vlan1 Full/DROther
! Roteador DROther com a prioridade 5 só será o DR na falha do DR e BDR
192.168.0.33 192.168.0.33 1 32 Vlan1 Full/BDR
! Roteador BDR com a prioridade 1
192.168.0.45 192.168.0.45 1 40 Vlan1 Full/DROther

O Switch com a Prioridade 5, irá tornar-se DR somente após falha no DR e no BDR.

Referencias:

Building Scalable Cisco Internetworks – Diane Teare/Catherine Paquet

Duvidas? Deixe um comentário!

Um grande abraço

Switches 3Com 4500G – Configurando o RIP versão 1

Publicado originalmente em 26 DE JULHO DE 2010

Olá amigos, já faz um bom tempo que eu venho pensando em escrever um post sobre o RIP. Esses dias durante a leitura de um livro muito bacana chamado Routing TCP/IP, Volume I 2nd Edition (Jeff Doyle, Jennifer Carroll), decidi escrever esse artigo.

Apesar do RIP ser um protocolo de Roteamento simples, sua função é bastante útil em redes pequenas, em comunicações entre Roteadores PE e CPE em redes MPLS, na redistribuição entre protocolos de Roteamento e dispositivos de rede com suporte apenas ao RIP (como protocolo de Roteamento Dinâmico).

O Routing Information Protocol (RIP) utiliza o algoritmo de vetor de distancia (Distance Vector) para escolha de melhor caminho para o destino – o RIP determina a distancia como métrica.

A contagem máxima de distancia para o RIP é 15, o 16º salto é considerado como inalcançável ou infinito.

No exemplo abaixo com todos os Roteadores com RIP ativo, o Roteador W informaria dinamicamente a todos os Roteadores diretamente conectados que possui a Rede 192.168.1.0/24 essas informações são repassadas pelos outros Roteadores até o Roteador X que escolheria o Caminho B como caminho mais curto para acesso a rede 192.168.1.0/24 e incluiria essa informação na tabela de Roteamento.

O RIP encaminha a cada 30 segundos toda a sua tabela de Roteamento em Broadcast (255.255.255.255) na porta 520 UDP.

A regra Split Horizon diz que as atualizações recebidas por uma interface não serão incluídas e/ou encaminhadas de volta nas atualizações para aquela interface. Exemplificando, o Roteador X não encaminhará informações da Rede 192.168.1.0/24 de volta aos Roteadores que lhe encaminharam informações sobre essa rota.

Outra maneira de evitar rotas inconsistentes é a utilização de Route Poisoning, por exemplo, se a rota 192.168.1.0/24 ficar Down o Roteador W iniciará o Route Poisoning anunciando a rede com métrica 16 (como inalcançável). Os roteadores diretamente conectados responderão com a mensagem poison reverse ao Roteador W certificando que receberam a mensagem além de replicarem a rota poisoning aos outros Roteadores.

O RIP encaminha mensagens a cada 30 segundos, o tempo para determinar uma rota como invalida é de 180 segundos.

Obs: o RIP versão 1 não encaminha informações sobre mascara nas atualizações de Rotas para os vizinhos, por isso é considerado um protocolo ClassFull (classe cheia) que obrigatoriamente precisa de consistência na distribuição de sub-redes, não sendo possível trabalhar com mascaras de tamanho variável e redes descontinuas.

Configurando o RIP


Switch 4500-A 
[4500G-A]
vlan 1
#
vlan 2
#
vlan 50
#
interface Vlan-interface1
ip address 192.168.1.1 255.255.255.0
! Atribuindo o endereço IP a VLAN 1
#
interface Vlan-interface2
ip address 192.168.2.1 255.255.255.0
! Atribuindo o endereço IP a VLAN 2
#
interface Vlan-interface50
ip address 192.168.50.1 255.255.255.0
! Atribuindo o endereço IP a VLAN 50
#
rip 1
! Ativando o processo RIP 1(é possivel trabalharmos com processos RIP 
! independentes no mesmo Switch)
version 1
! O RIP possui 2 versões,a versão 1 trabalha somente com mensagens em  
!  Broadcaste rotas Classfull enquanto o RIP versão 2 oferece suporte 
!  a máscaras de tamanho variável e atualizações em multicast
network 192.168.1.0
network 192.168.2.0
network 192.168.50.0
! Adicionando as redes 192.168.1.0, 192.168.2.0 e 192.168.50.0 ao 
! processo RIP, para encaminhamento de atualizações dessas redes 
! aos vizinhos, incluindo o encaminhamento de mensagens Broadcasts
! por essas VLANs 
#

Switch 4500-B
[4500G-B]
vlan 1
#
vlan 10
#
vlan 17
#
interface Vlan-interface1
ip address 192.168.1.2 255.255.255.0
#
interface Vlan-interface10
ip address 10.0.0.1 255.0.0.0
#
interface Vlan-interface17
ip address 172.17.0.1 255.255.0.0
#
rip 1
network 192.168.1.0
network 172.17.0.0
network 10.0.0.0
#

Comandos Display

<4500G-A>display ip routing-table
Routing Tables: Public
Destinations : 10 Routes : 10
Destination/Mask Proto Pre Cost NextHop Interface
10.0.0.0/8 RIP 100 1 192.168.1.2 Vlan1
127.0.0.0/8 Direct 0 0 127.0.0.1 InLoop0
127.0.0.1/32 Direct 0 0 127.0.0.1 InLoop0
172.17.0.0/16 RIP 100 1 192.168.1.2 Vlan1
192.168.1.0/24 Direct 0 0 192.168.1.1 Vlan1
192.168.1.1/32 Direct 0 0 127.0.0.1 InLoop0
192.168.2.0/24 Direct 0 0 192.168.2.1 Vlan2
192.168.2.1/32 Direct 0 0 127.0.0.1 InLoop0
192.168.50.0/24 Direct 0 0 192.168.50.1 Vlan50
192.168.50.1/32 Direct 0 0 127.0.0.1 InLoop0

<4500G-A>display rip
RIP process : 1
RIP version : 1
Preference : 100
Checkzero : Enabled
Default-cost : 0
Summary : Enabled
Hostroutes : Enabled
Maximum number of balanced paths : 1
Update time : 30 sec(s) Timeout time : 180 sec(s)
Suppress time : 120 sec(s) Garbage-collect time : 120 sec(s)
update output delay : 20(ms) output count : 3
TRIP retransmit time : 5 sec(s)
TRIP response packets retransmit count : 36
Silent interfaces : None Default routes : Disabled
Verify-source : Enabled
Networks :
192.168.50.0 192.168.2.0
192.168.1.0
Configured peers : None
Triggered updates sent : 43
Number of routes changes : 24
Number of replies to queries : 4

Até logo 🙂

Distância administrativa em Switches L3 e Roteadores H3C/3Com/HP Serie A

A tabela de roteamento dos Switches L3 e Roteadores, insere os destinos aprendidos manualmente (rotas estáticas ou redes diretamente conectadas) ou dinamicamente (aprendidos via protocolo de roteamento dinâmico).

 
Para os casos de uma destino ser aprendido de diferentes formas, como por exemplo, o prefixo 192.168.1.0/24 ser aprendido via RIP e OSPF, o Roteador dará preferência para a rota com  Distância Administrativa de menor valor, no caso, o destino aprendido via OSPF terá preferência pelo valor 10 em detrimento do protocolo RIP com o valor 100 (nesse exemplo a rota eo gateway da rede que será inserido na tabela de roteamento será o aprendido via OSPF).Perceba que as rotas diretamente conectadas possuem a prioridade 0 (zero) e serão roteadas internamente pelo dispositivo.

 
A Distância Administrativa possui apenas função local e não é compartilhada pelo protocolo de roteamento. Um detalhe importante a ser percebido é a diferença com os valores atribuídos para a distancia administrativa para Roteadores Cisco. Em todo caso para evitar problemas em cenários com mais de 1 protocolo de roteamento, altere a métrica  em um dos dois dispositivos.

 

Distância Adm. HP Serie A
Distância Adm. Cisco
Directly Connected
0
0
OSPF
10
110
IS-IS
15
115
STATIC
60
1
RIP
100
120
OSPF ASE
150
110
OSPF NSSA
150
110
IBGP
255
200
EBGP
255
20
Unknown
256
255

Abraços a todos

Switches HP A7500 – Configurando Autenticação para o OSPF na Área 0

Publicado originalmente em 29 DE JANEIRO DE 2011

Para validar a troca de informações de Roteamento, o protocolo OSPF suporta a Autenticação para estabelecimento de adjacência com vizinhos. O Processo incrementa segurança ao Roteamento Dinâmico com troca de chaves em MD5.

Para ativarmos a Autenticação é necessário informar qual a Área OSPF  utilizará  a Autenticação e precisaremos habilitar a chave na Interface VLAN que formará a adjacência.

Configurando

Segue abaixo a configuração dos Switches.

Switch A

#
interface Vlan-interface1
ip address 172.31.0.1 255.255.0.0
ospf authentication-mode md5 10 cipher testeospf
! Configurando a chave md5 cifrada com a chave numero 10 como testeospf na interface VLAN
(a senha será exibida no arquivo de configuração cifrada)
#
ospf 100 router-id 172.31.0.1
area 0.0.0.0
authentication-mode md5
! Habilitando a autenticação utilizando md5 na Area 0
network 172.31.1.1 0.0.0.0
area 2
network 192.168.1.1 0.0.0.0
! Area 2 sem autenticação
#

Switch B

#
interface Vlan-interface1
ip address 172.31.0.2 255.255.0.0
ospf authentication-mode md5 10 cipher testeospf
! Configurando a chave md5 cifrada com a chave numero 10 como testeospf na interface VLAN #
ospf 100 router-id 172.31.0.2
area 0.0.0.0
authentication-mode md5
! Habilitando a autenticação utilizando md5 na Area 0
network 172.31.1.2 0.0.0.0

Display

[SW1] display ospf peer
OSPF Process 100 with Router ID 172.31.0.1
Neighbor Brief Information
Area: 0.0.0.0
Router ID  Address Pri Dead-Time Interface State
172.31.0.2 172.31.0.2 1 36 Vlan1 Full/DR

 

Até a próxima! 😉

 

 

Switches 3Com 4800G – RIPng

Publicado originalmente em 5 DE AGOSTO DE 2010

Olá amigos, hoje escreverei um artigo sobre o RIPng, o primeiro post de uma série sobre IPv6.

O RIPng é um protocolo de Roteamento dinâmico, IGP, de vetor de distancia que permite que Roteadores troquem informações sobre as suas rotas/prefixos IPv6 dentro do domínio RIPng, utilizando-se da contagem de saltos como custo para cada prefixo (rede).

Assim como no RIP versão 1 e 2 (redes IPv4), o RIPng utiliza a contagem de até 15 saltos, conforme os Roteadores vão repassando os prefixos para os vizinhos é adicionado o custo 1 ao prefixo declarado em cada Roteador , o 16º salto é considerado inalcançável(infinito).

 

O RIPng possui os mesmos temporizadores (timers), procedimentos e mensagens que o RIP versão 2 ( 30 segundos para atualizações, 180 para timeout, 120 para garbage-collection e 180 segundos para holddown).

Diferente do RIP versão 2, a autenticação fica a encargo do IPv6. O RIPng encaminha e recebe datagramas UDP na porta 521.

Configurando o RIPng

• O Switch 1 possui o a rede 2001:db8:90::/64
o A comunicação com o Switch 2 será pela rede 2001:db8:1::/64
o A comunicação com o Switch 3 será pela rede 2001:db8:2::/64

• O Switch 2 possui o a rede 2001:db8:20::/64
o A comunicação com o Switch 1 será pela rede 2001:db8:1::/64
o A comunicação com o Switch 3 será pela rede 2001:db8::/64

• O Switch 3 possui o a rede 2001:0db8:30::/64
o A comunicação com o Switch 2 será pela rede 2001:db8::/64
o A comunicação com o Switch 1 será pela rede 2001:db8:2/64

Switch 1

sysname SW1
#
vlan 1 
#
vlan 2
#
vlan 90
#
ipv6
! Ativando o IPv6 
#
interface Vlan-interface1
ipv6 address 2001:DB8:1::1/64
! Configurando o endereço IPv6 2001:0db8:1::1/64 
ripng 1 enable
! Ativando o RIPng processo 1 na interface VLAN 1
#
interface Vlan-interface2
ipv6 address 2001:DB8:2::2/64
! Configurando o endereço IPv6 2001:db8:2::2/64 
ripng 1 enable
! Ativando o RIPng processo 1 na interface VLAN 2 
#
interface Vlan-interface90
ipv6 address 2001:DB8:90::1/64
! Configurando o endereço IPv6 2001:db8:90::1/64
ripng 1 enable
! Ativando o RIPng processo 1 na interface VLAN 90
#
interface GigabitEthernet1/0/31
#
interface GigabitEthernet1/0/32
port link-type access
port access vlan 2
#

Switch 2

sysname SW2
#
vlan 1
#
vlan 3
#
vlan 20
#
ipv6
#
interface Vlan-interface1
ipv6 address 2001:DB8:1::2/64
ripng 1 enable
#
interface Vlan-interface3
ipv6 address 2001:DB8::1/64
ripng 1 enable
#
interface Vlan-interface20
ipv6 address 2001:DB8:20::1/64
ripng 1 enable
#
interface GigabitEthernet1/0/25
#
interface GigabitEthernet1/0/26
port link-type access
port access vlan 3
#

Switch 3

#
sysname SW3
#
vlan 1
#
vlan 2
#
vlan 3
#
ipv6
#
interface Vlan-interface2
ipv6 address 2001:DB8:2::1/64
ripng 1 enable
#
interface Vlan-interface3
ipv6 address 2001:DB8::2/64
ripng 1 enable
#
interface Vlan-interface30
ipv6 address 2001:DB8:30::1/64
ripng 1 enable
#
interface GigabitEthernet1/0/47
port link-type access
port access vlan 3
#
interface GigabitEthernet1/0/48
port link-type access
port access vlan 2
#

Comandos Display

[SW3]display ipv6 routing-table 

Routing Table :
Destinations : 11 Routes : 12

Destination: ::1/128 Protocol : Direct
NextHop : ::1 Preference: 0
Interface : InLoop0 Cost : 0

Destination: 2001:DB8::/64 Protocol : Direct
NextHop : 2001:DB8::2 Preference: 0
Interface : Vlan3 Cost : 0

Destination: 2001:DB8::2/128 Protocol : Direct
NextHop : ::1 Preference: 0
Interface : InLoop0 Cost : 0

Destination: 2001:DB8:1::/64
Protocol : RIPng NextHop : FE80::224:73FF:FEE0:8481 Preference: 100
Interface : Vlan2 Cost : 1 

Destination: 2001:DB8:1::/64
Protocol : RIPng NextHop : FE80::224:73FF:FEDC:4381 Preference: 100
Interface : Vlan3 Cost : 1 

Destination: 2001:DB8:2::/64
Protocol : Direct NextHop : 2001:DB8:2::1 Preference: 0
Interface : Vlan2 Cost : 0

Destination: 2001:DB8:2::1/128 Protocol : Direct
NextHop : ::1 Preference: 0
Interface : InLoop0 Cost : 0

Destination: 2001:DB8:20::/64 Protocol : RIPng
NextHop : FE80::224:73FF:FEDC:4381 Preference: 100
Interface : Vlan3 Cost : 1

Destination: 2001:DB8:30::/64 Protocol : Direct
NextHop : 2001:DB8:30::1 Preference: 0
Interface : Vlan30 Cost : 0

Destination: 2001:DB8:30::1/128 Protocol : Direct
NextHop : ::1 Preference: 0
Interface : InLoop0 Cost : 0

Destination: 2001:DB8:90::/64 Protocol : RIPng
NextHop : FE80::224:73FF:FEE0:8481 Preference: 100
Interface : Vlan2 Cost : 1

Destination: FE80::/10 Protocol : Direct
NextHop : :: Preference: 0
Interface : NULL0 Cost : 0

Um detalhe importante a ser percebido (grifado em vermelho) na visualização da tabela de Roteamento IPv6, são as rotas aprendidas dinâmicamente pelo RIPng. Repare que o endereço do NextHop (próximo salto) foi gerado dinamicamente pelo RIPng.

 

O endereço FE80::/10 é reservado para endereços chamados de Link-local que possuem escopo limitado e são utilizados para configuração automatica de endereços, descoberta de rotas e por diversos Protocolos de Roteamento.

No caso dos links Ethernet é utilizado a derivação do endereço MAC (48 bits) do Switch para gerar um endereço de 64 bits, por exemplo, o Switch 1 possui o endereço MAC 0024-73e0-8480. O NextHop para a rede 2001:db8:90::/64 mostrado na tabela de roteamento IPv6 do SW3 é :

Destination: 2001:DB8:90::/64 Protocol : RIPng
NextHop : FE80::224:73FF:FEE0:8481 Preference: 100

Note que é inserido 16 bits (FFFE) entre o endereço MAC para criação automática do endereço Link Local.

Obs: A especificação do próximo salto para o RIPng sempre será um Link local.

 

[SW3]display ripng 1 route
Route Flags: A - Aging, S - Suppressed, G - Garbage-collect
----------------------------------------------------------------

Peer FE80::224:73FF:FEDC:4381 on Vlan-interface3
Dest 2001:DB8::/64,
via FE80::224:73FF:FEDC:4381, cost 1, tag 0, A, 19 Sec
Dest 2001:DB8:20::/64,
via FE80::224:73FF:FEDC:4381, cost 1, tag 0, A, 19 Sec
Dest 2001:DB8:1::/64,
via FE80::224:73FF:FEDC:4381, cost 1, tag 0, A, 19 Sec

Peer FE80::224:73FF:FEE0:8481 on Vlan-interface2
Dest 2001:DB8:2::/64,
via FE80::224:73FF:FEE0:8481, cost 1, tag 0, A, 17 Sec
Dest 2001:DB8:90::/64,
via FE80::224:73FF:FEE0:8481, cost 1, tag 0, A, 17 Sec
Dest 2001:DB8:1::/64,
via FE80::224:73FF:FEE0:8481, cost 1, tag 0, A, 17 Sec

Aos poucos irei adicionando outros posts sobre IPv6.

Espero que tenham gostado!

Abraços

 

 

Switches 3Com 4800G – Filtro de prefixos e ASes no BGP

Pessoal, estou compartilhando um segundo script sugerido pelo Meeeeeestre Denis Albuquerque sobre a utilização de filtros para o tamanho dos prefixos incluíndo filtros baseados em ASes. O post serve como continuidade ao post anterior sobre configuração básica do BGP.

Comentario Geral sobre o Script
O BGP permite a configuração regras baseadas em prefixos, ASes, metricas de entrada, saída,etc. A route-policy SAIDA servirá para controlarmos as redes que serão injetadas no proximo AS, como por exemplo, para proteção do próprio AS 65535 não servir de trânsito em caso de conexão direta com outros ASes. A route-policy SAIDA limitará o recebimento de prefixos para SOMENTE os prefixos interessantes.

Configuração

#
interface Vlan-interface10
ip address 10.0.0.1 255.255.255.252
! Interface para estabelecimento de peering eBGP
#
interface Vlan-interface11
ip address 11.0.0.1 255.255.255.252
! Interface para estabelecimento de peering iBGP
#
bgp 65535
undo synchronization
peer 10.0.0.2 as-number 65530
! formação de peering eBGP
peer 11.0.0.2 as-number 65535
! formação de peering iBGP
peer 10.0.0.2 description eBGP
peer 11.0.0.2 description iBGP
peer 10.0.0.2 route-policy SAIDA export
! a route-policy declarará prefixos da regra SAIDA
peer 10.0.0.2 route-policy ENTRADA import
! a route-policy receberá prefixos da regra ENTRADA
peer 10.0.0.2 route-limit 1000
! desfaz o peering se o limite de prefixos recebidos for atingido
peer 10.0.0.2 password simple SENHA
peer 11.0.0.2 next-hop-local
! inclui o Switch como next-hop das rotas encaminhadas. 
#
route-policy ENTRADA permit node 10
if-match ip-prefix FILIAIS
! a route-policy permitirá os prefixos do ip-prefix FILIAIS
route-policy SAIDA permit node 10
if-match as-path 1
! a route-policy permitirá somente os ASes do AS-path 1
#
ip ip-prefix FILIAIS index 10 permit 172.17.0.0 16 greater-equal 16 less-equal 32
! a regra ip-prefix FILIAIS permitirá somente o anuncio da rede 172.17.0.0/16 até /32 , prefixos diferentes ou menores que /16 não serão recebidos
#
ip as-path 1 permit ^$
! a expressão regular ^$ representa somente as rotas locais do próprio AS

Até mais…