Comware – Roteamento seletivo entre VRFs com export-map

A utilização de VRFs (Virtual Routing and Forwarding ou vpn-instance na linguagem HP) em Roteadores permite a criação de tabelas de roteamentos virtuais que trabalham de forma independente da tabela de roteamento “normal”, protegendo os processos de roteamento de cada cliente de forma individual.

Como nós explicamos anteriormente no post http://www.comutadores.com.br/roteamento-entre-vrfs-com-mp-bgp-em-roteadores-hp-h3c/ o rotemento entre VRFs (quando necessário) pode ser efetuado com a manipulação do  route-targets (RT) com o processo MP-BGP ativo no Roteador.

Há também cenários em que é necessário a troca seletiva de prefixos de rede entre as tabelas de roteamento virtuais, escolhendo quais redes devem ser exportardas ou não entre as VRFs. Lembrando que os valores vpn-target (route-target) trabalham com as Extended community do BGP para troca de prefixos entre VRFs,  é possível manipular o processo via route-policy (route-map), configurando a “comunidade estendida” para o prefixo e utilizando o comando export dentro da VRF.

Relembrando…

No diagrama abaixo há 2 VRFs já configuradas (com o processo MP-BGP ativo) e com seus respectivos prefixos.

Como os valores para import/export das VRFs não são os mesmos, não há roteamento entre as VRFs (cada VRF tem o seu roteamento isolado). Configuração do 1º exemplo

VRFs prefixes

No exemplo abaixo, caso manipulassemos o import/export, teríamos as 2 tabelas de roteamento compartilhadas… Configuração do 2º exemplo

inter VRFs prefixes

Mas imaginem que a VRF Client_B, por questões de segurança no roteamento, não precissasse ensinar os prefixos 172.16.2.0/24 e 172.16.3.0/24 para a VRF Client_A mas somente o prefixo 172.16.1.0/24…. Nesse caso precisaríamos configurar o roteamento seletivo para que a VRF Client_A aprenda somente os prefixos necessários.

Ja a VRF Client_A exportará todos os prefixos sem filtros para a Client_B

Utilizaremos no exemplo o valor da Extended Community 65000:12 para exportar o prefixo 172.16.1.0/24.

ip ip-prefix Client_B_prefixo index 5 permit 172.16.1.0 24
! Selecionando o prefixo via prefix-list
!
route-policy Client_B_export permit node 10
 if-match ip-prefix Client_B_prefixo
 apply extcommunity rt 65000:12  additive
#
! Configurando a community estendida via Route-map
!
ip vpn-instance Client_B
 export route-policy Client_B_export
 quit
! Configurando o export seletivo de prefixo
end
!

inter VRFs prefixes exportmap

A configuração dos 3º cenário pode ser encontrada aqui

Obs: O mesmo controle pode ser feito para os prefixos de entrada, utilizando o “import map”

Dúvidas , deixe um comentario

Referência: http://www.rotadefault.com.br/roteamento-seletivo-entre-vrfs-com-export-map/

Roteadores HP 6600 – MPLS L2VPN com Martini através de um Túnel GRE

O script abaixo permite a extensão de um domínio de Broadcast através de uma rede IP utilizando o protocolo MPLS sobre um Túnel GRE sem a utilização de BGP em um roteador HP 6600.

Utilizei o cenário durante uma demanda para a extensão de um domínio de Broadcast entre 2 Data Centers Pares em quem o link dedicado para o Serviços de Computação em Nuvem sofreu atraso. O sincronismo dos Serviços  utilizando a camada de enlace (camada 2 do modelo OSI) foi estabelecido com a solução abaixo, visto que haviam restrições para configurar o mesmo serviço com MP-BGP por políticas de roteamento.

A solução permite o trânsito de quadros tagueados com 802.1q.

Obs: Antes de estabelecer o túnel GRE, certifique que as interfaces Loopback estejam acessíveis via Roteamento.

MPLS L2VPN Martini atraves de GRE

Espero ter sido útil. 🙂

Switches HPN 12500 – MPLS – Configuração Básica

Dando continuidade aos posts anteriores sobre MPLS, segue abaixo a configuração básica para ativar o serviço em um Switch HPN modelo A12500. O script dará foco no protocolo LDP para adjacência entre roteadores vizinhos e a troca de labels; em conjunto com o OSPF para o vinculo (binding) dos prefixos IP com  labels.

Configuração

#
interface LoopBack1
 ip address 1.1.1.1 255.255.255.255
#
mpls
! Ativando o Serviço MPLS no Switch
#
mpls ldp
! Ativando o protocolo LDP para troca de labels
#
mpls lsr-id 1.1.1.1
! Forçando o Router id com o endereço da Loopback para adjacência
! entre Roteadores  vizinhos
#
interface Vlan-interface1
 ip address 10.0.0.1 255.255.255.0
 mpls
! Ativando o Serviço na interface VLAN 1
 mpls ldp
! Ativando o protocol LDP para troca de Labels na
! Interface VLAN 1 e adjacência
#
interface Ten-GigabitEthernet0/0/34
 port link-mode route
 ip address 10.0.1.2 255.255.255.252
mpls 
mpls ldp
#
ospf 1
 area 0.0.0.0
 network 0.0.0.0 255.255.255.255
 #

Displays

Para visualização dos neighbors, LSP e bindings, sugiro os seguintes comandos abaixo:

[Switch] display mpls ldp peer

[Switch] display mpls ldp session

[Switch] display mpls ldp interface

[Switch]display mpls ldp lsp
                              LDP LSP Information
 SN     DestAddress/Mask   In/OutLabel   Next-Hop        In/Out-Interface 

26     192.168.1.0/24       25/26     10.0.1.1          XGE0/0/34
27     192.168.0.1/32      2236/3043     192.0.0.5      XGE0/0/34
28     192.168.3.1/32     1037/1044     192.0.0.5       XGE0/0/34

[Switch]display mpls ldp
                           LDP Global Information

 Protocol Version        : V1           Neighbor Liveness    : 120 Sec
 Graceful Restart        : Off          FT Reconnect Timer   : 300 Sec
 MTU Signaling           : Off          Recovery Timer       : 300 Sec
                          LDP Instance Information

 Instance ID             : 0            VPN-Instance         :
 Instance Status         : Active       LSR ID               : 1.1.1.1
 Hop Count Limit         : 32           Path Vector Limit    : 32
 Loop Detection          : Off
 DU Re-advertise Timer   : 30 Sec       DU Re-advertise Flag : On
 DU Explicit Request     : Off          Request Retry Flag   : On
 Label Distribution Mode : Ordered      Label Retention Mode : Liberal

Até logo!

Introdução ao MPLS (Multi Protocol Label Switching) – parte 2

Essa semana publicamos no RotaDefault o segundo artigo introdutório sobre MPLS com comentários sobre a nomenclatura  de alguns termos como Roteadores CE, PE e P, informações sobre FEC, LSP e etc.

O Artigo poderá ser lido no link abaixo:

 http://www.rotadefault.com.br/2011/12/03/introducao-ao-mpls-multi-protocol-label-switching-%e2%80%93-parte-2/

A configuração para equipamentos HPN foi publicada no post :

http://comutadores.blogspot.com/2011/11/switches-hpn-12500-mpls-configuracao.html

Até logo!

Introdução ao MPLS (Multi Protocol Label Switching) – parte 1

Publicado originalmente em 20 DE OUTUBRO DE 2011

Essa semana publiquei no site RotaDefault um artigo introdutório sobre MPLS que será dividido em algumas partes. O mesmo servirá de gancho para alguns posts sobre a configuração de LDP, MP-BGP e VPLS em Roteadores e Switches HPN.

O artigo está emhttp://www.rotadefault.com.br/2011/10/20/introducao-ao-mpls-multi-protocol-label-switching-%e2%80%93-parte-1/

Obs: No final do artigo há a indicação de alguns livros interessantes que usei como referência!

Abraços a todos