Blog Archives

Resumo de Configuração: Link Aggregation com LACP e extensão de VLANs no Trunk (Comware 5)

Resumo de Configura de Link Aggregation

Sentiram a falta de alguma configuração? Gostariam de fazer alguma sugestão? Deixem comentários!

Roteadores HP 8800 – Configurando interface Route-Aggregation

Alguns Roteadores da HP permitem a criação de  Interfaces Link-Aggregation com endereço IP atribuído, chamado de Route-Aggregation. A feature auxilia o Roteador na agregação de Portas Ethernet com Switches, Roteadores, etc ( muito parecido com um Multilink PPP), permitindo a configuração de maneira estática ou via protocolo LACP.

[Router]interface route-aggregation 1
link-aggregation mode dynamic
! Habilitando a formação do Route-Aggregation via LACP
ip address 192.168.1.1 255.255.255.0
! Atribuindo um endereço IP a Interface
quit
!
# Configurando as portas para participarem do Route-Aggregation
interface Gigabitethernet 3/0/1
port link-aggregation group 1
quit
interface Gigabitethernet 3/0/2
port link-aggregation group 1
quit

Para visualizar se a agregação de portas foi executada corretamente, utilize o comando display link-aggregation summary

[Router] display link-aggregation summary

Aggregation Interface Type:
BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation
Aggregation Mode: S -- Static, D -- Dynamic
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Actor System ID: 0x8000, 000f-e2ff-0001

AGG         AGG       Partner ID               Select Unselect   Share
Interface   Mode                               Ports  Ports      Type
---------------------------------------------------------------------
RAGG1       D         0x8000, 000f-e2ff-00aa   2      0          Shar

Já da parte do Switch, HP, 3Com, Cisco e etc, não há alteração na maneira que configuramos os equipamentos com Link-Aggregation/Etherchannel para o Roteador.  ;)

 

Até logo.

Switches HP A7500 – IRF v2 utilizando LACP com MAD

Uma das coisas bacanas da utilização do IRF é a possibilidade de transformarmos diversos Switches físicos em um único Switch lógico facilitando o modo de gerenciamento. Todos os equipamentos serão visualizados como uma única “caixa”. Na versão 2 do protocolo é possível efetuar o Stacking utilizando links de 10G ( como por exemplo fibra, cabo CX4, etc).

Uma das features que podem ser utilizadas nesse cenário é a utilização de Link Aggregation distribuído (Ditribuited Link Aggregation) entre os equipamentos do IRF com Switches de acesso (sem configuração adicional no Link Aggregation).

Se um Switch empilhado apresentar algum problema, como por exemplo, problemas elétricos, o(s) outro(s) Switches serão capazes de permitir a continuidade do encaminhamento em Camada 2 e 3 (incluindo processos de Roteamento Dinâmico).

Porém, um dos problemas que o IRF pode trazer é quando ocorre uma quebra do Link 10G que mantém o IRF ativo, chamado de SPLIT. Cada caixa ira agir como se fosse o MASTER do IRF, duplicando alguns serviços e trazendo diversos conflitos na Rede.

Multi-Active Detection (MAD)

O MAD é uma das formas para os Switches do Stack detectarem que houve o SPLIT no IRF colocando o Equipamento com o maior Member ID do IRF (não Master) em modo Recovery, bloqueando assim todas as suas portas.

Após restaurado o Link do IRF as portas serão vinculadas novamente o Stack e ao seu estado normal de encaminhamento.

Uma das formas utilizadas pelo MAD para detecção de falha é utilizando uma extensão do protocolo LACP ( Link Aggregation). No TLV do protocolo é inserido o ID do Switch membro do IRF. Nesse caso os Switches da outra ponta do Link Aggregation, encaminham de forma transparente os LACP’s para os Switches Membros do IRF.

Como no exemplo acima, se não há SPLIT no IRF, todas mensagens serão geradas pelo ID do MASTER.

Em caso de quebra do SPLIT as mensagens serão geradas com o ID de cada equipamento e nesse caso o bloqueio das portas do não-Master.

Após detecção as portas bloqueadas do IRF pelo LACP com MAD.

Configuração

A configuração abaixo deverá ser aplicada somente no Switch com o IRF versão 2 “já ativo”.

[S7500]interface bridge-aggregation 1
!Criando a Interface Bridge-Aggregation 1
[S7500-Bridge-Aggregation1] link-aggregation mode dynamic
! Ativando a troca do protocol LACP no Link Aggregation
[S7500-Bridge-Aggregation1] mad enable
! Ativando a extensão MAD no protocol LACP
[S7500-Bridge-Aggregation1] quit
[S7500] interface gigabitethernet 1/3/0/2
[S7500-GigabitEthernet1/3/0/2] port link-aggregation group 1
!Adicionando a interface ao Link Aggregation 1
[S7500-GigabitEthernet1/3/0/2] quit
[S7500] interface gigabitethernet 2/3/0/2
[S7500-GigabitEthernet2/3/0/2] port link-aggregation group 1
!Adicionando a interface ao Link Aggregation 1
[S7500-GigabitEthernet2/3/0/2] quit

Obs: Os switches de acesso conectados ao IRF pelo Link Aggregation não necessitam da configuração do MAD. Mas o fabricante sugere que esse Switch seja um equipamento H3C.

“Requires an intermediate switch, which must be an H3C switch that supports the extended LACP.”

Comandos Display

S7500] display mad
MAD LACP enabled.

Comando display após SPLIT do IRF no Switch não Master

[S7500]display mad verbose
Current MAD status: Recovery
! Switch não-Master em modo recovery após perceber o SPLIT no IRF
! (bloqueando todas as portas)
…………………………

MAD enabled aggregation port:
Bridge-Aggregation1

Obs: o modo Recovery também permite excluímos algumas portas para que continuem em estado de encaminhamento. Há também um segundo modo de utilizar o MAD para detecção de SPLIT utilizando o Protocolo BFD.

Referência:

http://www.h3c.com/portal/Technical_Support___Documents/Technical_Documents/Switches/H3C_S5800_…

Abraços a todos

Configurando Link-Aggregation/Etherchannel entre Cisco e HPN

A agregação de diversas interfaces Ethernet (portas físicas) para a utilização de uma única porta lógica com o intuito de prover redundância e aumento de banda é uma atividade muito comum em redes de médio e grande porte .

Infelizmente o nome atribuído pelos fabricantes não segue um padrão, mas por outro lado todos possuem as mesmas funções citadas anteriormente:EtherchannelPort-channelLink-AggregationBridge-AggregationTrunk  [ nome dado antigamente para agregação de portas. (Não confundam com a utilização de interface Trunk atribuída pelos Switches Cisco e 3Com. Os Switches Procurve ainda utilizam essa terminologia) ]  e etc.

Existem algumas formas de estabelecer a agregação de portas, como por exemplo:

Manual : sem a certificação do meio por protocolos auxiliares
PAgP : Protocolo disponível em equipamentos Cisco
- LACP : Protocolo padrão IEEE,  disponível quase todos Switches gerenciáveis.

Modos de formação de um Etherchannel em Switches Cisco

Cisco(config-if)# channel-group 1 mode ?
  active Enable LACP unconditionally
  auto       Enable PAgP only if a PAgP device is detected
  desirable  Enable PAgP unconditionally
  on         Enable Etherchannel only
  passive    Enable LACP only if a LACP device is detected

No Script abaixo mostraremos a configuraçaõ de Link Aggregation/Etherchannel entre um Switch Cisco e um Switch HPN Serie-A

Switch HPN

#
interface Bridge-aggregation 1
link-aggregation mode dynamic
! Estabelecendo a conexão do Link-Aggregation utilizando o protocolo LACP
#
interface gigabitEthernet 1/0/1
port link-aggregation group 1
! Atribuindo a porta para negociar a agregação via protocolo LACP
#
interface gigabitEthernet 1/0/2
port link-aggregation group 1
! Atribuindo a porta para negociar a agregação via protocolo LACP

Switch Cisco

!
interface port-channel 1
!
interface gigabitEthernet 1/10
channel-group 1 mode active
! Estabelecendo a conexão do Etherchannel utilizando o protocolo LACP
!
interface gigabitEthernet 1/11
channel-group 1 mode active
! Estabelecendo a conexão do Etherchannel utilizando o protocolo LACP
!

Comandos Show e Display

Switch HPN

[HPN]display link aggregation verbose
Aggregation Interface: Bridge-Aggregation1
Aggregation Mode: Dynamic
Loadsharing Type: Shar
System ID: 0x8000, 3822-d6a2-5c00

Local:
  Port             Status  Priority Oper-Key  Flag
----------------------------------------------------
GE1/0/1       S       32768    8         {ACDEF}
GE1/0/2       S       32768    8         {ACDEF}

Remote:
Actor Partner Priority Oper-Key SystemID Flag
------------------------------------------------------------
GE1/0/1 516 32768 45 0x8000, 4055-39d4-8e13 {ACDEF}
GE1/0/2 517 32768 45 0x8000, 4055-39d4-8e13 {ACDEF}

Switch Cisco

Cisco#show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s – suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
Number of channel-groups in use: 2
Number of aggregators:           2
Group  Port-channel  Protocol    Ports
------+-------------+-----------+--------------------------
1     Po1(SU)        LACP      Gi1/10(P)  Gi1/11(P)

Não esqueça!!!

Sempre quando for necessario a alteração de VLANs das portas do Link Aggregation/Etherchannel faça a alteração somente na interface virtual ( port channel/ bridge-aggregation), que a configuração será replicada para as interfaces físicas.
Mantenha a consistência de VLANs nas 2 pontas do Link Aggregation/Etherchannel.

Use velocidades de portas idênticas como: interfaces 1Gb com interfaces 1G e interfaces 10Gb com interfaces 10Gb e assim por diante…  ;)

Boa semana!

Publicado originalmente em http://www.rotadefault.com.br/2012/03/29/configurando-link-aggregationetherchannel-entre-cisco-e-hpn/

Switches 3Com 4800G – Link Aggregation

Publicado originalmente em 9 DE ABRIL DE 2010

Os Switches 3Com/ HPN/ H3C oferecem a utilização de interfaces Ethernet, Fast Ethernet, GigabitEthernet ou 10 GigabitEthernet. O Link Aggregation permite a agregação de diversas portas para incrementar a velocidade do link na comunicação full duplex entre dois dispositivos.

Os link são utilizados em paralelo, provendo crescimento e expansão de banda, redundância, sem a necessidade de compra de Hardware adicional.

Por exemplo, podemos utilizar 4 portas de 100Mb em cada dispositivo para formar um link de comunicação entre 2 Switches de 400Mb. Entretanto a utlilzação de enlaces redundantes cria a possibilidade de Loops na rede. O Link Aggregation evita que os estados de bloqueios ou Loop para as portas agregadas, tratando-as como uma única interface. Para o STP, SNMP e VLANs as interfaces são tratadas como um único link lógico.

Outros nomes utilizados para o Link Aggregation são: Ethernet bonding, NIC teaming, port channel, link bundling, EtherChannel, MLT, NIC bonding, network bonding e Network Fault Tolerance (NFT).

O protocol LACP é parte da especificação 802.3ad para Link Aggregation, permitindo que Switches, Servidores negociem automaticamente o grupo de portas em diferentes fabricantes. Ambas as portas deverão oferecer suporte ao protocolo para o correto funcionamento do Link Aggregation.

Alguns modelos de Switch poderão utilizar o protocolo PAgP(Cisco) ou o modo estático das interfaces, sugerimos a utilização do protocolo LACP que é suportado pela grande maioria dos fabricantes de dispositivos para rede.

!Criando uma agregação de links com o ID 1
interface bridge-aggregation 1
! Criação da interface lógica com o ID 2 para o Link Aggregation
link-aggregation mode dynamic
! Configuração da interface lógica para troca dinâmica do protocol LACP

No Exemplo abaixo configuraremos 2 portas GigaEthernet como Link Aggregation, formando um link de 2 Gigabits

4800-1

interface Bridge-Aggregation1
link-aggregation mode dynamic
port link-type trunk
port trunk permit vlan all
#
interface GigabitEthernet1/0/31
port link-type trunk
port trunk permit vlan all
port link-aggregation group 1
#
interface GigabitEthernet1/0/32
port link-type trunk
port trunk permit vlan all
port link-aggregation group 1

4800-2

interface Bridge-Aggregation1
link-aggregation mode dynamic
port link-type trunk
port trunk permit vlan all#
interface GigabitEthernet1/0/23
port link-type trunk
port trunk permit vlan all
port link-aggregation group 1
#
interface GigabitEthernet1/0/24
port link-type trunk
port trunk permit vlan all
port link-aggregation group 1

Comandos display

[4800-1]display link-aggretion summary

Aggregation Interface Type:
BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation Aggregation Mode: S -- Static, D -- Dynamic
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Actor System ID: 0x8000, 4001-c621-8400

AGG AGG Partner ID Select Unselect
Share Interface Mode Ports Ports Type
-------------------------------------
BAGG1 D 0x8000, 0024-73cd-b900 2 0 Shar

[4800-1]displ link-aggregation verbose
Loadsharing Type:
Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected Flags: A -- LACP_Activity,
B -- LACP_Timeout, C -- Aggregation,D -- Synchronization, E -- Collecting,
F -- Distributing, G -- Defaulted, H -- Expired

Aggregation Interface: Bridge-Aggregation1Aggregation Mode: Dynamic
Loadsharing Type: Shar
System ID: 0x8000, 4001-c621-8400
Local: Port Status Priority Oper-Key Flag
--------------------------------------
GE1/0/31 S 32768 1 {ACDEF}
GE1/0/32 S 32768 1 {ACDEF}

Remote:
Actor Partner Priority Oper-Key SystemID Flag
GE1/0/23 1 32768 1 0x8000, 0024-73cd-b900 {ACDEF}
GE1/0/24 2 32768 1 0x8000, 0024-73cd-b900 {ACDEF}

Verificando o Spanning-Tree

[4800-2]displ stp brief
MSTID Port Role STP State Protection
0 Bridge-Aggregation1 ROOT FORWARDING NONE

É possível verificarmos que as interfaces são reconhecidas como uma única porta para a Topologia Spanning-Tree, de forma que as duas portas estão ativas na Topologia com redundância.

Switches 3Com 5500 – Guia rápido de Configuração!!!

Publicado originalmente em 24 DE AGOSTO DE 2010

 Olá amigos, os scripts de hoje fazem parte de um manual muito bacana repassado pelo Fabinho e o Índio da Infraero. Os Scripts seguem como um manual rápido para instalação e/ou configuração de Switches 3Com do modelo 5500 ( parte dos comandos são aceitos na maioria dos Switches da 3Com); os scripts são simples e bastante úteis!

Configurando o nome do Switch
[5500G-EI]sysname SW_Core
[SW_Core]

Configuração de Vlans
Criando uma Vlan e colocando-a um nome
[Switch] vlan 3
[Switch-vlan] name

Criando uma Vlan e colocando-a uma descrição
[Switch] vlan 3
[Switch-vlan] description

Criando uma várias vlans ao mesmo tempo
[Switch] vlan to 2 to 5

Apagando uma vlan
[Switch] undo vlan 2

Mostrando quais as vlans que existem no switch
[Switch] display vlan

Mostrando as informações de uma determinada vlan (descrição, endereço IP se houver, portas tagged e untagged)
[Switch] display vlan  2

Definindo o IP para a VLAN 2 
[Switch]interface Vlan-interface 2
[Switch]-Vlan-Interface]ip address 192.168.100.1 255.255.255.0

Configurando o default gateway
[Switch] ip route-static 0.0.0.0 0.0.0.0 192.168.100.254 (ip do gateway)

Configurações de portas
Entrando no modo de configuração de uma porta
[Switch] interface gigabit-ethernet 1/0/4

Colocando uma descrição na porta
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] description

Adicionando porta a uma vlan 
Configurando o tipo de porta
Porta ACCESS: Porta de acesso, utilizada para ligar hosts (estações, servidores, etc)
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] port link-type access

Porta TRUNK: Porta que permitirá mais de uma vlan trafegar pela porta(utilizando TAG(802.1q). Utilizada como porta de uplink, nas ligações entre switches.
[Switch] interface gigabit-ethernet 1/0/5
[Switch-GigabitEthernet] port link-type trunk

Associando uma porta access a uma vlan.
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] port access vlan 5

Removendo uma vlan de uma porta access. A porta voltará a pertencer a vlan 1 (default)
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] undo port access vlan

Associando todas as vlans a porta trunk. Desse modo, todas as vlans passarão pela porta trunk
[Switch] interface gigabit-ethernet 1/0/5
[Switch-GigabitEthernet] port trunk permit vlan all

Copiando as configurações de uma porta para outra (vlan, spanningtree, velocidade etc). Não efetua a copia das configurações de controle de broadcast
[Switch]copy configuration source gigabit-ethernet 1/0/1destination giggabit-ethernet 1/0/6

Copiando as configurações de uma porta para várias portas
[Switch]copy configuration source gigabit-ethernet 1/0/1destination giggabit-ethernet 1/0/6 to gigabit-ethernet 1/0/12

Definindo a senha do usuário ADMIN como s3nha
local-user admin
service-type telnet terminal
level 3
password cipher s3nha

Removendo os usuários default MANAGER e MONITOR
[Switch]undo local-user manager
[Switch]undo local-user monitor

Configurando e habilitando o gerenciamento SNMP com as comunidades s1ro e s1rw
[Switch]snmp-agent community read s1ro
[Switch]snmp-agent community write s1rw

Removendo as comunidades default PUBLIC e PRIVATE
[Switch]undo snmp-agent community write private
[Switch]undo snmp-agent community read public

Habilitando o spanning tree protocol (já é habilitado por padrão)
[Switch] stp enable

Configurando a versão do  rapid spanning tree protocol
[Switch] stp mode rstp 

Configurando o switch como root bridge primário do spanning tree
 O comando stp root primary configura automaticamente o valor do Bridge Priority para 0 (zero)
[Switch] stp root primary
ou
[Switch] stp priority 0

Configurando o switch como root bridge secundário do spanning tree
O comando stp root secondary configura automaticamente o valor do Bridge Priority para 4096
[Switch] stp root secondary
ou
[Switch] stp priority 4096

Criando um LINK AGGREGATION entre dois Switches. Não esquecer de executar esses procedimentos em ambos os Switches. Neste exemplo estão sendo utilizadas as portas 1/0/25 e 1/0/26 dos dois Switches.
link-aggregation group 1 mode static
#
interface GigabitEthernet 1/0/25
undo shutdown
port link-aggregation group 1
#
interface GigabitEthernet 1/0/26
undo shutdown
port link-aggregation group 1

Salvando as configurações do Switch
save

Apagando todas as configurações do Switch
reset saved-configuration
reboot

Comandos Display

Informações de uma determinada porta (velocidade, duplex, etc)

display interface GigabitEthernet 1/0/3

Mostrando um resumo de TODAS as portas
display brief interface

Mostrando quais portas do Switch são do tipo TRUNK
display port trunk

Mostrando um sumário do LINK AGGREGATION. 
display link-aggregation summary
display link-aggregation verbose

Mostrando a configuração do Switch atual
display current-configuration

Mostrando informações do Spanning Tree, quais portas estão BLOQUEADAS e quais estão em FORWARDING 
display stp brief
display stp

E vocês, possuem mais alguma sugestão de comando para os Switches da linha 5500?
Sintam-se a vontade…

Um abração! :)