Gratuitous ARP em Switches HP baseados no Comware

O Protocolo ARP é utilizado na comunicação entre dispositivos em uma Rede Ethernet da mesma Sub-rede que utilizam endereços IPv4. A principal função do ARP é a tradução de endereços IP em endereços MAC. O emissor encaminha em broadcast um pacote ARP contendo o endereço IP do outro host e espera uma resposta com um endereço MAC respectivo.

Em resumo, o ARP auxilia os computadores e Switches que utilizam endereços IPv4 (endereço lógico) ,  a encontrarem o endereço mac (endereço físico) das máquinas em redes Ethernet.

Todo endereço da camada de rede, precisa do mapeamento do endereço da camada de enlace.

Assim,  todos os equipamentos de rede montam uma tabela ARP dinâmica (em redes LAN), que é atualizada de tempos em tempos (o tempo pode variar dependendo do Sistema Operacional) caso alguma máquina troque de IP, ou aprenda um endereço “velho” via DHCP.

Segue abaixo a saída da tabela ARP de uma máquina rodando windows 7.

C:\Users\comutadores>arp -a
Interface: 192.168.99.104 --- 0x10
  Internet Address      Physical Address      Type
  192.168.99.1          14-d6-4d-7e-f7-d8     dynamic
  192.168.99.100        10-3b-59-c7-62-34     dynamic
  192.168.99.102        e8-8d-28-f2-60-7b     dynamic
  192.168.99.255        ff-ff-ff-ff-ff-ff     static
  224.0.0.22            01-00-5e-00-00-16     static
  224.0.0.251           01-00-5e-00-00-fb     static
  224.0.0.252           01-00-5e-00-00-fc     static
  239.255.255.250       01-00-5e-7f-ff-fa     static
  255.255.255.255       ff-ff-ff-ff-ff-ff     static

Uma das  funções do protocolo ARP é o Gratuitous ARP, que permite o envio de requisição ou resposta (contendo o mapeamento endereço IP + endereço MAC) mesmo quando não é solicitado.

O gratuitous ARP é uma mensagem enviada geralmente para atualizar a tabela ARP.

Por exemplo, imagine que todas as máquinas de uma rede possuam como gateway um Switch de Distribuição que precisa ser substituído por um novo equipamento mais robusto e moderno. Agora, imagine que essa migração deva ocorrer de maneira quase que imperceptível por inúmeras restrições. O novo Switch é então conectado a todos os outros Switches da rede, incluindo o Switch legado, e cada vez que uma interface do Switch legado é colocada em shutdown (desligada), a mesma é configurada no Switch novo.

Pense que, uma vez que o gateway é movido para outro equipamento (com o mesmo IP) o endereço mac  deverá mudar…

A configuração do gratuitous ARP deverá auxiliar nessa questão, com o novo equipamento enviando a atualização do endereço IP + MAC para todos os dispositivos da rede.

interface Vlan-interface1
 ip address 192.168.99.1 255.255.255.0
 arp send-gratuitous-arp 

Após a certificação e sucesso da migração, o comando poderá ser removido da interface vlan.

[Switch-Vlan-interface1]undo arp send-gratuitous-arp

Espero ter ajudado 😉

Dúvidas, deixe um comentário!

Comando “default interface” em Switches HPN

O Adilson Florentino publicou em seu blog  Netfinders Brasil sobre a utilização do comando “default interface” dentro de uma porta Ethernet  para zerar a configuração da interface em Roteadores e Switches Cisco http://netfindersbrasil.blogspot.com/2012/10/como-remover-as-configuracoes-de-uma.html

O comando é bastante útil em ambientes de Data Center ou onde se é necessário a troca de toda configuração de uma porta sem ter que descobrir qual o comando “no” ou “undo” de cada feature.

As últimas atualizações para o Comware 5 dos Switches HPN atribuiu o comando “default” para ser aplicado dentro de uma porta para zerar a configuração da mesma.

Segue abaixo a configuração ( o comando foi testado em Switches 7500 com o Release 6626P02)

 

[HP-GigabitEthernet1/0/1] disp this
! verificando a configuração antiga da porta
#
interface GigabitEthernet1/0/1
port link-mode bridge
port link-type trunk
port trunk permit vlan all
#
return

[HP-GigabitEthernet1/0/1]default
This command will restore the default settings. Continue? [Y/N]:y
! Aplicando o comando default na interface
!
[HP-GigabitEthernet1/0/1]disp this
#
interface GigabitEthernet1/0/1
port link-mode bridge
#

Até logo 😉

Switches HPN – Configurando Sflow

Sflow(RFC 3176) é um protocolo que permite a coleta de estatísticas de tráfego de rede baseado em  amostras (formatadas) enviadas para um servidor que possa ler as informações. Esse tipo de formato possui uma vantagem ao espelhamento de porta por não encaminhar toda a mensagem “bruta” para o servidor. O protocolo exibe informações referente aos protocolos de rede. A feature é similar ao Netflow e não é proprietária.

A configuração do Sflow envolve 2 componentes:

  • Sflow Agent:  função atribuída a Switches , Roteadores, Access-Point que coletam as informações dos pacotes transmitidos e encaminham as amostras.
  • Sflow Collector: função atribuída de analizar as informações de cada Sflow Agent criando um modelo estatístico para exibição das informações.

Com base em uma taxa de amostragem definidos, tanto para o Agente ou para completar uma única interface, 1 de N pacotes são capturados e enviados para um Servidor de coleta. Este tipo de amostragem não fornece um resultado 100% de precisão na análise, mas que faz prever um resultado com precisão quantificáveis.

Os dados da amostra é enviado em UDP para o coletor sFlow. A porta padrão é 6343. A falta de confiabilidade no transporte UDP não afeta significativamente a precisão das medidas obtidas a partir de um agente sFlow. Se as amostras de contador são perdidas , a  perda de amostras de fluxo de pacotes é uma ligeira redução na taxa de amostragem efetiva.

A carga contém o datagrama UDP sFlow. Cada datagrama fornece informações sobre a versão sFlow, endereço de seu agente, IP de origem, número sequencial, quantas amostras ele contém e, geralmente, até 10 amostras de fluxo ou contra-amostras.

A técnia de amostragem pode ser utilizada com o seguinte critério

  • Flow sampling: Baseado na amostra de pacotes, usado para obter informações do conteúdo do pacote como protocolos e etc.
  • Counter sampling: Baseado na amostra de tempo,usado para obter estatisticas de interfaces.

Configurando Sflow em Switches com Comware

Para especificar o endereço de origem para envio de pacotes Sflow.
[Switch] sflow agent [ip <ip_address> | ipv6 <ip_address>]


Endereço e grupo do Servidor de coleta (podemos encaminhar para mais de um Servidor)

[Switch] sflow collector <collector_id> ip <ip_address>
[Switch] sflow collector <collector_id> ipv6 <ip_address>


Interface para coleta de informações e amostragem

[Switch] interface <interface_type/interface_number>
[Switch-<interface>] sflow sampling-rate <rate>
[Switch-<interface>] sflow flow collector <collector_id>
[Switch-<interface>] sflow counter interval <interval_time>
[Switch-<interface>] sflow counter collector <collector_id>

Exibição de coleta em um Servidor Sflow

Segue o exemplo da Configuração encamimhada pelo Marcos Schimidt de um Switch 4800G como Agente e um Servidor Solarwinds como Coletor ( a sintaxe pode variar dependendo da familia do Switch):

 

Configuração do switch
 sflow agent ip 172.16.0.254
 sflow collector ip 172.16.1.4
 sflow interval 60

Configuração da Interface
interface GigabitEthernet2/0/7
 sflow enable inbound
 sflow enable outbound
 sflow sampling-rate 100000

Referência

http://pt.wikipedia.org/wiki/SFlow

http://www.sflow.org/

Switches 3Com 7900 – Aplicando ACLs em VLANs

Para configurarmos as listas de acesso (ACL) e aplicarmos a uma interface física ou VLAN no Switch 7900 é necessário o vínculo a uma politica de QoS, aplicando a ACL indiretamente à Interface ou VLAN.

No script abaixo iremos negar a rede 192.168.1.0/24 de comunicar-se com a rede 172.31.1.0/24.

Configuração

vlan 192
vlan 172
#
interface Vlan-interface192

ip address 192.168.1.1 255.255.255.0
#
interface Vlan-interface172
ip address 172.31.1.1 255.255.255.0
#
acl number 3001
!criando a ACL avançada 3001
rule 0 deny ip source 192.168.1.0 0.0.0.255 destination 172.31.1.0 0.0.0.255
! regra 0 irá negar a origem 192.168.1.0/24 (é obrigatório a utilização de máscara curinga) de comunicar com a rede 172.31.1.0/24. Nesse caso poderíamos ter mais de uma regra!!
quit
traffic classifier rede_192 operator and
! Criando a classificação de tráfego com o nome rede_192
if-match acl 3001
! Efetuando match na ACL 3001
quit
#
traffic behavior rede_172
! Criando o comportamento com o nome rede_172

filter deny
! Criando o filtro negar (deny)
quit
#
qos policy proibe_rede_192_172

!Criando a policy com nome proibe_rede_192_172

classifier rede_192 behavior rede_172
! vinculo do classifier rede_192(ACL) com o behavior rede_172 (deny)
quit
qos vlan-policy proibe_192_172 vlan 192 inbound
! aplicando a politica de QoS na VLAN 192, proibindo a rede 192.168.1.0/24 de comunicar-se com a rede 172.31.1.0/24 no sentido de entrada do Switch

Para aplicarmos a sintaxe a uma porta física (GigabitEthernet) a sintaxe seria:

interface GigabitEthernet 2/0/9
qos apply policy proibe_192_172 inbound

A utilização do script acima para filtro de pacotes negará todas as regras que forem explicitamente escritas, nesse caso permitirá a comunicação da rede 192.168.1.0/24 com qualquer outra rede que não tenha referência nas linhas da ACL 3001 (não importando o permit ou deny da ACL).

Até logo 🙂