Comandos secretos para os Switches HP 1950

Galera, segue abaixo a dica para liberar a configuração de algumas funcionalidades via CLI para os Switches HP 1950.

O comando “xtd-cli-mode” no modo user-view libera a configuração “avançada” do Switch via CLI.

Após digitar o comando aparecerá a imagem de warning abaixo. A senha é: foes-bent-pile-atom-ship Continue reading

Comandos Secretos para os Switches HP 1920

Essa semana recebi uma dica bem bacana do Leonardo Soares para a administração dos Switches HP 1920. Foi publicada nos comentários do post: http://www.comutadores.com.br/comandos-secretos-para-os-switches-3com-baseline-e-hp-v1910/

Ainda não pude testar a dica em equipamentos em produção, então tomem todo o cuidado antes de executar o procedimento abaixo (prestem bastante atenção no warning exibido após a execução do comando) 😉 . De resto, assim como o post anterior curtam e simulem a dica em laboratório e depois comentem aqui no blog!!!

O comando “_cmdline-mode on” no modo user-view libera a configuração “avançada” do Switch via CLI.

<HP 1920G Switch>_cmdline-mode on

Após digitar o comando aparecerá a imagem de warning abaixo. A senha é: Jinhua1920unauthorized

HP 1920 cmdline-mode on

Ps: Há também referências do comando no fórum: http://www.reddit.com/r/networking/comments/2nl4g9/hp_1920_cmdlinemode_password/

abração

 

Dicionário de comandos HP Networking comparados com Cisco CLI – versão 3

A HP Network disponibilizou a terceira versão do guia de referência de comandos como um dicionário para comparação de features dos Switches HP, H3C/3Com (Comware), HP Provision e IOS Cisco. Dessa vez foram adicionados comandos para o Comware 7.

Dicionario HPN v3

Para visualização ou download baixe do site da HP Press https://h30590.www3.hp.com/product/HP+Networking+and+Cisco+CLI+Reference+Guide+-+Version+3-PDF-15901

Se o link estiver quebrado, deixe um comentário…

Abração

Dicas para usar o “display current-configuration”

Dicas para usar o “display current-configuration”

Navegando pela internet descobri em alguns blogs dicas interessantes para visualizar a configuração em equipamentos com o Comware (Switches e Roteadores 3Com, H3C e HPN). Como no site: http://configureterminal.com/hp-comware/

Fiz uma pequena adaptação em português para alguns comandos que podem ser bastante úteis.

 display this

O comando display this exibe a configuração baseado na “view” de acesso. Por exemplo, se estivermos aplicando a configuração em uma interface GigabitEthernet, o comando display this exibirá as configurações aplicadas na interface.

[HP]
[HP]interface  GigabitEthernet 1/0/1
[HP-Ethernet1/0/1]display this
#
interface GigabitEthernet1/0/1
 port link-mode route
 ip address 159.63.229.149 255.255.255.252
#

display current-configuration

O comando display current-configuration exibe  a configuração aplicada corrente na “memória RAM” do equipamento. É possível extrair algumas “dicas” do comando visualizando as opções:

[HP]disp current-configuration ?
  by-linenum     Display configuration with line number
  configuration  The pre-positive and post-positive configuration information
  exclude        Display current configuration without specified module
  interface      The interface configuration information
  |              Matching output

by-linenum

O “sufixo” by-lineum permite exibir a configuração numerada, como por exemplo, facilitando o troubleshooting remoto para identificar a linha que deseja demonstrar ao outro técnico.

[HP]display current-configuration by-linenum
    1:  #
    2:   version 5.20, Release 9101
    3:  #
    4:   sysname SW1
    5:  #
    6:   undo voice vlan mac-address 00e0-bb00-0000
    7:  #
    8:   domain default enable system
    9:  #
   10:   ip unreachables enable
   11:  #
   12:   lldp enable
   13:  #
   14:   rpr mac-address timer aging 100
   15:  #
   16:  vlan 1
   17:  #
   18:  domain system
   19:   access-limit disable
  ---- More ----

configuration

O “sufixo” configuration permite exibir a configuração de determinado processo…

[HP]disp current-configuration configuration ?
  attack-defense-policy  Display Attack-defense-policy configuration
  bgp                    Display Bgp configuration
  by-linenum             Display configuration with line number
  isp                    Display Isp configuration
  post-system            Display Post-system configuration
  route-policy           Display Route-policy configuration
  system                 Display System configuration
  ugroup                 Display Ugroup configuration
  user-interface         Display User-interface configuration
  wlan-rrm               Display Wlan-rrm configuration
  |                      Matching output

[SW1]display  current-configuration configuration bgp
#
bgp 65012
 import-route direct
 undo synchronization
 peer 172.16.0.2 as-number 65000
 peer 172.16.0.2 advertise-community
 peer 172.16.0.2 substitute-as
#
return

Pipe |

A utilização do “|” permite selecionarmos apenas parte da configuração para ser exibida , incluindo a utilização de algumas expressões regulares. O “include” exibe apenas parte da configuração que contêm a palavra selecionada, o “begin” exibe a configuração a partir da primeira palavra encontrada e o “exclude” exibe a configuração sem a palavra selecionada.

[HP]display current-configuration | ?
  begin    Begin with the line that matches
  exclude  Match the character strings excluding the regular expression
  include  Match the character strings including with the regular expression

No exemplo abaixo, utilizaremos o include para visualizar a parte da configuração que inclua a palavra “face”

[HP]display current-configuration | include face
interface NULL0
interface GigabitEthernet1/0/1
interface GigabitEthernet1/0/2
interface GigabitEthernet1/0/3
interface GigabitEthernet1/0/4
interface GigabitEthernet1/0/5
interface GigabitEthernet1/0/6
interface GigabitEthernet1/0/7
interface GigabitEthernet1/0/8
interface GigabitEthernet1/0/9
interface GigabitEthernet1/0/10
interface GigabitEthernet1/0/11
interface GigabitEthernet1/0/12
interface GigabitEthernet1/0/13
interface GigabitEthernet1/0/14
interface GigabitEthernet1/0/15
interface GigabitEthernet1/0/16
interface GigabitEthernet1/0/17
interface GigabitEthernet1/0/18
interface GigabitEthernet1/0/19
interface GigabitEthernet1/0/20
interface GigabitEthernet1/0/21
interface GigabitEthernet1/0/22
  ---- More ----

[HP]display  current-configuration | include ^v
vlan 1
vlan 2 to 4
vlan 10
vlan 20
vlan 30
vlan 40

Outros inumeros exemplos podem ser utilizados com expressões regulares para filtro de exibição da configuração.

A utilização do “begin” exibe a configuração a partir da primeira palavra encontrada (parte da palavra).

[HP]display current-configuration | begin Ten
interface Ten-GigabitEthernet1/0/25
 port link-type trunk
 port trunk permit vlan 1 20
#
interface Ten-GigabitEthernet1/0/26
#
interface Ten-GigabitEthernet1/0/27
#
interface Ten-GigabitEthernet1/0/28
#
user-interface aux 0
user-interface vty 0 15
#
return
[HP]

outros comandos interessantes para visualizar a configuração são os caracteres “/” or “+” or “-“:

/ o mesmo que “begin”
+ o mesmo que “include”
– o mesmo que “exclude”

O primeiro primeiro passo é digitar o ” display current”

[HP]display current-configuration
#
 version 5.20, Release 1110P05
#
 sysname HP
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
#
 domain default enable system
#
 telnet server enable
#
vlan 1
#
radius scheme system
 server-type extended
 primary authentication 127.0.0.1 1645
 primary accounting 127.0.0.1 1646
 user-name-format without-domain
#
domain system
 access-limit disable
  ---- More ----

Quando o “—More—” aparecer para a paginação da configuração, digite a tecla “/” mais a palavra para filtro da configuração. Em nosso exemplo usaremos “/Ten”:

/Ten
filtering...
interface Ten-GigabitEthernet1/0/25
 port link-type trunk
 port trunk permit vlan 1 10
#
interface Ten-GigabitEthernet1/0/26
#
interface Ten-GigabitEthernet1/0/27
#
interface Ten-GigabitEthernet1/0/28
#
ospf 1
 area 0.0.0.0
  network 10.1.1.1 0.0.0.0
  network 10.1.2.1 0.0.0.0
#
 load xml-configuration
#
user-interface aux 0
user-interface vty 0 15
#
return
[HP]

Utilize o “-” para não exibir parte da da configuração. Em nosso exemplo, “net”:

-net

filtering...
#
interface NULL0
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
  ---- More ----

Até logo! 😉

Dica: Comando “logging synchronous” para o HPN (Comware)

Para aqueles que estão acostumados com o comando “logging synchronous” no IOS existe a opção “info-center synchronous” para o Comware

 [4800G]info-center synchronous
% Info-center synchronous output is on

Segue o output com o commando habilitado:

[4800G]interface GigabitEthernet 1/0/
%Apr 26 09:25:32:201 2000 4800G IFNET/4/LINK UPDOWN:
GigabitEthernet1/0/2: link status is DOWN
[4800G]interface GigabitEthernet 1/0/

Segue o output com o commando desabiiltado (percebam o comando “em digitação” fica oculto e assim comprometendo a configuração, tornando suceptível a erros:

[4800G]interface GigabitEthernet 1/0/
%Apr 26 10:42:36:371 2000 4800G IFNET/4/LINK UPDOWN:
GigabitEthernet1/0/2: link status is UP

Abraços a todos

Comandos Secretos para os Switches 3Com Baseline e HP v1910

Essa semana  recebi uma dica bem bacana do Dilson Augusto para a administração de Switches 3Com Baseline.

Pesquisando melhor na Internet sobre o procedimento, vi que há outros modelos como o Switch HP v1910 que também aceitam o “comando secreto” para liberar a configuração de diversas features via CLI.

Ainda não pude testar a dica infomada em equipamentos em produção, então tomem todo o cuidado antes de executar o procedimento abaixo (prestem bastante atenção no warning exibido após a execução do comando) 😉 . De resto, curtam e simulem a dica em laboratório e comentem aqui no blog!!!

Obrigado Dilson. Segue abaixo o texto:

 

Boa tarde Diego,

Gostaria de compartilhar algo que descobri recentemente depois de muito tempo de pesquisa.
A linha Baseline Switch da HP é conhecida por ter seu gerenciamento console bem “restrito”, para não dizer simplório…

<3Com Baseline Switch>?
User view commands:
initialize  Delete the startup configuration file and reboot system
ipsetup     Specify the IP address of the VLAN interface 1
password    Specify password of local user
ping        Ping function
quit        Exit from current command view
reboot      Reboot system
summary     Display summary information of the device.
upgrade     Upgrade the system boot file or the Boot ROM program

<3Com Baseline Switch>

Então… depois de muita pesquisa, acabei encontrando um comando mais que bacana… Se tiver um switch desses a mão, testa aí:

<3Com Baseline Switch>_cmdline-mode on

Vai apresentar a mensagem:

All commands can be displayed and executed. Continue? [Y/N]Y
Please input password:******
Warning: Now you enter an all-command mode for developer's testing, 
some commands may affect operation by wrong use, please carefully use 
it with our engineer's direction.

A senha é: 512900

<3Com Baseline Switch>?
User view commands:
archive        Specify archive settings
backup         Backup next startup-configuration file to TFTP server
boot-loader    Set boot loader
bootrom        Update/read/backup/restore bootrom
cd             Change current directory
clock          Specify the system clock
cluster        Run cluster command
copy           Copy from one file to another
debugging      Enable system debugging functions
delete         Delete a file
dir            List files on a file system
display        Display current system information
fixdisk        Recover lost chains in storage device
format         Format the device
free           Clear user terminal interface
ftp            Open FTP connection
initialize     Delete the startup configuration file and reboot system
ipsetup        Specify the IP address of the VLAN interface 1
lock           Lock current user terminal interface
logfile        Specify log file configuration
mkdir          Create a new directory
more           Display the contents of a file
move           Move the file
ntdp           Run NTDP commands
password       Specify password of local user
ping           Ping function
pwd            Display current working directory
quit           Exit from current command view
reboot         Reboot system
rename         Rename a file or directory
reset          Reset operation
restore        Restore next startup-configuration file from TFTP server
rmdir          Remove an existing directory
save           Save current configuration
schedule       Schedule system task
screen-length  Specify the lines displayed on one screen
send           Send information to other user terminal interface
sftp           Establish one SFTP connection
ssh2           Establish a secure shell client connection
stack          Switch stack system
startup        Specify system startup parameters
summary        Display summary information of the device.
super          Set the current user priority level
system-view    Enter the System View
telnet         Establish one TELNET connection
terminal       Set the terminal line characteristics
tftp           Open TFTP connection
tracert        Trace route function
undelete       Recover a deleted file
undo           Cancel current setting
upgrade        Upgrade the system boot file or the Boot ROM program

<3Com Baseline Switch>

<3Com Baseline Switch>system-view
System View: return to User View with Ctrl+Z.

[3Com Baseline Switch]display cpu-usage history
100%|
95%|
90%|
85%|
80%|
75%|
70%|
65%|
60%|
55%|
50%|
45%|
40%|
35%|
30%|
25%|
20%|             #
15%|             #
10%|             #
5% |#            #
------------------------------------------------------------
10        20        30        40        50        60  (minutes)
cpu-usage last 60 minutes(SYSTEM)

[3Com Baseline Switch]

Caso queira compartilhar no blog, sinta-se a vontade… pode vir a auxiliar diversos administradores de rede.

Referências

Segue o link como referência o Switch HP v1910
http://glazenbakje.wordpress.com/2012/08/21/hp-v1910-secret-commando-list-how-to-enable-it/

Segue a saída publicada no forum da HP para o Switch 3Com 2952
http://h30499.www3.hp.com/hpeb/attachments/hpeb/itrc-269/30228/1/user_mode_cli.txt