Blog Archives

Utilizando sub-interfaces nos Rotadores HP MSR’s, 8800 e 6600

A utilização de sub-interfaces em Roteadores permite a multiplexação/divisão de um único link físico em múltiplos links lógicos.

Como exemplo nos cenários abaixo, o Roteador poderá atuar tanto como Gateway para roteamento entre as VLANs X e Y no cenário A para casos em que o Roteador possua possua poucas portas disponíveis, por exemplo; como também em casos para rotear pacotes sem que as redes X e Y tenham acesso uma a outra com a utilização de VRFs , chamadas de VPN-Instance nos Roteadores HPN ( para o cenário B).

Subinterfaces no MSR

Para configurar uam sub-interface em um Roteador 8800, utilize o “.”(ponto) + o id da VLAN após o numero indicativo da porta em uma interface no modo routed.

[Roteador]interface Ten-GigabitEthernet 2/1/1.?

#

Segue um exemplo da configuração para o cenário A

interface Ten-GigabitEthernet 2/1/1.30
description VLAN_X
ip adress 192.168.20.1 255.255.255.0
quit
#
interface Ten-GigabitEthernet 2/1/1.31
description VLAN_Y
ip adress 192.168.30.1 255.255.255.0
quit
#

Em alguns modelos de Roteadores como a Serie 6600 será necessário configurar o VLAN ID, com a configuração do vlan-type dot1q vid [id da vlan] dentro da sub-interface, isto em razão do SO do Roteador não entender que é explicito o ID da VLAN no número da sub-interface. Roteadores Cisco funcionam da mesma forma.

interface Ten-GigabitEthernet 2/1/1.30
description VLAN_X
ip adress 192.168.20.1 255.255.255.0
vlan-type dot1q vid 30
quit
#
interface Ten-GigabitEthernet 2/1/1.31
description VLAN_Y
ip adress 192.168.30.1 255.255.255.0
vlan-type dot1q vid 31
quit
#

… então como as sub-interfaces estão diretamente conectadas, as rotas são adicionadas à tabela de roteamento, o equipamento fará  o roteamento de pacotes.

Já para o segundo cenário, a mesma configuração é válida, bastando apenas configurar a sub-interface com a configuração da vpn-instance antes de configurar o endereço IP.

#Criando a VRF para o cliente X
ip vpn-instance clientex
 route-distinguisher 65000:1
 vpn-target 65000:1 export-extcommunity
 vpn-target 65000:1 import-extcommunity
#
#Criando a VRF para o cliente Y
ip vpn-instance clientey
 route-distinguisher 65000:2
 vpn-target 65000:2 export-extcommunity
 vpn-target 65000:2 import-extcommunity
#
interface Ten-GigabitEthernet 2/1/1.30
description 
ip binding vpn-instance clientex
ip adress 192.168.20.1 255.255.255.0
quit
#
interface Ten-GigabitEthernet 2/1/1.31
description VLAN_Y
ip binding vpn-instance clientey
ip adress 192.168.30.1 255.255.255.0
quit
#
# as configurações do compartimento WAN de cada VRF foram omitidas
#

 obs: Uma rede não será roteada para outra a menos que estejam na mesma VRF.

Já para a configuração do Switch basta apenas configurar a interface como trunk permitindo as vlans correspondente. Se o Roteador for da Serie 6600 a configuração vlan-type dot1q vid … também será necessária (para o segundo cenário).

Um grande abraço e a Paz! :)

Video: VLANs – Configuração de Porta Access, Hybrid e Trunk para Switches HPN, 3Com e H3C

A publicação de conteúdo em vídeo, sempre foi um dos meus desejos para os assuntos já abordados aqui no blog. Nesse primeiro video, abordamos a configuração de portas Access, Hybrid e Trunk para Switches HPN, 3Com e H3C..

Sugestões e Comentários serão bem vindos. Espero que a gravação possa ser útil! ;)


Abração a todos!

Switches 3Com 4800G – GVRP uma solução ao VTP

Publicado originalmente em 17 DE JUNHO DE 2011

Em diversos treinamentos e projetos recebo perguntas de alunos e clientes sobre a utilização de protocolos com função similar ao VTP da Cisco. Os Switches 3Com/HP trabalham com o protocolo aberto para registro dinâmico de VLANs chamado GVRP.

A utilização do GVRP é bem simples e pode trabalhar resumidamente nos 3 seguintes modos:

  • Normal: permite que o Switch envie e receba mensagens para aprendizado de VLANs dinâmicas.
  • Fixed: permite que o Switch envie mensagens GVRP com as VLANs geradas localmente, mas o dispositivo não insere na tabela dinâmica as VLANs anunciadas por outros Switches.
  • Forbidden: permite que o Switch ignore as mensagens do protocolo.

Diferente do VTP, devemos ativar o processo globalmente no Switch e configurar nas interfaces Trunk qual o perfil que ela terá (Normal, Fixed ou Forbidden).

No exemplo abaixo configuramos o GVRP em todas as interfaces Trunk para consistência de VLANs na topologia e criamos as VLANs 4 e 5 no SWA.


Ao visualizarmos as VLANs dinamicas no SWC, veremos a saída na tabela:

[SWC] display vlan dynamic
Total 2 dynamic VLAN exist(s).
The following dynamic VLANs exist:
4-5

Configuração

A configuração do GVRP é bem simples:

#
gvrp
! Habilitando o GVRP globalmente no Switch
#
interface GigabitEthernet1/0/1
port link-type trunk
port trunk permit vlan all
gvrp
! Habilitando a(s) interface(s) trunk(s) para propagação das mensagens GVRP
 (por default as interfaces funcionam no modo Normal).

Com a configuração dos comandos acima em todos os Switches é possível verificar quais VLANs estão configuradas localmente ou aprendidas de forma dinâmica utilizando os comandos “display vlan static” ou “display vlan dynamic”:

 

[SWB]display vlan static
Total 1 static VLAN exist(s).
The following static VLANs exist:
1(default),

[SWB]display vlan dynamic
Total 4 dynamic VLAN exist(s).
The following dynamic VLANs exist:
3-4,

Para habilitar os modos forbidden ou fixed, utilize os comandos abaixo interface-view:

[SWC-GigabitEthernet1/0/1]gvrp registration ?
fixed Fixed type
forbidden Forbidden type
normal Normal type

Como recomendação, sugerimos a criação de VLANs somente no Switch Core com as interfaces Trunk em modo forbidden para proteção e controle de tráfego em caso de erro na configuração dos Switches de acesso.

Obs: Lembrando que ao criamos ou deletarmos determinada VLAN (estática, não aprendida via GVRP) no Switch em modo normal e fixed, a informação será replicada a todos dispositivos da rede, caso nenhum Switch possua a VLAN estática e a mesma for deletada, a VLAN será apagada em todos equipamentos!

Até logo!

 

 

 

VLAN – Trunk utilizando 802.1q (dot1q)

Publicado originalmente em 15 DE OUTUBRO DE 2010

A utilização de VLAN (Virtual Local Area Network) permite que uma rede física seja dividida em várias redes lógicas dentro de um Switch. A partir da utilização de VLANs, uma estação não é capaz de comunicar-se com estações que não são pertencentes a mesma VLAN (para isto, é necessário a utilização de uma sub-rede por VLAN e que o tráfego passe primeiro por um roteador para chegar a outra rede [ ou utilizando um Switch Multicamada para efetuar o Roteamento]).

Se não utilizássemos uma interface como Trunk e precisássemos passar o tráfego da VLAN para o outro Switch, seria necessário a passagem de um cabo de cada VLAN para o outro dispositivo, como no exemplo abaixo.

Como a maioria dos Switches possui entre 24 e 48 portas a solução ficaria inviável , inutilizando a maioria das portas para conexões entre os dispositivos.

O protocolo IEEE 802.1q permite utilizarmos apenas um cabo na comunicação entre os Switches, marcando cada Frame (quadro) com o ID de cada VLAN.

A marcação efetuada (chamada de TAG) adiciona aos quadros Ethernet 4 bytes no frame original e calculam um novo valor de checagem de erro para o campo FCS.

Dos valores contidos dentro do campo TAG o numero da VLAN é adicionado ao campo VLAN id permitindo a identificação da VLAN entre os Switches.

Uma observação relevante é a utilização do campo Priority (também dentro da TAG) para função de QoS em camada 2 para Ethernet, chamado de 802.1p ou CoS (Class of Services), permitindo a diferenciação de classes de serviços por Switches sem a necessidade de leitura do campo IP.

Já a comunicação entre computadores no mesmo Switch que pertencem a mesma VLAN não são “tagueadas” (untagged). Muitas placas de rede para PC’s e impressoras não são compativéis com o protocolo 802.1Q e ao receberem um frame tagged, não compreenderão o TAG de VLAN e descartarão a informação.
Os Switches que recebem na sua interface Trunk um frame com TAG, irão remover o campo e entregar o quadro ao destino sem a marcação.

A regra é bem simples para a maioria dos casos (salvo exceções):

  • Para comunicação entre Switches, configure as interfaces como Trunk ( Tagged)
  • Para comunicação entre Switches e hosts, servidores, impressoras; configure as interfaces como Access (untagged) com o ID da VLAN

Configuração

Para a maioria dos Switches H3C/3Com configure as portas como trunk da seguinte maneira:

interface GigabitEthernet 1/0/x
! acesso a interface GigabitEthernet
port link-type trunk
! configuração da interface como trunk (frames encaminhados como tagged)
port trunk permit vlan all
! configuração da porta permitindo todas as VLANs no trunk

Porta de acesso

interface GigabitEthernet 1/0/x
! acesso a interface GigabitEthernet
port link-type access
! configuração da interface como acesso (frames encaminhados como untagged)
port access vlan 2
! configuração da porta na vlan 2

Para retornar a porta de alguma VLAN para a VLAN 1, digite o comando undo port access vlan dentro da interface física.

Obs: Por default os frames da VLAN 1 não são encaminhados com TAG dentro do Trunk.

Abraços a todos!!!

 

 

 

 

Switches 3Com 5500 – Guia rápido de Configuração!!!

Publicado originalmente em 24 DE AGOSTO DE 2010

 Olá amigos, os scripts de hoje fazem parte de um manual muito bacana repassado pelo Fabinho e o Índio da Infraero. Os Scripts seguem como um manual rápido para instalação e/ou configuração de Switches 3Com do modelo 5500 ( parte dos comandos são aceitos na maioria dos Switches da 3Com); os scripts são simples e bastante úteis!

Configurando o nome do Switch
[5500G-EI]sysname SW_Core
[SW_Core]

Configuração de Vlans
Criando uma Vlan e colocando-a um nome
[Switch] vlan 3
[Switch-vlan] name

Criando uma Vlan e colocando-a uma descrição
[Switch] vlan 3
[Switch-vlan] description

Criando uma várias vlans ao mesmo tempo
[Switch] vlan to 2 to 5

Apagando uma vlan
[Switch] undo vlan 2

Mostrando quais as vlans que existem no switch
[Switch] display vlan

Mostrando as informações de uma determinada vlan (descrição, endereço IP se houver, portas tagged e untagged)
[Switch] display vlan  2

Definindo o IP para a VLAN 2 
[Switch]interface Vlan-interface 2
[Switch]-Vlan-Interface]ip address 192.168.100.1 255.255.255.0

Configurando o default gateway
[Switch] ip route-static 0.0.0.0 0.0.0.0 192.168.100.254 (ip do gateway)

Configurações de portas
Entrando no modo de configuração de uma porta
[Switch] interface gigabit-ethernet 1/0/4

Colocando uma descrição na porta
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] description

Adicionando porta a uma vlan 
Configurando o tipo de porta
Porta ACCESS: Porta de acesso, utilizada para ligar hosts (estações, servidores, etc)
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] port link-type access

Porta TRUNK: Porta que permitirá mais de uma vlan trafegar pela porta(utilizando TAG(802.1q). Utilizada como porta de uplink, nas ligações entre switches.
[Switch] interface gigabit-ethernet 1/0/5
[Switch-GigabitEthernet] port link-type trunk

Associando uma porta access a uma vlan.
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] port access vlan 5

Removendo uma vlan de uma porta access. A porta voltará a pertencer a vlan 1 (default)
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] undo port access vlan

Associando todas as vlans a porta trunk. Desse modo, todas as vlans passarão pela porta trunk
[Switch] interface gigabit-ethernet 1/0/5
[Switch-GigabitEthernet] port trunk permit vlan all

Copiando as configurações de uma porta para outra (vlan, spanningtree, velocidade etc). Não efetua a copia das configurações de controle de broadcast
[Switch]copy configuration source gigabit-ethernet 1/0/1destination giggabit-ethernet 1/0/6

Copiando as configurações de uma porta para várias portas
[Switch]copy configuration source gigabit-ethernet 1/0/1destination giggabit-ethernet 1/0/6 to gigabit-ethernet 1/0/12

Definindo a senha do usuário ADMIN como s3nha
local-user admin
service-type telnet terminal
level 3
password cipher s3nha

Removendo os usuários default MANAGER e MONITOR
[Switch]undo local-user manager
[Switch]undo local-user monitor

Configurando e habilitando o gerenciamento SNMP com as comunidades s1ro e s1rw
[Switch]snmp-agent community read s1ro
[Switch]snmp-agent community write s1rw

Removendo as comunidades default PUBLIC e PRIVATE
[Switch]undo snmp-agent community write private
[Switch]undo snmp-agent community read public

Habilitando o spanning tree protocol (já é habilitado por padrão)
[Switch] stp enable

Configurando a versão do  rapid spanning tree protocol
[Switch] stp mode rstp 

Configurando o switch como root bridge primário do spanning tree
 O comando stp root primary configura automaticamente o valor do Bridge Priority para 0 (zero)
[Switch] stp root primary
ou
[Switch] stp priority 0

Configurando o switch como root bridge secundário do spanning tree
O comando stp root secondary configura automaticamente o valor do Bridge Priority para 4096
[Switch] stp root secondary
ou
[Switch] stp priority 4096

Criando um LINK AGGREGATION entre dois Switches. Não esquecer de executar esses procedimentos em ambos os Switches. Neste exemplo estão sendo utilizadas as portas 1/0/25 e 1/0/26 dos dois Switches.
link-aggregation group 1 mode static
#
interface GigabitEthernet 1/0/25
undo shutdown
port link-aggregation group 1
#
interface GigabitEthernet 1/0/26
undo shutdown
port link-aggregation group 1

Salvando as configurações do Switch
save

Apagando todas as configurações do Switch
reset saved-configuration
reboot

Comandos Display

Informações de uma determinada porta (velocidade, duplex, etc)

display interface GigabitEthernet 1/0/3

Mostrando um resumo de TODAS as portas
display brief interface

Mostrando quais portas do Switch são do tipo TRUNK
display port trunk

Mostrando um sumário do LINK AGGREGATION. 
display link-aggregation summary
display link-aggregation verbose

Mostrando a configuração do Switch atual
display current-configuration

Mostrando informações do Spanning Tree, quais portas estão BLOQUEADAS e quais estão em FORWARDING 
display stp brief
display stp

E vocês, possuem mais alguma sugestão de comando para os Switches da linha 5500?
Sintam-se a vontade…

Um abração! :)

 

 

Switches 3Com 4007 – Configurações Básicas – parte 2 de 2

Publicado originalmente em 9 DE ABRIL DE 2010

Criando VLANs

Na criação de VLANs, deveremos tomar os seguintes cuidados:

a) Cada Vlan vai possuir um ID que deverá ser o mesmo para todos os módulos e em todos os equipamentos Gigabit da rede;

b) Será visto o conceito de TAGGED 802.1Q. Quando forem definidas as portas utilizadas pela Vlan, cada porta deve ser definida como TAGGED ou UNTAGGED:

TAGGED 802.1Q – Quando se define que uma porta será TAGGED, está sendo informado que esta porta será utilizada como Backbone Port(UP Link), ou seja, por esta porta poderão passar mais de uma Vlan. Esta definição é usada para as portas de Backplane e portas de fibras. Também pode-se definir uma porta (RJ45) como TAGGED, para interligar com outra porta (RJ45) também definida como TAGGED. Para o outro Switch entender a marcação da VLAN. Esse conceito é similar ao das portas TRUNK.

IMPORTANTE: Porta definida como TAGGED, só funcionará se o dispositivo conectado a porta entender os frames “tagueados” (Switches ou Servidores), e se forem definidas as mesmas Vlans para as duas portas.

UNTAGGED – Quando se define que uma porta será UNTAGGED, está sendo informado que a porta será dedicada a uma determinada Vlan, ou seja, somente uma Vlan funcionará nesta porta. Esta definição é usada geralmente em portas de usuários finais (RJ45). Não há marcação no quadro com TAG.

 

CB9000> connect 7.1 // conectando ao Fabric
Menu options (Corebuilder 9000-1A97FC):

CB9000@slot 7.1 [24G-FAB-T] ():

Menu options (Corebuilder 9000-1A97FC): ----------------
module - Administer module-level functions
ethernet - Administer Ethernet ports
bridge - Administer bridging/VLANs
snmp - Administer SNMP
disconnect - Disconnect and return to Management Console

Type ? for help.
--------------------------------------------------------
CB9000@slot 7.1 [24G-FAB-T] (): bridge

Menu options (Corebuilder 9000-1A97FC): ----------------
display - Display bridge information
agingTime - Set the bridge address aging time
spanningTree - Administer spanning tree
cos - Administer COS priority queues
port - Administer bridge ports
multicast - Administer multicast filtering
vlan - Administer VLANs
trunk - Administer trunks
link - Administer resilient links

Type "q" to return to the previous menu or ? for help.
----------------------------------------------------------
CB9000@slot 7.1 [24G-FAB-T] (bridge): vlan

Menu options (Corebuilder 9000-1A97FC): ------------------
summary - Display summary information
detail - Display detail information
define - Define a VLAN
modify - Modify a VLAN
remove - Remove a VLAN
mode - Configure VLAN mode

// criaremos aqui uma Vlan com nome TESTE

Type "q" to return to the previous menu or ? for help.
-----------------------------------------------------------
CB9000@slot 7.1 [24G-FAB-T] (bridge/vlan): define
Enter VID (1 Default-VLAN,2-4094) [2]: 2 // ID da VLAN
Select bridge ports (1,5,9,13-17,21all?): all
Configure per-port tagging? (n,y) [y]: [Enter]
Enter port 1-4 tag type (none,802.1Q) [none]: 802.1Q
Enter port 5-8 tag type (none,802.1Q) [none]: 802.1Q
Enter port 9-12 tag type (none,802.1Q) [none]: 802.1Q
Enter port 13 tag type (none,802.1Q) [none]: 802.1Q
Enter port 14 tag type (none,802.1Q) [none]: 802.1Q
Enter port 15 tag type (none,802.1Q) [none]: 802.1Q
Enter port 16 tag type (none,802.1Q) [none]: 802.1Q
Enter port 17-20 tag type (none,802.1Q) [none]: 802.1Q
Enter port 21-24 tag type (none,802.1Q) [none]: 802.1Q
Enter VLAN Name {?} [ ]: teste

Adicionando Portas a uma VLAN

CB9000> connect 6.1

Menu options (Corebuilder 9000-1C0F38): -------------------
module - Administer module-level functions
ethernet - Administer Ethernet ports
bridge - Administer bridging/VLANs
snmp - Administer SNMP
analyzer - Administer Roving Analysis
disconnect - Disconnect and return to Management Console

Type ? for help.
-----------------------------------------------------------
CB9000@slot 6.1 [36-E/FEN-TX-L2] (): bridge

Menu options (Corebuilder 9000-1C0F38): -------------------
display - Display bridge information
agingTime - Set the bridge address aging time
spanningTree - Administer spanning tree
cos - Administer COS priority queues
port - Administer bridge ports
multicast - Administer multicast filtering
vlan - Administer VLANs
trunk - Administer trunks
link - Administer resilient links

Type "q" to return to the previous menu or ? for help.
-----------------------------------------------------------
CB9000@slot 6.1 [36-E/FEN-TX-L2] (bridge): vlan 

Menu options (Corebuilder 9000-1C0F38): -------------------
summary - Display summary information
detail - Display detail information
define - Define a VLAN
modify - Modify a VLAN
remove - Remove a VLAN
mode - Configure VLAN mode
Type "q" to return to the previous menu or ? for help.
-----------------------------------------------------------
CB9000@slot 6.1 [36-E/FEN-TX-L2] (bridge/vlan): modify
Enter VID (2-4094) [2]:
Select bridge ports (1-24all?) [1-24]: 2
Configure per-port tagging? (n,y) [y]:
Enter port 2 tag type (none,802.1Q) [none]: none
// configurando a porta 2 untagged
Enter port 37 tag type (none,802.1Q) [none]: 802.1Q
// porta taggeada
Enter port 38 tag type (none,802.1Q) [none]: 802.1Q
Enter VLAN Name {?} []: teste

Verificando as portas adicionadas as VLANs

Menu options (Corebuilder 9000-1C0F38): -------------------
summary - Display summary information
detail - Display detail information
define - Define a VLAN
modify - Modify a VLAN
remove - Remove a VLAN
mode - Configure VLAN mode

Type "q" to return to the previous menu or ? for help.
-----------------------------------------------------------
CB9000@slot 6.1 [36-E/FEN-TX-L2] (bridge/vlan): sumary

 

 

 

Switches HPN A5800 – Configurando QinQ

Publicado originalmente em 25 DE JANEIRO DE 2012
Um dos primeiros tópicos do site Comutadores, no ano de 2010, explicava a configuração de uma topologia com a configuração do QinQ em um Switch 5500. Após a aquisição da 3Com por parte da HP, houveram algumas mudanças na linha de equipamentos, com alguns modelos sendo descontinuados e outros alteraram apenas os seus Part Numbers.

As sintaxes de algumas features foram atualizadas e pelo o que temos visto até agora, a mudança tem sido bastante positiva.

A feature QinQ (802.1q sobre 802.1q), conhecido também como Stacked VLAN ou VLAN sobre VLAN, suporta a utilização de duas TAGs 802.1q no mesmo frame para trafegar uma VLAN dentro de outra VLAN – sem alterar a TAG original.

Para o cliente é como se a operadora tivesse estendido o cabo entre os seus Switches. Já para a Operadora não importa se o cliente está mandando um frame com TAG ou sem TAG, pois ele adicionará mais uma TAG ao cabeçalho e removerá na outra ponta apenas a ultima TAG inserida.

Em resumo, o tráfego no sentido  de entrada na porta configurada com QinQ, adicionará uma TAG 802.1q ao quadro, mesmo em casos que já houver a marcação de VLANs, entretanto no sentido de saída, é removido apenas a última TAG acrescentada, sendo mantida a TAG 802.q inserida pelo cliente.

Configurando

No Exemplo acima deveremos configurar nos Switches A e B uma VLAN para cada cliente e a configurar as interfaces conectadas aos Switches do cliente, como qinq enable. Como detalhe, percebam que é necessário desabilitar o STP em cada interface para os BPDU’s de cada empresa não interferir na topologia STP de cada uma. Segue abaixo a configuração dos Switches A e B:

Vlan 10
name clienteA
!
Vlan 11
name clienteB
!
Vlan 12
name clienteC
!
Interface GigabitEthernet x/y/z
port link-type access
qinq enable
stp disable
Em caso de necessidade de transporte de protocolos de camada 2 como CDP, LLDP, STP e etc, é possivel utilizar na interface algum dos comandos abaixo:

bpdu-tunnel dot1q cdp dldp eoam gvrp hgmp lacp lldp |pagp pvst
stp udld vtp }

A configuração dos Switches de cada cliente não sofre nenhuma alteração em particular e a visão de cada um  será  como se os Switches estivessem diretamente conectados.
Abraços a Todos! :)

Switches 3Com 5500 – Configurando QinQ (VLAN-VPN)

Publicado originalmente em 22 DE FEVEREIRO DE 2010

Conhecido também como Stacked VLAN, o QinQ suporta a utilização de duas TAGs 802.1q no mesmo frame para trafegar uma VLAN dentro de outra VLAN – sem alterar a TAG original.

A idéia é prover serviços aos clientes para manterem suas próprias VLANs dentro da rede do PROVEDOR, que poderá configurar uma VLAN para cada cliente independente da marcação 802.1q efetuada.

O comando vlan-vpn enable permite a utilização de QinQ.

Chamaremos os Switches 5500 de equipamentos do Provedor e os Switches 4210 e 4500 como Switches do Cliente.

No exemplo abaixo a comunicação entre o host A e B ocorrerá da seguinte forma:

1º – O Frame encaminhado pelo host A será marcado no Switch 4500 com a TAG 10 para o Switch 5500-A.
2º – O Switch 5500-A irá manter a informação da VLAN 10 e adicionará mais uma marcação com a TAG 100.
3º – O Switch 5500-B removerá a TAG 100 e encaminhará o Frame para o Switch 4210 com a TAG adicionada pelo Switch 4500.
4º – O Switch 4210 irá remover a TAG 10 e encaminhará o frame para o Host B

A estrutura do provedor (Switches 5500-A e 5500-B) será transparente para o cliente.

Segue abaixo as configurações efetuadas:

 

Switch 4210 
vlan 10
#
interface Ethernet1/0/1
port access vlan 10
#
interface GigabitEthernet1/0/27
port link-type trunk
port trunk permit vlan all

Switch 5500-A
vlan 100
#
interface GigabitEthernet1/0/25
stp disable
port access vlan 100
vlan-vpn enable
undo ntdp enable
#
interface GigabitEthernet1/0/26
port link-type trunk
port trunk permit vlan 1 100

Switch 5500-B vlan 100
#
interface GigabitEthernet1/0/25
stp disable
port access vlan 100
vlan-vpn enable
undo ntdp enable
#
interface GigabitEthernet1/0/26
port link-type trunk
port trunk permit vlan 1 100

Switch 4500 vlan 10
#
interface Ethernet1/0/1
port access vlan 10
#
interface GigabitEthernet1/0/27
port link-type trunk
port trunk permit vlan all

Percebam que nos equipamentos do Provedor, será necessário a configuração da porta de UpLink com o cliente como Access para não alterarmos a TAG inicial e também desabilitarmos o NTDP e STP.

Na configuração acima, os Switches 4210 e 4500 não irão trocar BPDUs, isto é, não haverá uma topologia única para o Spanning-Tree ( dos Switches do Cliente). Cada Switch do Cliente será Root da sua topologia (Os switches do Provedor, não participarão do Spanning-tree)

Para uma topologia única para o Spanning-tree do Cliente, será necessário configurarmos o comando vlan-vpn tunnel globalmente nos equipamentos da Operadora.
Segue abaixo configuração :

Switch 5500-A 
vlan-vpn tunnel
#
vlan 100
#
interface GigabitEthernet1/0/25
stp disable
port access vlan 100
vlan-vpn enable
undo ntdp enable
#
interface GigabitEthernet1/0/26
port link-type trunk
port trunk permit vlan 1 100

Switch 5500-B 
vlan-vpn tunnel
#
vlan 100
#
interface GigabitEthernet1/0/25
stp disable
port access vlan 100
vlan-vpn enable
undo ntdp enable
#
interface GigabitEthernet1/0/26
port link-type trunk
port trunk permit vlan 1 100

Comando display STP no Switch 4210:

display stp
-------[CIST Global Info][Mode MSTP]-------
CIST Bridge :32768.0024-73c4-7477
Bridge Times :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
CIST Root/ERPC :32768.0022-5733-5280
CIST RegRoot/IRPC :32768.0024-73c4-7477
CIST RootPortId :128.25

Até logo!