Switches ArubaOS – Guia Rápido de Configuração

Para aqueles que estão começando a gerenciar equipamentos Aruba criamos uma lista de comandos para instalação e configuração de Switches com ArubaOS (parte dos comandos são aceitos na maioria dos modelos); os scripts são simples e bastante úteis!

Algumas funcionalidades podem ser configuradas de diferentes maneiras, mas tentaremos ser o mais abrangente possível nos scripts abaixo:

Configurando o nome do Switch

Switch(config)# hostname Sw_Core
Sw_Core(config)#

Configuração de VLANs

vlan 2
name ADM

Mostrando quais as VLANs que existem no switch

show vlans

Mostrando as informações de uma determinada vlan (descrição, portas tagged e untagged)

show vlans 3

Definindo o IP para a VLAN 1

vlan 1
ip address 192.168.2.254 255.255.255.0

Configurando o default gateway

ip route 0.0.0.0 0.0.0.0 192.168.2.1

Habilitando o roteamento

ip routing

Configurações de portas
Entrando no modo de configuração de uma porta

interface 1

Colocando uma descrição na porta

interface 1
name "ROTEADOR"
exit

VLAN
Adicionando uma VLAN em uma porta de acesso

interface 2
untagged vlan 2

Adicionando VLANs em uma porta de uplink (as VLANs necessitam estar previamente configuradas)

interface ethernet 24
tag vlan 2,4,5,6,7,8,9,101,192,200

ou ….
Adicionando a porta a uma vlan

vlan 1
untagged 1
! Adicionando a porta 1 na VLAN 1

vlan 3
untagged 3,5-7
! Adicionando a porta 3,5,6 e 7 na VLAN 3

Para as portas utilizadas na conexão entre switches, todo o trafego de VLANs é encaminhado para essas portas como tagged (utilizando a TAG 802.1Q), exceto para a VLAN 1, que será encaminhada como untagged. 

Criando usuário
Definindo a senha do usuário diego como s3nha

password manager user-name "diego" plaintext s3nha

SNMPv2

snmp-server community s1ro restricted
! Comunidade SNMP de Leitura como s1ro
snmp-server community s1rw unrestricted
! Comunidade SNMP de Leitura e Escrita como s1rw

Habilitando o spanning tree protocol

spanning-tree

Configurando a versão do MSTP (802.1s)

spanning-tree mode mstp

Configurando o switch como root bridge do STP. O comando stp root primary configura automaticamente o valor do Bridge Priority para 0 (zero)

spanning-tree root primary
ou
spanning-tree priority 0

Criando um LINK AGGREGATION

No exemplo abaixo, exemplificamos a configuração das portas 23 e 24 como trunk (agregação de portas) com o protocolo LACP. Os Switches ArubaOs nomeiam as interfaces Link-Aggregation como trunk e nomeiam cada interface como trk[numero].

trunk 23-24 trk1 lacp

Syslog

logging 10.0.100.111

NTP

timesync ntp
ntp enable
ntp server 10.0.100.112
ntp unicast

Salvando as configurações do Switch

save

Apagando todas as configurações do Switch

erase startup-config

Comandos show

show interface brief
! Mostrando um resumo de TODAS as portas
show trunks
! Mostrando quais portas do Switch utilizam link-aggregation
show running-config
show running-config structured
! Mostrando a configuração do Switch atual
show spanning-tree
show spanning-tree config
! Mostrando informações do STP, quais portas estão BLOQUEADAS e FORWARDING
show mac-address
show arp
! Mostrando a tabela MAC e tabela ARP
show logging
! Visualizando os logs no Switch

E vocês, possuem mais alguma sugestão de comando para os Switches ArubaOS?
Sintam-se à vontade…

One thought on “Switches ArubaOS – Guia Rápido de Configuração

  1. Marcos Viana de Sousa 26 de abril de 2019 / 13:05

    Muito bom estas explicações, particularmente não gostei da hp ter ido para aruba pois as configurações dos hps já estavam enraizadas. talvez seja apenas questão de costume.

    De qualquer forma parabéns pelas postagens, suas orientações me ajuda muito no dia a dia.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *