Switches 3Com 5500 – Guia rápido de Configuração!!!

Publicado originalmente em 24 DE AGOSTO DE 2010

 Olá amigos, os scripts de hoje fazem parte de um manual muito bacana repassado pelo Fabinho e o Índio da Infraero. Os Scripts seguem como um manual rápido para instalação e/ou configuração de Switches 3Com do modelo 5500 ( parte dos comandos são aceitos na maioria dos Switches da 3Com); os scripts são simples e bastante úteis!

Configurando o nome do Switch
[5500G-EI]sysname SW_Core
[SW_Core]

Configuração de Vlans
Criando uma Vlan e colocando-a um nome
[Switch] vlan 3
[Switch-vlan] name

Criando uma Vlan e colocando-a uma descrição
[Switch] vlan 3
[Switch-vlan] description

Criando uma várias vlans ao mesmo tempo
[Switch] vlan to 2 to 5

Apagando uma vlan
[Switch] undo vlan 2

Mostrando quais as vlans que existem no switch
[Switch] display vlan

Mostrando as informações de uma determinada vlan (descrição, endereço IP se houver, portas tagged e untagged)
[Switch] display vlan  2

Definindo o IP para a VLAN 2 
[Switch]interface Vlan-interface 2
[Switch]-Vlan-Interface]ip address 192.168.100.1 255.255.255.0

Configurando o default gateway
[Switch] ip route-static 0.0.0.0 0.0.0.0 192.168.100.254 (ip do gateway)

Configurações de portas
Entrando no modo de configuração de uma porta
[Switch] interface gigabit-ethernet 1/0/4

Colocando uma descrição na porta
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] description

Adicionando porta a uma vlan 
Configurando o tipo de porta
Porta ACCESS: Porta de acesso, utilizada para ligar hosts (estações, servidores, etc)
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] port link-type access

Porta TRUNK: Porta que permitirá mais de uma vlan trafegar pela porta(utilizando TAG(802.1q). Utilizada como porta de uplink, nas ligações entre switches.
[Switch] interface gigabit-ethernet 1/0/5
[Switch-GigabitEthernet] port link-type trunk

Associando uma porta access a uma vlan.
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] port access vlan 5

Removendo uma vlan de uma porta access. A porta voltará a pertencer a vlan 1 (default)
[Switch] interface gigabit-ethernet 1/0/4
[Switch-GigabitEthernet] undo port access vlan

Associando todas as vlans a porta trunk. Desse modo, todas as vlans passarão pela porta trunk
[Switch] interface gigabit-ethernet 1/0/5
[Switch-GigabitEthernet] port trunk permit vlan all

Copiando as configurações de uma porta para outra (vlan, spanningtree, velocidade etc). Não efetua a copia das configurações de controle de broadcast
[Switch]copy configuration source gigabit-ethernet 1/0/1destination giggabit-ethernet 1/0/6

Copiando as configurações de uma porta para várias portas
[Switch]copy configuration source gigabit-ethernet 1/0/1destination giggabit-ethernet 1/0/6 to gigabit-ethernet 1/0/12

Definindo a senha do usuário ADMIN como s3nha
local-user admin
service-type telnet terminal
level 3
password cipher s3nha

Removendo os usuários default MANAGER e MONITOR
[Switch]undo local-user manager
[Switch]undo local-user monitor

Configurando e habilitando o gerenciamento SNMP com as comunidades s1ro e s1rw
[Switch]snmp-agent community read s1ro
[Switch]snmp-agent community write s1rw

Removendo as comunidades default PUBLIC e PRIVATE
[Switch]undo snmp-agent community write private
[Switch]undo snmp-agent community read public

Habilitando o spanning tree protocol (já é habilitado por padrão)
[Switch] stp enable

Configurando a versão do  rapid spanning tree protocol
[Switch] stp mode rstp 

Configurando o switch como root bridge primário do spanning tree
 O comando stp root primary configura automaticamente o valor do Bridge Priority para 0 (zero)
[Switch] stp root primary
ou
[Switch] stp priority 0

Configurando o switch como root bridge secundário do spanning tree
O comando stp root secondary configura automaticamente o valor do Bridge Priority para 4096
[Switch] stp root secondary
ou
[Switch] stp priority 4096

Criando um LINK AGGREGATION entre dois Switches. Não esquecer de executar esses procedimentos em ambos os Switches. Neste exemplo estão sendo utilizadas as portas 1/0/25 e 1/0/26 dos dois Switches.
link-aggregation group 1 mode static
#
interface GigabitEthernet 1/0/25
undo shutdown
port link-aggregation group 1
#
interface GigabitEthernet 1/0/26
undo shutdown
port link-aggregation group 1

Salvando as configurações do Switch
save

Apagando todas as configurações do Switch
reset saved-configuration
reboot

Comandos Display

Informações de uma determinada porta (velocidade, duplex, etc)

display interface GigabitEthernet 1/0/3

Mostrando um resumo de TODAS as portas
display brief interface

Mostrando quais portas do Switch são do tipo TRUNK
display port trunk

Mostrando um sumário do LINK AGGREGATION. 
display link-aggregation summary
display link-aggregation verbose

Mostrando a configuração do Switch atual
display current-configuration

Mostrando informações do Spanning Tree, quais portas estão BLOQUEADAS e quais estão em FORWARDING 
display stp brief
display stp

E vocês, possuem mais alguma sugestão de comando para os Switches da linha 5500?
Sintam-se a vontade…

Um abração! :)

 

 

{ Deixe um comentário }

  1. Jonas B. dos Santos

    Cara suas dicas tutoriais e guias são muito bons ajudam bastante.
    PARABÉNS

  2. Jose Roberto

    Cara,
    seu tutorial foi muito bom, me ajudou muito. Parabéns

  3. Luiz Felipe

    Diego bom dia, é possivel alterar a vlan default (1) para 10 por exemplo?

  4. Paulo

    Olá amigo! Não entendi muito bem como funciona “Configurando o switch como root bridge primário do spanning tree”. Será que vc explicar um pouco melhor essa função? E outra dúvida, é melhor usar o RSTP do que o padrão (STP)? Abraços e parabéns pelo excelente tutorial!

  5. Victor

    Cara, parabens pelo trabalho. Clareou muito. Estou com um certo problema. Após fazer toda a configuração que preciso no meu switch, ele roda normal, mas quando cai energia , ele perde todas as configurações. Como proceder?

    Abraço,

    Victor

  6. Bruno Pinto

    Parabéns pelo trabalho..
    tem ajudado muito,posso responder por todos que e um excelente tutorial.
    Compartilhando conhecimento sempre!!

  7. Judson Borges

    Boa noite Diego, eu gostaria de saber como faria para dividir a minha rede em 3 vlans, VOIP, IMPRESSORAS e Administrativa, mas as duas primeiras não baseadas em portas e sim por MAC. Meu problema é que tenho um Debian como DHCP porque tive um problema e tive que tirar o DHCP do Switch Core, minha topologia é 3com 5500 (core – Piso 1) -> 3com 4800G + (3com 4210)x3 (Piso 1) -> 3com 4800G + (3com 4210)x16 (Piso 2). Qualquer luz é bem vinda!

      • Judson Borges

        Obrigado pela atenção Diego, vou estudar melhor como resolver esse problema. Mas você já me deu um norte, valeu!

  8. Fabio

    Boa noite Diego. Em 1° lugar gostaria de parabenizá-lo pelo seu blog, de grande ajuda. E preciso de um help com um Switch 3com 5500, não possuo acesso pela interface web. Deletei as configurações que estavam nele, e refiz com outro endereço IP na Vlan1(default) e não consigo acessar a interface web. Tentei acessar com o usuario admin sem senha e não surtiu efeito. Aguardo uma resposta. Obrigado

      • Fabio

        Boa tarde Diego. Você tem o comando certo para ativar a interface LAN? Pois ativei o serviço mas ainda sem sucesso o acesso a interface web.

  9. Fabio

    Olá como faço para colocar um segundo IP na mesma vlan?

  10. Edmilson

    Boa noite Diego, parabéns pelas dicas. Você saberia informar o porque dos meus clientes as vezes recebem IP do meu DHCP Linux (Vlan 1), as vezes não recebem? Contudo vejo no log do servidor Linux que ele pagou um IP, mas simplesmente não chegou naqueles clientes associados à Vlan 9. As demais Vlans funcionam normalmente.

    Um abraço e obrigado.

  11. Marcelo

    Olá Diego, tudo certo?

    Suas dicas são muito boas, gostaria de ver contigo uma situação, tenho uma rede equipada com switches de borda HP A5120 e no core tenho HP A5500 tenho segmentada as vlans mas ainda não executei o projeto estou ainda fazendo alguns testes. No promeiro teste adicionei as vlans no servidor dhcp e no swtche de borda adicionei na porta do note uma vlan. O notebook pegou o ip da vlan sem problemas e ainda consigo pingar para as máquinas locais que estão na vlan(default) sem problemas mas, as máquinas que estão na vlan(default) não conseguem pingar, nem ao menos consigo acessar os servidores que estão em outro site. No core todas as fibras estão com trunk e permissão de todas as vlans. O que pode ser o problema?

  12. Paulo Henrique

    Boa tarde Diego, como autentico portas no switch para bloquear maquinas que nao estejam nas normas da minha rede?

  13. Raul Viana

    Boa noite Diego!!!…Uma duvida, estou com um sw hp a5500, gostaria de saber qual usuário e senha default???…Pois ja tentei configurar via console outro usuário e senha e não funciona…:/….Parabens pelo artigo….abraço!!!

  14. Raul Viana

    Ah esqueci de mencionar que é acesso via web…tks

  15. Igor Comunale Silva

    Boa Tarde, Diego. Tudo bem? Preciso de uma ajuda, estou com um 4500 e preciso configurar ele em Layer 3 e trabalhar com voip. Ex.: Internet Full -> 3com 4500 -> 2 servidores.

    Obrigado!

  16. Adriel

    Buen día, usted me podria ayudar?, necesito comunicar 2 Vlans de distintos switches 3C5500 3COM. Necesito habilitar un puerto en modo Tagged?, como lo realizo. Gracias

  17. gabrel

    Boa tarde!

    Estou com um switch 5500 hp, e estou precisando conectar a ele via web, porém, todas as portas estão DOWN como faço para deixa-las UP.

    • Raul Viana

      Gabrel…somente acessa via console e por lá você dá o comando “no shutdown” nas portas…após isso é possivel acesso via web….

  18. fabiano

    Diego, boa tarde!

    Gostaria de saber como faço para desvincular as portas 11/12/23/24 das portas de transceiver gbic (25/26/27/28) no switch 3com 5500G-EI. Pois todas as configurações que estão nas portas 25/26/27/28 o switch replica para as 11/12/23/24.

    Aguardo seu retorno.

    Obrigado!

  19. fabiano

    Boa tarde!

    Gostaria de saber como faço para desvincular as portas 11/12/23/24 das portas de transceiver (gbic), pois toda configuração que faço nas portas Gbic´s são replicadas para as outras portas que informei.
    modelo 3Com Switch 5500G-EI 24-Port

    Obrigado.

  20. Alan

    Cara, elas devem está configurada como “port mirroring”.

    Não sei exatamente como desabilita isso via comandos… mas é fácil pela GUI.

    Seguinte:

    port > port mirroring:
    Nesse momento, ele vai te mostrar o sumário.

    Se você navegar pelas abas, observará as opções de summary, create, remove, modify port e modify vlan.

    :)

  21. Gabriel

    Boa tarde pessoal,

    Algum tem noção de como se configura um “dot1q tunnel” nestes switches 3Com?

    A situação que tenho, é um trecho composto por uma rede 3Com, na qual tenho de trafegar uma quantidade X de Vlan’s (sendo X um número no qual temos certeza de serem 2 Vlan’s, mas que pode se extender a cerca de 50-100 VLAN’s, dependendo a contratação das empresas aéreas).

    Minha dúvida era se é possível fazer uma configuração de túnel (similiar a que se pode fazer em um switch Cisco) para termos uma conexão “dedicada”, não limitando a quantidade de VLAN’s nas portas (sem ter de adicionar a toda hora uma vlan nova implementada a passar na rede 3Com).

    Abraços!

  22. Fábio

    Gostaria de tirar uma dúvida, como devo configurar VLAN de um Switch JG9772A(VLAN20) e o JG543A(VLAN10), para se comunicar, fiz a porta trunk mais não está comunicando.

  23. David

    Olá primeiramente parabens pelo site e pela dedicação.
    Gostaria de tirar uma duvida.
    tenho um 3com 2924 e gostaria de ver se é possivel criar 1 vlan e deixar uma porta trunk ligando nessa porta o link de internet que vem do roteador da GVT
    dentro da Vlan1 estaria o servidor de internet.
    outra pergunta é possivel ter mais de 1 porta trunk ?

    Obrigado

  24. Fabio

    É possível o equipamento HI 5500(JG543A), em cada porta de fibra está conectado em switch modelo (J9772A), e em cada equipamento deste uma VLAN diferenciada?

    Por exemplo
    display interface gig 1/0/9
    PVID:1
    Port link-type: trunk
    VLAN PASSING: 1, 202
    VLAN PERMITTED: 1, 202

    E 2530(J9772A)
    vlan 205
    name VLAN205
    tagged 25-28
    untagged 1-24
    ip address 10.192.1.2 255.255.0.0
    primary-vlan
    management-vlan

  25. Lorena

    Boa tarde Diego!
    Muito boa as dicas, parabéns.
    Tenho um Switch 4210 26-port, cuja o O.S não sobe, você sabe onde posso encontrar o firmware deste equipamento?

  26. Diego Martins

    Pessoal to com uma dúvida, tenho um 3com gerenciável e gostaria de saber se tem a possibilidade de colocar 2 links de internet nele e configurando para que quando um cai o outro fique rodando? Se sim como seria? Há ele é dual wan.

  27. José Oliveira

    Muito obrigado. Seu site é show de bola.

    Parabéns.

    Abs

  28. Marcelo

    Diego,

    Sabe de alguma forma de rodar o o comando display current-configuration trazendo a configuração por completo, sem quebras, e sem o — more —?

    Algo similar ao terminal pager 0 dos Cisco…

    Isso para os 3Com 4210 e 5500…

    Obrigado!

  29. Paulo Dias

    Usei as dicas de voces e consegui entrar no switch (3com 4500) e habilitar we, atualizare etc… OBRIGADÃO!!
    Mas to precisando desabilitar o lance que remove as tags VLAN das portas… preciso que ele funcione como um switch comum não gerenciavel. 2 equipamentos com vlan não se comunicam quando passam pelo switch…. preciso passar nvlans em cada porta e que nada seja feito ..como num switch de R$ 30….alguem me ajuda ??

  30. Marlon Augusto Heiber

    Como faço para configurar uma porta dele para acesso a interface web dele?

  31. Marlon Augusto Heiber

    Tenho um 5500/5500G zerado de fábrica e vou substituir por um que apresentou problemas na minha infraestrura. Alguém sabe me dizer como faço backup e restore de toda configuração do Switch? Sendo que eu utilizo eles com a porta Stack.

    • Willdson Almeida

      Costumo fazer da seguinte forma:

      No SW danificado, roda o “dis cur” o resultado é toda a configuração do SW. Copie em um notepad e cole no modo de configuração do novo SW.

  32. geandro

    Olá desde que atualize o meu 5500G meu empilhamento não funciona mais, vc poderia me dar uma ajuda sobre como configurar o irf nesse equipamento desde agradeço

  33. JSMAC

    Muito boa as informações Diego, Só que estou com um problema,tenho um switch 3com 4500 26 portas com senha habilitada no boot e não sei a senha, algúem sabe o procedimento de reset factory da senha, agradeço quem poder me ajudar.

  34. Wesley Gottara

    Parabéns amigo, excelente tutorial. Estou me aprofundando um pouco em SWs da 3com/HP, pois nem todas as empresas utilizam CISCO. Se possível poderia fazer um tutorial como este, mais nos SWs da Juniper? Deis de já agradeço fique com Deus.

  35. Alessandro

    Bom dia Diego,

    Na empresa que trabalho possuímos o switch 5500G. Atualmente temos 20 vLans criadas e gostaríamos de criar ACLs para limitar o trafego entre as redes(por exemplo, vLan 5 só enxerga vLan 1). Você tem alguma sugestão de como podemos fazer isso de maneira eficiente?

    Também gostaria de agradecer pelo seu blog pois já me ajudou muito. Um abraço.

  36. Thiago

    Bom dia,
    Estou com um HPE 5130 (JG975A) ativei a opção de http so que o usuário admin esta sem opção edição.
    tentei colocar: authorization-attribute level 3 mais não existe level 3 neste modelo.
    Sabe como posso adicionar permissão ?

  37. Welington

    Bom dia,

    Excelente post, gostaria de saber se tem alguma configuração que possamos fazer alta disponibilidade entre dois switches do modelo A5500, um parar de funcionar o outro assumir as configurações do principal.

  38. Edgard

    Poderia me ajudar, informando qual comando no router 3com para simular ligação?

Deixe uma resposta

O seu endereço de email não será publicado. Campos obrigatórios são marcados com *

Pingback & Trackback

  1. Configurar switch hp A5500 « Blog do Fernando - Pingback on 2012/07/19/ 02:59
  2. Artigos mais populares de 2015 | Comutadores - Pingback on 2016/01/10/ 09:56