Switches 3Com 5500 – Configurando QinQ (VLAN-VPN)

Publicado originalmente em 22 DE FEVEREIRO DE 2010

Conhecido também como Stacked VLAN, o QinQ suporta a utilização de duas TAGs 802.1q no mesmo frame para trafegar uma VLAN dentro de outra VLAN – sem alterar a TAG original.

A idéia é prover serviços aos clientes para manterem suas próprias VLANs dentro da rede do PROVEDOR, que poderá configurar uma VLAN para cada cliente independente da marcação 802.1q efetuada.

O comando vlan-vpn enable permite a utilização de QinQ.

Chamaremos os Switches 5500 de equipamentos do Provedor e os Switches 4210 e 4500 como Switches do Cliente.

No exemplo abaixo a comunicação entre o host A e B ocorrerá da seguinte forma:

1º – O Frame encaminhado pelo host A será marcado no Switch 4500 com a TAG 10 para o Switch 5500-A.
2º – O Switch 5500-A irá manter a informação da VLAN 10 e adicionará mais uma marcação com a TAG 100.
3º – O Switch 5500-B removerá a TAG 100 e encaminhará o Frame para o Switch 4210 com a TAG adicionada pelo Switch 4500.
4º – O Switch 4210 irá remover a TAG 10 e encaminhará o frame para o Host B

A estrutura do provedor (Switches 5500-A e 5500-B) será transparente para o cliente.

Segue abaixo as configurações efetuadas:

 

Switch 4210 
vlan 10
#
interface Ethernet1/0/1
port access vlan 10
#
interface GigabitEthernet1/0/27
port link-type trunk
port trunk permit vlan all

Switch 5500-A
vlan 100
#
interface GigabitEthernet1/0/25
stp disable
port access vlan 100
vlan-vpn enable
undo ntdp enable
#
interface GigabitEthernet1/0/26
port link-type trunk
port trunk permit vlan 1 100

Switch 5500-B vlan 100
#
interface GigabitEthernet1/0/25
stp disable
port access vlan 100
vlan-vpn enable
undo ntdp enable
#
interface GigabitEthernet1/0/26
port link-type trunk
port trunk permit vlan 1 100

Switch 4500 vlan 10
#
interface Ethernet1/0/1
port access vlan 10
#
interface GigabitEthernet1/0/27
port link-type trunk
port trunk permit vlan all

Percebam que nos equipamentos do Provedor, será necessário a configuração da porta de UpLink com o cliente como Access para não alterarmos a TAG inicial e também desabilitarmos o NTDP e STP.

Na configuração acima, os Switches 4210 e 4500 não irão trocar BPDUs, isto é, não haverá uma topologia única para o Spanning-Tree ( dos Switches do Cliente). Cada Switch do Cliente será Root da sua topologia (Os switches do Provedor, não participarão do Spanning-tree)

Para uma topologia única para o Spanning-tree do Cliente, será necessário configurarmos o comando vlan-vpn tunnel globalmente nos equipamentos da Operadora.
Segue abaixo configuração :

Switch 5500-A 
vlan-vpn tunnel
#
vlan 100
#
interface GigabitEthernet1/0/25
stp disable
port access vlan 100
vlan-vpn enable
undo ntdp enable
#
interface GigabitEthernet1/0/26
port link-type trunk
port trunk permit vlan 1 100

Switch 5500-B 
vlan-vpn tunnel
#
vlan 100
#
interface GigabitEthernet1/0/25
stp disable
port access vlan 100
vlan-vpn enable
undo ntdp enable
#
interface GigabitEthernet1/0/26
port link-type trunk
port trunk permit vlan 1 100

Comando display STP no Switch 4210:

display stp
-------[CIST Global Info][Mode MSTP]-------
CIST Bridge :32768.0024-73c4-7477
Bridge Times :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
CIST Root/ERPC :32768.0022-5733-5280
CIST RegRoot/IRPC :32768.0024-73c4-7477
CIST RootPortId :128.25

Até logo!

 

 

2 thoughts on “Switches 3Com 5500 – Configurando QinQ (VLAN-VPN)

  1. Rafael 29 de agosto de 2015 / 1:07

    É possivel taggear uma vlan na mesma porta do qinq e excluir ela do qinq?

    • Diego Dias 7 de setembro de 2015 / 11:41

      Olá Rafael,

      sim é possível com a utilização de QoS. As configurações do traffic-behavior permitem alterar parâmetros como S-tag e C-Tag.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *