Resumo: T38 – Fax over IP (FoIP) em Roteadores HP MSR

O Fax (abreviação de fac-símile) é a transmissão telefônica de material impresso digitalizado (texto e imagens), normalmente para um número de telefone conectado a uma impressora ou outro dispositivo de saída.

O protocolo T.38 permite transmitir mensagens de fax através de uma rede IP em tempo real (na velocidade da transmissão). Os aparelhos de FAX não necessariamente precisam obter informações sobre a rede e podem continuar a enviar as suas mensanges no padrão T.30.

O padrão T.38 Fax Relay foi concebido em 1998 como uma maneira de permitir que a mensagem via fax a seja transportadas através de redes IP entre terminais de fax existentes no padrão do Grupo 3.

Existem outros protocolos de envio de FAX sobre IP mas o padrão do ITU é o T.38.

Como T.38 Fax Relay funciona?

Os dados modulados pelo fax analógico são digitalizados pelo DSP (Digital Signal Processor) no gateway e as informações são geradas em binário.

A informações em binário são encapsuladas no pacote T.38 e então transportada pela rede IP.

O DSP no gateway de destino extrai a informação transportada pelo pacote T.38 e modula dentro do sinal de fax analógico tradicional.

T38

Configuração

No exemplo abaixo utilizaremos o mesmo exemplo do Configuration Guide do MSR 3012 para Voz, utilizando SIP entre duas localidades.

Comware T38

 

<RouterA> system-view
[RouterA] voice-setup
[RouterA-voice] dial-program
[RouterA-voice-dial] entity 2000 voip
[RouterA-voice-dial-entity2000] match-template 2000
[RouterA-voice-dial-entity2000] address sip ip 10.2.2.2
[RouterA-voice-dial-entity2000] fax protocol standard-t38 ls-redundancy 4
[RouterA-voice-dial-entity2000] quit
[RouterA-voice-dial] entity 1000 pots
[RouterA-voice-dial-entity1000] match-template 1000
[RouterA-voice-dial-entity1000] line 2/1/1
[RouterA-voice-dial-entity1000] fax protocol standard-t38 ls-redundancy 4
####
<RouterB> system-view
[RouterB] voice-setup
[RouterB-voice] dial-program
[RouterB-voice-dial] entity 1000 voip
[RouterB-voice-dial-entity1000] match-template 1000
[RouterB-voice-dial-entity1000] address sip ip 10.1.1.1
[RouterB-voice-dial-entity1000] fax protocol standard-t38 ls-redundancy 4
[RouterB-voice-dial-entity1000] quit
[RouterB-voice-dial] entity 2000 pots
[RouterB-voice-dial-entity2000] match-template 2000
[RouterB-voice-dial-entity2000] line 2/1/1
[RouterB-voice-dial-entity2000] fax protocol standard-t38 ls-redundancy 4

Para visualizar as estatísticas utilize os comandos:

display voice fax statistics
reset voice fax statistics

Até logo

Referências

https://www.youtube.com/watch?v=GkVUGeaIXjg

HPE FlexNetwork MSR Router Series – Voice – Configuration Guide Document version: 6PW104-20151118

https://en.wikipedia.org/wiki/T.38

 

Configurando IRF em Roteadores HP MSR

Os novos Roteadores MSR da HP possuem suporte para a configuração em IRF. O IRF é uma tecnologia que permite transformarmos diversos Switches ou Roteadores físicos em um único equipamento lógico. Todos os equipamentos serão visualizados como uma única “caixa”, aumentando a disponibilidade da rede.

A recomendação é efetuar o IRF com equipamentos da mesma família e modelo, mas há dispositivos que suportam equipamento da mesma família, mas com diferentes modelos. É bom pesquisar caso a caso.

O cenário abaixo foi construído utilizando o simulador HCL utilizando 2 Roteadores em IRF conectando um Router-Aggregation com um Switch 5820.

MSR em IRF

Configurando o IRF

Segue abaixo o passo-a-passo da configuração:

1º altere o irf-member ID do segundo Roteador (por padrão o member ID é 1) e o priority de cada equipamento para eleição do Master (vence o maior valor).

R1
<ROUTER>system
[ROUTER]irf priority 31

R2
<ROUTER>system
[ROUTER]irf member 2
[ROUTER]irf priority 30

Configurando as IRF-port

R1
[ROUTER]irf-port 1
[ROUTER-irf-port1]port group interface GigabitEthernet 0/0
[ROUTER-irf-port1]quit

R2
[ROUTER]irf-port 2
[ROUTER-irf-port2]port group interface GigabitEthernet 0/0
[ROUTER-irf-port2]quit

Habilitando o IRF

R1
[ROUTER]chassis convert mode irf
The device will switch to IRF mode and reboot.
You are recommended to save the current running configuration and specify the configuration file for the next startup. Continue? [Y/N]:y
Do you want to convert the content of the next startup configuration file flash:/startup.cfg to make it available in IRF mode? [Y/N]:y
Now rebooting, please wait...

R2
[ROUTER]chassis convert mode irf
....

Comandos display

[ROUTER]display irf

MemberID   Role   Priority CPU-Mac       Description
*+1       Master 31       90eb-4082-0100 ---
2       Standby 30       94cc-d87d-0200 ---
--------------------------------------------------
* indicates the device is the master.
+ indicates the device through which the user logs in.
The Bridge MAC of the IRF is: 90eb-4082-0100
Auto upgrade               : yes
Mac persistent             : 6 min
Domain ID                   : 0
Auto merge                 : yes

 

[ROUTER]display irf configuration
MemberID NewID   IRF-Port1                    IRF-Port2
1       1       GigabitEthernet1/0/0         disable
2       2       disable                       GigabitEthernet2/0/0

 

Configurando o Router-Aggregation nos MSRs em IRF

[ROUTER]interface Route-Aggregation 1
[ROUTER-Route-Aggregation1]link-aggregation mode dynamic
[ROUTER-Route-Aggregation1]ipv6 address 2001:db8:1234::a 64
[ROUTER-Route-Aggregation1]disp this

#
interface Route-Aggregation1
link-aggregation mode dynamic
ipv6 address 2001:DB8:1234::A/64
#
return
[ROUTER-Route-Aggregation1]quit

[ROUTER]interface GigabitEthernet 1/0/1
[ROUTER-GigabitEthernet1/0/1]port link-aggregation group 1
[ROUTER-GigabitEthernet1/0/1]interface GigabitEthernet 2/0/1
[ROUTER-GigabitEthernet2/0/1]port link-aggregation group 1
[ROUTER-GigabitEthernet2/0/1]end

Configuração do Switch

#
interface Bridge-Aggregation1
link-aggregation mode dynamic
#
#
interface GigabitEthernet1/0/1
port link-mode bridge
combo enable fiber
port link-aggregation group 1
#
interface GigabitEthernet1/0/2
port link-mode bridge
combo enable fiber
port link-aggregation group 1
#
interface Vlan-interface1
ipv6 address 2001:DB8:1234::B/64
#
[Router]disp link-aggregation verbose
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected, I – Individual
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
D -- Synchronization, E -- Collecting, F -- Distributing,
G -- Defaulted, H -- Expired

Aggregate Interface: Route-Aggregation1
Aggregation Mode: Dynamic
Loadsharing Type: Shar
System ID: 0x8000, 90eb-4082-0100

Local:
Port             Status Priority Oper-Key Flag
--------------------------------------------------------------------------------
GE1/0/1         S       32768   1        {ACDEF}
GE2/0/1         S       32768   1         {ACDEF}
Remote:
Actor           Partner Priority Oper-Key SystemID               Flag
--------------------------------------------------------------------------------
GE1/0/1         3       32768   1         0x8000, 94de-65c3-0300 {ACDEF}
GE2/0/1         2       32768   1         0x8000, 94de-65c3-0300 {ACDEF}

 

[Router]ping ipv6 2001:db8:1234::b
Ping6(56 data bytes) 2001:DB8:1234::A --> 2001:DB8:1234::B, press CTRL_C to break
56 bytes from 2001:DB8:1234::B, icmp_seq=0 hlim=64 time=2.000 ms
56 bytes from 2001:DB8:1234::B, icmp_seq=1 hlim=64 time=1.000 ms
56 bytes from 2001:DB8:1234::B, icmp_seq=2 hlim=64 time=0.000 ms
56 bytes from 2001:DB8:1234::B, icmp_seq=3 hlim=64 time=1.000 ms
56 bytes from 2001:DB8:1234::B, icmp_seq=4 hlim=64 time=1.000 ms

--- Ping6 statistics for 2001:db8:1234::b ---
5 packets transmitted, 5 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 0.000/1.000/2.000/0.632 ms
[Router]%Jan 26 13:40:07:783 2016 Router PING/6/PING_STATISTICS: Ping6 statistics for
2001:db8:1234::b: 5 packets transmitted, 5 packets received, 0.0% packet loss, round-trip
min/avg/max/std-dev = 0.000/1.000/2.000/0.632 ms.

Até logo

 

Configurando o MSR como um SIP Enhanced Media Gateway com Microsoft Lync.

Esses dias pesquisando sobre configuração de SIP Trunking em roteadores HP MSR encontrei o Technical Configuration Guide para configuração com Microsoft Lync.

O nome do documento é “Configuring HP MSR Series as a SIP Enhanced Media Gateway with Microsoft Lync” e pode ser visualizado em http://h20195.www2.hp.com/V2/GetPDF.aspx%2F4AA4-9293ENW.pdf

Se o link estiver quebrado, deixe um comentário.

abração

Artigos mais populares de 2015

Galera, segue abaixo a lista dos artigos mais acessados no site comutadores no ano de 2015.

1. Switches 3Com 5500 – Guia rápido de Configuração
http://www.comutadores.com.br/switches-3com-5500-guia-rapido-de-configuracao/

2. Comandos Secretos para os Switches 3Com Baseline e HP v1910
http://www.comutadores.com.br/comandos-secretos-para-os-switches-3com-baseline-e-hp-v1910/

3. VLAN – Trunk utilizando 802.1q (dot1q)
http://www.comutadores.com.br/vlan-trunk-utilizando-802-1q-dot1q/

4. Elegendo o Switch Root do Spanning-Tree
http://www.comutadores.com.br/elegendo-o-switch-root-do-spanning-tree/

5. Perguntas e Respostas: Portas Access/Trunk/Híbrida, LACP e STP.
http://www.comutadores.com.br/perguntas-e-respostas-portas-access-trunk-hibrida-lacp-e-stp/

Boas Festas!

familia cierais- sem fundo 1
Galera, queria escrever esse último post do ano para finalizar as atividades do blog para 2015 e tirar uns dias de descanso. Além de desejar um bom final de ano para vocês! 🙂

Agradeço mais uma vez a todos os leitores pela audiência, as dicas e comentários. É um prazer acompanhar os acessos e ver como o site cresceu. Já no começo do próximo semestre iniciaremos nosso 5º ano! Agradeço também o investimento e a confiança no blog com a compra dos ebooks.

Para encerrar, quero desejar a todos vocês que o próximo ano seja menos turbulento, mais tranquilo, próspero, com muita saúde e em família. Gostaria de compartilhar abaixo 2 textos que gosto muito.

Bom descanso e boas festas.

Vamos à luta.

Para tudo há uma ocasião, e um tempo para cada propósito debaixo do céu: tempo de nascer e tempo de morrer, tempo de plantar e tempo de arrancar o que se plantou, tempo de matar e tempo de curar, tempo de derrubar e tempo de construir, tempo de chorar e tempo de rir, tempo de prantear e tempo de dançar, tempo de espalhar pedras e tempo de ajuntá-las, tempo de abraçar e tempo de se conter, tempo de procurar e tempo de desistir, tempo de guardar e tempo de lançar fora, tempo de rasgar e tempo de costurar, tempo de calar e tempo de falar, tempo de amar e tempo de odiar, tempo de lutar e tempo de viver em paz. O que ganha o trabalhador com todo o seu esforço? Tenho visto o fardo que Deus impôs aos homens.

Ele fez tudo apropriado a seu tempo. Também pôs no coração do homem o anseio pela eternidade; mesmo assim este não consegue compreender inteiramente o que Deus fez. Descobri que não há nada melhor para o homem do que ser feliz e praticar o bem enquanto vive. Descobri também que poder comer, beber e ser recompensado pelo seu trabalho, é um presente de Deus.‘ Eclesiastes 3:1-13

Atire o seu pão sobre as águas, e depois de muitos dias você tornará a encontrá-lo.
Eclesiastes 11:1

Deus abençoe.

Comware 7 – Configurando o GRE

O GRE (Generic Routing Encapsulation) é um protocolo de tunelamento que pode encapsular diversos protocolos dentro de tuneis IP, criando links ponto-a-ponto virtuais entre roteadores remotos.

O protocolo é extremamente funcional em diversos cenários, pois foi desenvolvido para permitir que redes remotas pareçam estar diretamente conectadas. Como o GRE não faz a criptografia, o GRE pode trabalhar em conjunto com IPsec para garantir a integridade das informações quando necessário.

Abaixo podemos observar a representação do encapsulamento de um pacote IP pelo GRE como também a inclusão de um novo cabeçalho.

GRE header

O interessante é que o protocolo de transporte poderia ser o IPv6 e o protocolo encapsulado poderia ser o IPX, tráfego Multicast, etc; E ao ser entregue ao roteador de destino, o novo cabeçalho é removido e o pacote é entregue intacto.

Segue abaixo um exemplo de configuração de um túnel GRE para Roteadores com o Comware 7, fechando a adjacência OSPF entre 2 roteadores separados por uma rede MPLS. Nos testes usamos o roteador HP VSR1000.

comware 7 GRE

Tabela de Rotas e tracert do Roteador R2

[R2]disp ip routing-table | inc O
192.168.1.0/24     O_INTRA 10  1563        192.168.13.1    Tun0

<R2>tracert 192.168.13.1
traceroute to 192.168.13.1 (192.168.13.1), 30 hops at most, 52 bytes each packet, press CTRL_C to break
 1  192.168.23.2 (192.168.23.2)  0.488 ms  0.523 ms  1.668 ms
 2  192.168.13.1 (192.168.13.1)  0.962 ms  5.463 ms  0.881 ms

<R2>tracert 192.168.1.1
traceroute to 192.168.1.1 (192.168.1.1), 30 hops at most, 52 bytes each packet, press CTRL_C to break
 1  192.168.1.1 (192.168.1.1)  1.116 ms  2.588 ms  1.731 ms

Referências

http://www.comutadores.com.br/roteadores-hp-6600-protocolo-de-tunelamento-gre/

http://www.rotadefault.com.br/protocolo-de-tunelamento-gre/

Switches Procuve – Comando ‘comware-help-display’

Para aqueles que estão acostumados a gerenciar Switches 3Com/H3C/HP baseados no Comware e precisam administrar switches em ambientes multivendor, com equipamentos HP Procurve, podem utilizar o comando comware-help-display para habilitar alguns comandos do Comware no Provision.

Habilite a feature com o comando

HP-5406zl(config)# comware-help-display

Exemplo de configuração

HP-5406zl(config)# interface vlan 32
HP-5406zl(vlan-32)# display this
vlan 1
name "default"
no untagged A1,A3-A4,A7-A8,A10,A14-A16,A20
untagged A2,A5-A6,A9,A13,A17-A19,A21-A22,Trk1-Trk2
ip address dhcp-bootp
ip igmp
dhcp-snooping
exit
vlan 10
name "RH"
untagged A1
no ip address
exit
vlan 31
!saída omitida

HP-5406zl(vlan-32)# display current-configuration
; J8697A Configuration Editor; Created on release #K.15.17.0008
hostname "HP-5406zl"
module 1 type j8702a
comware-help-display enable
console idle-timeout 7200
console idle-timeout serial-usb 7200
dhcp-snooping
no telnet-server
time timezone -200
no web-management
!saída omitida

Abraços

Instalando o HP VSR1000 no VMWare Workstation

Galera segue um passo-a-passo para a instalação do roteador HP VSR1000 no VMWare Workstation versão 9. Para mais informações sobre o HP VSR 1000 acesse: http://www.comutadores.com.br/hp-vsr1000-virtual-service-router/

O download do VSR100 pode ser feito no site https://h10145.www1.hp.com/Downloads/SoftwareReleases.aspx?ProductNumber=JG813AAE&lang=en&cc=us&prodSeriesId=5443163

  1. No VMWare Workstation clique em “File” e “New virtual Machine…“. Depois escolha a opção “Custom (Advanced)”, clique em next e next.
  2. Escolha o diretório que para instalar a imagem ‘.iso’ e avance.

HP VSR instalar 1

  1. Em ‘Select a Guest Operating Sytem” Escolha a opção “Other”, “FreeBSD” e avance.

HP VSR instalar 2

  1. Escolha o nome da sua máquina virtual, depois escolha o diretório para salvar e avance.
  2. Escolha a quantidade de processadores.

HP VSR instalar 4

Obs: O software do HP VSR1000 pode ser baixado gratuitamente com liberdade para uso de todas as features com a performance limitada a 5Kpps. O período trial dura 60 dias (para utilização de 1 CPU).

  1. Para a quantidade de memória escolhi 1024 para fazer o lab. Defina e clique em “Next”.
  2. Em “Network type”, utilizei “bridged networking
  3. Em “Select I/O Controller Types”, selecione “LSI Logic

HP VSR instalar 7

  1. Em “Select a Disk type” escolha “SCSI”.
  2. Em “Select a Disk”, escolha “Create a New Virtual Disk”.
  3. Em “Specify Disk Capaciy”, escolhi 8Gb de memória e “Split virtual disk into multiple files”.

HP VSR instalar 10

  1. …clique em Next..

HP VSR instalar 11

  1. Antes de finalizar, vá para “Customize Hardware” para adicionar as interfaces GigabitEthernet.

HP VSR instalar 12

HP VSR instalar 13

HP VSR instalar 14

Repita o processo para quantas interfaces você desejar.

obs:Tenho utilizado 4 interfaces para Lab.

  1. Clique em Finish..

HP VSR instalar 17

  1. Após iniciar a VM.. escolha Fresh Install, yes e yes. 🙂

HP VSR instalar 18

Após finalizar o processo inicial de instalação já é possível utilizar o HP VSR 1000

Comunicação com a LAN

Se estiver com problemas de comunicação com a rede local abra o “Virtual Network Editor” e escolha a interface para saída. No meu caso para o Lab eu escolhi a minha interface Wireless.

Espero ter ajudado.

Abração

Comware7: Configuração básica para BGP

As configurações do BGP via CLI para os equipamentos baseados no Comware 7 diferem um pouco em relação aos Switches e Roteadores baseados no Comware 5.

Se você quiser saber um pouco mais sobre como funciona  o BGP, temos alguns artigos no blog. Os principais são:
http://www.comutadores.com.br/switches-3com-4800g-configuracao-basica-do-bgp/
http://www.comutadores.com.br/resumo-sobre-border-gateway-protocol-bgp-mase-parte1/

Basicamente para o Comware 7, uma vez dentro do processo BGP, basta habilitar o ‘peering’ com o roteador vizinho normalmente, mas a grande diferença está no anuncio de prefixos, pois uma vez que você necessite anunciar prefixos IPv4 ou IPv6, será necessário entrar no address-family, ativar o peering e aplicar o comando network, import (redistribute) etc.

Para ficar mais fácil, veja o exemplo abaixo o peering eBGP entre o Roteador R1 (AS 100) e R4 (AS 400):

BGP Comware 7

<R1> display current-configuration configuration bgp
bgp 100
peer 10.0.0.2 as-number 400
#
 address-family ipv4 unicast
    network 192.168.1.0 255.255.255.0
    peer 10.0.0.2 enable 
   
<R4> display current-configuration configuration bgp
bgp 400
peer 10.0.0.1 as-number 100
#
 address-family ipv4 unicast
  network 192.168.2.0 255.255.255.0
  peer 10.0.0.1 enable  

O ponto mais importante dessa configuração é definir o IPv4 unicast address family e ativar o peer. Perceba que as redes deverão ser anunciadas dentro do address family correto.
Para validar o peering:

<R1>display bgp peer ipv4 unicast
BGP local router ID: 192.168.1.1
Local AS number: 100
Total number of peers: 1 Peers in established state: 1
* - Dynamically created peer
Peer     AS   MsgRcvd MsgSent OutQ PrefRcv Up/Down State
10.0.0.2 400   125     118     0    2       01:47:39 Established

IPv6
O mesmo vale se o peering e/ou prefixos for para endereços IPV6

<R4>display current-configuration configuration bgp
#
bgp 400
 peer 2001:DB8:14::1 as-number 100
 #
  address-family ipv6 unicast
   network 2001:DB8:4:: 64
   network 2001:DB8:44:: 64
   peer 2001:DB8:14::1 enable

Para validar o peering BGP com endereço IPv6:

 <R4>display bgp peer ipv6 unicast
 BGP local router ID: 192.168.44.4
 Local AS number: 400
 Total number of peers: 1          Peers in established state: 1
  * - Dynamically created peer
Peer             AS  MsgRcvd  MsgSent OutQ PrefRcv Up/Down  State

2001:DB8:14::1   100 60       60      0     2 00:47:40 Established

Para validar a tabela BGP basta preencher conforme o output abaixo: IPv4, IPv6, vpnv4, vpnv6, etc..

<R4>display bgp routing-table ?
  dampened   Display dampened BGP routes
  flap-info  Display BGP route flap information
  ipv4       Specify the IPv4 address Family
  ipv6       Specify the IPv6 address Family
  vpnv4      Specify the VPNv4 address family
  vpnv6      Specify the VPNv6 address family

Até logo.