Blog Archives

Telefonia IP – Convergência entre o Avaya Aura e Switches HPN.

A Avaya publicou um documento muito bacana para convergência entre o Avaya Aura rodando em uma rede com Switches HPN  modelo A7500 e A5500 (em inglês).

Os testes de compatibilidade que incluem comandos para features como Voice VLAN com QoS, LLDP-MED, PoE, etc.

Segue o link para consulta https://devconnect.avaya.com/public/download/dyn/HP7500_AA62.pdf

Caso o link esteja quebrado, avise-nos por favor!

Até mais!

Utilizando telefones Cisco em Switches HP (Comware Switches)

Esses dias pesquisando em alguns blogs na Internet tive o prazer de encontrar o blog http://kontrolissues.net e conseguir trocar alguns emails com o Chris  (administrador do site) . Após a aprovação do autor, fiz uma versão em português para o artigo “Cisco Phones on HP Comware Switches”.

O post original pode ser lido em http://kontrolissues.net/2012/10/31/cisco-phones-on-hp-comware-switches/

A tecnologia PoE (Power over Ethernet) permite a transmissão de energia eletrica em um cabo de rede UTP juntamente com os dados – para alimentar câmeras IP, Access Point, telefones IP, etc…

A Cisco foi um dos primeiros fabricantes a incluir o PoE em seus Switches chamando a feature de Inline Power para energização de telefones IP. A versão era um pouco diferente do padrão IEEE 802.3af largamente utilizada pelos Switches de mercado atualmente.

Alguns modelos de telefone do fabricante como o 7940/7960 possuem somente suporte ao padrão Inline Power.

Em Switches HPN como o modelo 5500 é possível a energização dos telefones IP com suporte a feature legada com os seguintes comandos:

[HP_E5500EI]poe legacy enable pse 4
! Configurando globalmente o PoE para a versão legada do protocolo

[HP_E5500EI]Interface giga 1/0/1
[HP_E5500EI-GigabitEthernet1/0/1]poe enable 
! Habilitando o PoE na Interface Giga1/0/1

Configuração da Vlan de Voz

Uma das grandes facilidades de atribuição dinâmica de VLAN para telefones Cisco dava-se pela comunicação entre o Telefone IP Cisco e o Switch Cisco via protocolo CDP atribuindo configurações para a VLAN de voz conforme desejo do administrador da rede. Enquanto outros fabricantes trabalhavam com os options do DHCP e posteriormente com o LLDP e o LLDP-MED devido ao fato do CDP ser exclusivo do fabricante Cisco.

Para a configuração dinâmica dos telefones para a VLAN de voz (voice vlan) em Switches HP com o sistema operacional Comware, há a possibilidade de usarmos o LLDP para atribuição dinâmica de VLAN para os pacotes de Voz ou via o OUI (Object Unique Identifier) do endereço MAC que basicamente identifica a primeira metade do endereço reservado para os fabricantes.

No exemplo abaixo mostraremos a atribuição dinâmica em Telefones Cisco em Switches HP.

“Para aqueles que realmente desejam fazer o “caminho correto”, será necessário executar os comandos “undo” nos endereços MAC cadastrados por padrão nos Switches HPN para a VLAN de Voz e incluir a configuração com as 128 linhas incluídas no final deste post. (Alguém sabe por que a Cisco queimou tantos? Sério? Isso é um monte de OUIs! Tenho certeza de que poderia ter lidado com isso com muito menos!).”

Cenário

Telefone Cisco em Switches HP

Em nosso exemplo o Cisco Call Manager (CCM) está na VLAN 10 conectada no Switch HP 5500. O telefone IP está conectado na Interface GigabitEthernet 1/0/5 e o PC está conectado ao telefone.

O tráfego de voz será tagueado na VLAN 20 e o tráfego do PC será encaminhado sem tag e deverá ser direcionado na VLAN 30 pelo Switch.

!Removendo os endereços mac-oui mapeados por padrão nos Switches.
undo voice vlan mac-address 0001-e300-0000
undo voice vlan mac-address 0003-6b00-0000
undo voice vlan mac-address 0004-0d00-0000
undo voice vlan mac-address 0060-b900-0000
undo voice vlan mac-address 00d0-1e00-0000
undo voice vlan mac-address 00e0-7500-0000
undo voice vlan mac-address 00e0-bb00-0000

! Configurando os endereço mac-oui para resolver os telefones com suporte a LLDP-MED ou CDP  
voice vlan mac-address 0000-0000-0000 mask ff00-0000-0000
voice vlan mac-address 8000-0000-0000 mask ff00-0000-0000
undo voice vlan security enable

! Ative o LLDP globalmente
lldp enable
! Habilitando o LLDP no modo compatível com CDP
lldp compliance cdp

Como você pode ver acima, em vez de ter centenas de endereços MAC cadastrados para VLAN
de Voz ... com toda a OUI Cisco (role até o fim para obter uma lista completa dos diferentes
endereços específicos da Cisco, que eu e meus colegas coletamos ao longo dos anos ), você
pode colocar tudo em uma única instrução que irá permitir que você envie a VLAN de Voz quando 
qualquer telefone Cisco conecta à rede.

! Configuração para a interface

interface GigabitEthernet1/0/5
port link-mode bridge    
port link-type trunk    
port trunk pvid vlan 30
! Configurando a porta para receber o tráfego não tagueado na VLAN 30
undo port trunk permit vlan 
! Removendo a VLAN 1 do Trunk. Não necessário para essa atividade.
port trunk permit vlan 20 30    
! Permite a porta carregar o tráfego de dados e Voz separado em cada VLAN
undo voice vlan mode auto
! Desabilita o modo automatico de VLAN de Voz 
voice vlan 20 enable       
! Anuncia a VLAN 20 como VLAN de Voz via LLDP-MED e CDP nessa porta
broadcast-suppression pps 3000
undo jumboframe enable
apply poe-profile index 1  
lldp compliance admin-status cdp txrx 
! Permite pacotes CDPv2 nessa Interface

O jeito correto vs a realidade

Como a maioria de vocês já sabem, o mundo real é bem diferente da teoria. O método que eu mostrei acima realmente funciona, e remove o fardo de ter de acompanhar os endereços MAC OUIs  exclusivos da Cisco. É o método mais seguro do mundo? Provavelmente não, mas a segurança é sempre uma troca entre o quanto é difícil de implementar e operar e como é importante para proteger o ativo de informação em questão.

A maioria das chamadas de telefone não são tão importantes para ser honesto.

Mas … para aqueles que realmente insistem em fazer o “caminho correto”, eu já incluiu esta lista não exaustiva dos endereço MAC OUIs que a Cisco colocou em seus Telefones IP ao longo dos anos. Isso é algo que eu e meus colegas  temos coletado ao longo dos anos e espero que possa ajudar. Se você conhece novos endereços, por favor adicione nos comentários que atualizaremos a lista.

Se você notar que algo mudou e essa configuração não funcionar, por favor, sinta-se livre para escrever no blog e deixe-me saber.

Lista  de telephones IP  Cisco Mac-address OUIs

voice vlan mac-address 0002-B900-0000

voice vlan mac-address 0003-6B00-0000

voice vlan mac-address 0003-E300-0000

voice vlan mac-address 0005-3200-0000

voice vlan mac-address 0005-9A00-0000

voice vlan mac-address 0005-9B00-0000

voice vlan mac-address 0006-D700-0000

voice vlan mac-address 0007-0E00-0000

voice vlan mac-address 0007-5000-0000

voice vlan mac-address 0008-2100-0000

voice vlan mac-address 000B-5F00-0000

voice vlan mac-address 000B-BE00-0000

voice vlan mac-address 000B-BF00-0000

voice vlan mac-address 000c-ce00-0000

voice vlan mac-address 000D-2900-0000

voice vlan mac-address 000D-6500-0000

voice vlan mac-address 000D-BC00-0000

voice vlan mac-address 000D-ED00-0000

voice vlan mac-address 000E-3800-0000

voice vlan mac-address 000E-8400-0000

voice vlan mac-address 000E-D700-0000

voice vlan mac-address 000F-2300-0000

voice vlan mac-address 000F-3400-0000

voice vlan mac-address 000F-8F00-0000

voice vlan mac-address 0011-2000-0000

voice vlan mac-address 0011-2100-0000

voice vlan mac-address 0011-5C00-0000

voice vlan mac-address 0011-9300-0000

voice vlan mac-address 0011-BB00-0000

voice vlan mac-address 0012-0000-0000

voice vlan mac-address 0012-7F00-0000

voice vlan mac-address 0013-1900-0000

voice vlan mac-address 0013-1A00-0000

voice vlan mac-address 0013-7F00-0000

voice vlan mac-address 0013-8000-0000

voice vlan mac-address 0013-C300-0000

voice vlan mac-address 0013-C400-0000

voice vlan mac-address 0014-1C00-0000

voice vlan mac-address 0014-6900-0000

voice vlan mac-address 0014-6A00-0000

voice vlan mac-address 0014-A900-0000

voice vlan mac-address 0014-F200-0000

voice vlan mac-address 0015-6200-0000

voice vlan mac-address 0015-2B00-0000

voice vlan mac-address 0015-F900-0000

voice vlan mac-address 0015-FA00-0000

voice vlan mac-address 0016-4600-0000

voice vlan mac-address 0016-4700-0000

voice vlan mac-address 0016-C800-0000

voice vlan mac-address 0017-0E00-0000

voice vlan mac-address 0017-5900-0000

voice vlan mac-address 0017-5A00-0000

voice vlan mac-address 0017-9400-0000

voice vlan mac-address 0017-9500-0000

voice vlan mac-address 0017-E000-0000

voice vlan mac-address 0018-1800-0000

voice vlan mac-address 0018-1900-0000

voice vlan mac-address 0018-1D00-0000

voice vlan mac-address 0018-7300-0000

voice vlan mac-address 0018-B900-0000

voice vlan mac-address 0018-BA00-0000

voice vlan mac-address 0019-0600-0000

voice vlan mac-address 0019-2F00-0000

voice vlan mac-address 0019-3000-0000

voice vlan mac-address 0019-AA00-0000

voice vlan mac-address 0019-E700-0000

voice vlan mac-address 0019-E800-0000

voice vlan mac-address 001A-2F00-0000

voice vlan mac-address 001A-6D00-0000

voice vlan mac-address 001A-A100-0000

voice vlan mac-address 001A-A200-0000

voice vlan mac-address 001B-0C00-0000

voice vlan mac-address 001B-2A00-0000

voice vlan mac-address 001B-5300-0000

voice vlan mac-address 001B-5400-0000

voice vlan mac-address 001B-D400-0000

voice vlan mac-address 001B-D500-0000

voice vlan mac-address 001C-5800-0000

voice vlan mac-address 001D-4500-0000

voice vlan mac-address 001D-A200-0000

voice vlan mac-address 001E-1300-0000

voice vlan mac-address 001E-4A00-0000

voice vlan mac-address 001E-7A00-0000

voice vlan mac-address 001E-F700-0000

voice vlan mac-address 001F-6C00-0000

voice vlan mac-address 001F-9E00-0000

voice vlan mac-address 0021-1B00-0000

voice vlan mac-address 0021-5500-0000

voice vlan mac-address 0021-A000-0000

voice vlan mac-address 0022-5500-0000

voice vlan mac-address 0022-9000-0000

voice vlan mac-address 0023-0400-0000

voice vlan mac-address 0023-5E00-0000

voice vlan mac-address 0023-EB00-0000

voice vlan mac-address 0024-9700-0000

voice vlan mac-address 0025-8400-0000

voice vlan mac-address 0026-0B00-0000

voice vlan mac-address 0026-9900-0000

voice vlan mac-address 0026-CB00-0000

voice vlan mac-address 0030-9400-0000

voice vlan mac-address 04C5-A400-0000

voice vlan mac-address 04FE-7F00-0000

voice vlan mac-address 0817-3500-0000

voice vlan mac-address 081F-F300-0000

voice vlan mac-address 108C-CF00-0000

voice vlan mac-address 18EF-6300-0000

voice vlan mac-address 1C17-D300-0000

voice vlan mac-address 2893-FE00-0000

voice vlan mac-address 3037-A600-0000

voice vlan mac-address 5475-D000-0000

voice vlan mac-address 58BC-2700-0000

voice vlan mac-address 6416-8D00-0000

voice vlan mac-address 68BD-AB00-0000

voice vlan mac-address 68EF-BD00-0000

voice vlan mac-address 6C50-4D00-0000

voice vlan mac-address 9CAF-CA00-0000

voice vlan mac-address A40C-C300-0000

voice vlan mac-address A8B1-D400-0000

voice vlan mac-address B414-8900-0000

voice vlan mac-address B4A4-E300-0000

voice vlan mac-address B8BE-BF00-0000

voice vlan mac-address D057-4C00-0000

voice vlan mac-address DC7B-9400-0000

voice vlan mac-address E804-6200-0000

voice vlan mac-address EC44-7600-0000

voice vlan mac-address ECC8-8200-0000

voice vlan mac-address F025-7200-0000

voice vlan mac-address FCFB-FB00-0000

tradução original  http://www.rotadefault.com.br/2012/11/07/utilizando-telefones-cisco-em-switches-hp/

Switches 3Com 5500 – Guia rápido de Configuração!!! Parte 2

Publicado originalmente em 30 DE DEZEMBRO DE 2010

Olá amigos, para comemorar um ótimo ano profissional e para fechar 2010 com “chave de ouro”, hoje eu escrevo a continuação do Post mais popular desse ano. “Switches 3Com 5500 – Guia rápido de Configuração!!!”

Desejo a todos um Feliz 2011!!

Syslog
[Switch]info-center loghost 10.1.1.1
Encaminhando mensagens os Logs para o Servidor de Syslog 10.1.1.1

NTP
[Switch]ntp-service unicast-server 10.1.1.2
Configurando o sincronismo do relógio com o servidor 10.1.1.2

BANNER
header motd %
=================================================================

“This system resource are restricted to Corporate official business and subject to being monitored at any time. Anyone using this network device or system resource expressly consents to such monitoring and to any evidence of unauthorized access, use or modification being used for criminal prosecution.”

=================================================================
%
Mensagem exibida para os usuários que farão acesso ao Switch. O inicio e fim da mensagem é delimitado por um caractere especial, no nosso exemplo, utilizamos o %

Atualizando o Switch via Servidor TFTP
<Switch> tftp 10.1.1.10 get s4e04_02.btm
<Switch> tftp 10.1.1.10 get s4m03_03_02s168ep05.app
Copiando os arquivos .btm e .app do Servidor de TFTP para o SWitch
<Switch>boot bootrom s4e04_02.btm
Forçando o Bootrom com o arquivo s4e04_02.btm 
<Switch> boot boot-loader s4m03_03_02s168ep05.app
Forçando o .app (Sistema Operacional) com o arquivo s4m03_03_02s168ep05.app
<Reboot>

Atribuindo as portas como Edged(portfast)
[Switch]interface Ethernet 1/0/1
[Switch-Ethernet1/0/1] stp edged-port enable
A porta configurada como edged-port entrará automaticamente em estado encaminhamento (pulando os estados iniciais do STP ou RSTP) e não gerará mensagens de notificação à topologia em caso de UP ou DOWN

STP Root Protection
[Switch]interface Ethernet1/0/3
[Switch-Ethernet1/0/3]stp root-protection
Se a porta configurada com Root-protection receber um BPDU Superior ao Root (querendo tornar-se Root no STP), a mesma não trafegará dados até cessar o recebimento dos BPDUs superiores naquela porta

Configurando SSH
[Switch] rsa local-key-pair create
Gerando as chaves RSA
[Switch] user-interface vty 0 4
[Switch-ui-vty0-4] authentication-mode scheme
[Switch-ui-vty0-4] protocol inbound ssh
Configurando modo de autenticação SOMENTE para SSH
[Switch-ui-vty0-4] quit
[Switch] local-user clientex
[Switch-luser-clientex] password simple 3com
[Switch-luser-clientex] service-type ssh level 3
Permitindo o usuário clientex conectar via SSH com permissão de administrador (3)
[Switch-luser-client2] quit
[Switch] ssh authentication-type default all

Configurando autenticação no Switch via RADIUS
radius scheme empresax
Criando o Scheme para o RADIUS chamado empresax
primary authentication 10.110.91.164 1645
Configurando o servidor de autenticação com o IP 10.110.91.164 com a porta 1645
primary accounting 10.110.91.164 1646
Configurando o servidor de contabiilidade com o IP 10.110.91.164 com a porta 1646
key authentication Swsec2011
Configurando a chave Swsec2011 compartilhada entre o RADIUS e o Switch
key accounting Swsec2011
Configurando a chave para contabilidade Swsec2011 compartilhada entre o RADIUS e o Switch
user-name-format without-domain
Configurando a autenticação para encaminhamento do usuário sem o formato nome@dominio (nome@empresax)
#
domain empresax
Criando o domínio empresax
authentication radius-scheme empresax
Efetuando o vinculo do radius empresax com o domínio empresax
#
domain default enable empresax
Na utilização de mais de um domínio, o domínio default será o domínio empresax
#
user-interface vty 0 4
authentication-mode scheme
Habilitando a utilização na interface vty 0 4 de Telnet ou SSH para utilização do RADIUS para
autenticação ao Switch

Configurando uma porta conectada a um Telefone IP e um Host (na mesma porta).
[Switch] interface ethernet 1/0/6
[Switch-Ethernet1/0/6] port link-type trunk
[Switch-Ethernet1/0/6] port trunk permit vlan 2 4
Configurando a porta para permitir a VLAN 2 ( telefonia) e VLAN 4 (Host)
[Switch-Ethernet1/0/6] port trunk pvid vlan 4
Configurando a porta para enviar e receber frames não-tagueados na VLAN 4

Port Security
[Switch] port-security enable
[Switch] interface Ethernet 1/0/1
[Switch-Ethernet1/0/1] port-security max-mac-count 1
Configurando o Port Security para permitir o aprendizado de somente um endereço MAC
[Switch-Ethernet1/0/1] port-security port-mode autolearn
Configurando o Port Security para aprender dinamicamente o endereço MAC “amarrado a porta”. Se outro endereço MAC for aprendido após o primeiro aprendizado a porta entra´ra em estado de violação e não trafegará dados! 

DHCP-Relay 
[Switch] dhcp enable
Ativando o serviço DHCP
[Switch] dhcp –server 1 ip 10.1.1.1
Adicionando o servidor DHCP 10.1.1.1 dentro do grupo 1.
[Switch] interface vlan-interface 2
[Switch-Vlan-interface2] ip address 192.168.1.1 255.255.255.0
[Switch-Vlan-interface2] dhcp-server 1
Correlacionando a VLAN-interface 2 para o grupo DHCP 1

Saúde e Sucesso a todos!!!!