Blog Archives

Dica: Descobrindo o Serial Number de Switches HPN

O comando display device manuinfo ajuda a descobrir remotamente qual o serial number (número serial) de Switches HP baseados no Comware.

Geralmente as etiquetas que vem coladas nos switches não-modulares – uma vez que os equipamentos já estão no rack – é bem complicada de se encontrar ou ler os caracteres bem pequenos em um ambiente escuro (pois é, a idade já chegou…).

<Switch5800>display device manuinfo
Slot 1:
DEVICE_NAME          : A5800AF-48G JG225A
DEVICE_SERIAL_NUMBER : XXXXXXD00P
MAC_ADDRESS          : CC3E-5F0E-XXXX
MANUFACTURING_DATE   : 2013-05-19
VENDOR_NAME          : HP

<SwitchA5500>display device manuinfo
Slot 1:
DEVICE_NAME          : A5500-24G-PoE+ EI JG241A
DEVICE_SERIAL_NUMBER : XXXXXXD00B
MAC_ADDRESS          : CC3E-5F0A-XXXX
MANUFACTURING_DATE   : 2013-09-02
VENDOR_NAME          : HP

Ps: geralmente a informação do Serial Number é utilizada para registrar o equipamento com o fabricante, solicitar garantia de suporte, inventário, etc.

Abração

Dicionário de comandos HP Networking (H3C/3Com) comparados com Cisco CLI – versão 2

A HP Network disponibilizou  a segunda versão do guia de referência de comandos como um  dicionário para comparação de features dos Switches HP, H3C/3Com (Comware), HP Provision e IOS Cisco.

dicionario HP

Para visualização ou download clique aqui

Se o link estiver quebrado, deixe um comentário…

Abração

HP Network Simulator – o simulador de equipamentos de rede HP baseado no Comware 7

Recentemente a HP liberou uma nova versão do simulador para testes de comandos e features em equipamentos HP/ H3C /3Com ( baseados no Comware). O software é chamado de Simware ou HP Network Simulator .

A notícia é muito bem vinda e aguardada há um bom tempo por aqueles que administram esses equipamentos.

O  simulador baseia-se a versão 7 do Comware (a maioria dos comandos é muito similar a versão 5 do Sistema Operacional).

Segue o link para download, dentro dele há as instruções para instalação e configuração da topologia (em inglês):

http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/swdDetails/?swItem=nw_130365_1&ac.admitted=1403627434906.876444892.199480143

ou em

http://h17007.www1.hp.com/us/en/networking/products/simulator/index.aspx#.U_U1b_ldXrR

HP Network Simulator

Obs: Um detalhe importante é a necessidade  do Virtual Box para o funcionamento do Simulador, caso você encontre  algum problema na instalação, utilize a versão 4.3.2  http://download.virtualbox.org/virtualbox/4.3.2/

Apesar da ferramenta trabalhar no modo GUI, a montagem da topologia deverá ser feita via texto em um arquivo de configuração (também explicado no manual do software).

Curtam, compartilhem e façam comentários. É um bom momento para comemorarmos. :)

Se o link estiver quebrado, deixe um comentário.

Um grande abraço

Dica: Agendando o Reboot no Comware

O Kleber Coelho, enviou a dica abaixo na qual ele precisou mexer em uma configuração sensível no Switch HP 7510 que poderia gerar a perda da gerencia do equipamento.

Inicialmente ele salvou a configuração atual do Switch. Após isso, agendou o reboot para 10 minutos (em caso de perda da gerencia, o Switch reiniciaria e voltaria a ultima configuração salva), aplicou a configuração e após o sucesso dos comandos aplicados, ele cancelou o reboot.

A configuração do schedule reboot deverá ser feita no modo “user-view”

Segue o email do Kleber:

Diego, boa tarde, tudo bem?

Recentemente precisei bloquear da divulgação do OSPF um IP de gerência local em um HP-A7510.
Se for útil para você colocar no blog, sinta-se à vontade!

# salvando a configuração atual
save force
# gatilho de reboot para garantir a recuperação, 
# caso dê algo errado e perca o acesso 
schedule reboot delay 10
# criar ACL com redes bloqueadas
system
acl number 2500 name Remove_BOGON_OSPF
# rule deny source <IP> <Wildcard>
rule deny source 192.168.255.0 0.0.0.255
rule permit
# aplicar ACL na instancia OSPF
ospf 1
filter-policy 2500 export
# Se der algo errado e perder acesso, 
#     basta esperar  o equipamento reiniciar em 10 minutos.
# Se tudo der certo, salve e remova o agendamento de reboot.
save force
quit
quit
undo schedule reboot

Agradeço ao Kleber pela dica enviada. :)

Comware: comando Send

Em empresas de médio e grande porte é comum encontramos cenários onde um ou mais administradores de rede efetuam o acesso remoto em um unico equipamento para fins de troubleshooting, etc.

O comando send , em Switches HP baseados no Comware, permite enviar uma mensagem pela própria CLI para alertar os outros usuários sobre uma determinada informação relevante, como por exemplo, a execução de um comando como o reboot.

Configurando

Primeiro, identifique com o comando display users os usuários conectados.

<Switch>display users
The user application information of the user interface(s):
Idx UI      Delay    Type Userlevel
+ 29  VTY 0   00:00:00 SSH  3
  30  VTY 1   00:00:04 SSH  0

Following are more details.

VTY 0   :
User name: fulano
Location: 192.168.208.23
VTY 1   :
User name: ciclano
Location: 192.168.208.93

+    : Current operation user.
F    : Current operation user work in async mode.

Com o comando send, é possível escolher se a informação será enviada para um determinado administrador  ou para todos os usuários conectados ao equipamento.

<Switch>send ?
INTEGER<0-44>  Specify one user terminal interface
all            All user terminal interfaces
aux            Aux user terminal interface
tty            Async serial user terminal interface
vty            Virtual user terminal interface

<Switch>send all
Enter message, end with CTRL+Z or Enter; abort with CTRL+C:
Pessoal, reiniciaremos o Switch em 2 minutos
Send message? [Y/N]:y
! Enviando a mensagem para ser impressa na tela dos outros usuários

<Switch>

***
***
***Message from con0 to con0
***
Pessoal, reiniciaremos o Switch em 2 minutos

<Switch>
! Exemplo de como o texto será exibido

Até logo.

Comware: Reset de senha via SNMP

O Paulo Roque nos enviou um procedimento muito bacana para acesso à console de um Switch HP baseado no Comware com o IRF configurado quando não se tem a senha do equipamento, mas a community SNMP ainda é conhecida (o procedimento também funciona em Switches não configurados com o IRF).

Para executar esse procedimento precisaremos de:

  • um servidor para coleta e configuração do Switch via SNMP
  • um servidor para transferência de arquivos que utilize o serviço FTP.
  • máquina para acesso via console.

Para facilitar o exemplo, o nosso cenário incluirá todos os serviços instalados em uma só máquina, conforme desenho abaixo.

A máquina 192.168.1.40 está com o serviço SNMP e  FTP instalados , além do cabo console diretamente conectado do notebook ao Switch.

SNMP Comware Password Reset

  1. Teste  a conectividade com o Switch via SNMP
# snmpwalk -v 2c -c pri123 192.168.1.1 .1.3.6.1.2.1.1

SNMPv2-MIB::sysDescr.0 = STRING: H3C Comware software. H3C S12508 Product Version 
S12500-CMW520-R1728P01. Copyright (c) 2004-2012 Hangzhou H3C Tech. Co., Ltd. All rights reserved.
SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.25506.1.391
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (1672958598) 193 days, 15:06:25.98
SNMPv2-MIB::sysContact.0 = STRING: NOC-teste @ +55 11 aaaa bbbb
SNMPv2-MIB::sysName.0 = STRING: Switch-teste
SNMPv2-MIB::sysLocation.0 = STRING: Hangzhou, China
SNMPv2-MIB::sysServices.0 = INTEGER: 78
  1. Faça o download da configuração do Switch para o servidor FTP
#snmpset -v 2vc -c pri123 192.168.1.1 \
1.3.6.1.4.1.25506.2.4.1.2.4.1.2.2 i 3 \
1.3.6.1.4.1.25506.2.4.1.2.4.1.3.2 i 1 \
1.3.6.1.4.1.25506.2.4.1.2.4.1.4.2 s aa.cfg \
1.3.6.1.4.1.25506.2.4.1.2.4.1.5.2 a 192.168.1.40 \
1.3.6.1.4.1.25506.2.4.1.2.4.1.6.2 s ftpuser \
1.3.6.1.4.1.25506.2.4.1.2.4.1.7.2 s 123senha \
1.3.6.1.4.1.25506.2.4.1.2.4.1.9.2 i 4

O Sistema irá returnar a seguinte informação:

iso.3.6.1.4.1.25506.2.4.1.2.4.1.2.2 = INTEGER: 3
iso.3.6.1.4.1.25506.2.4.1.2.4.1.3.2 = INTEGER: 1
iso.3.6.1.4.1.25506.2.4.1.2.4.1.4.2 = STRING: "aa.cfg"
iso.3.6.1.4.1.25506.2.4.1.2.4.1.5.2 = IpAddress: 192.168.1.40
iso.3.6.1.4.1.25506.2.4.1.2.4.1.6.2 = STRING: "ftpuser"
iso.3.6.1.4.1.25506.2.4.1.2.4.1.7.2 = STRING: "123senha"
iso.3.6.1.4.1.25506.2.4.1.2.4.1.9.2 = INTEGER: 4
  1. Ao efetuar o download do arquivo, caso o Switch não esteja configurado com a autenticação por TACACS/RADIUS,  abra o arquivo de configuração e veja se a senha foi configurada como não-cifrada. Nesse caso,  se for possível detectar a senha, descarte todos os processos abaixo  e faça a autenticação no Switch com  a senha escrita no arquivo de configuração.

Se o procedimento acima não resolver para efetuar a autenticação ao Switch, continue com os passos abaixo para alterar a configuração corrente do Switch via SNMP e assim desabilitar o processo de autenticação da console do equipamento

  1. Crie um arquivo chamado “passreset.cfg” e insira a seguinte configuração:
user-interface aux 0 1
 authentication-mode none

obs: o nome do arquivo é apenas sugestivo

  1. Salve o arquivo no servidor FTP
  2. Utilize o servidor FTP para transferência do arquivo para o Switch  e via snmpset  envie os atributos abaixo via SNMP para o Switch (o equipamento irá solicitar o download da configuração ao servidor ftp pela instruções utilizadas via SNMP).
# snmpset -v 2c -c pri123 192.168.1.1 \
1.3.6.1.4.1.25506.2.4.1.2.4.1.2.3 i 4 \
1.3.6.1.4.1.25506.2.4.1.2.4.1.3.3 i 1 \
1.3.6.1.4.1.25506.2.4.1.2.4.1.4.3 s passreset.cfg \
1.3.6.1.4.1.25506.2.4.1.2.4.1.5.3 a 192.168.1.40 \
1.3.6.1.4.1.25506.2.4.1.2.4.1.6.3 s ftpuser \
1.3.6.1.4.1.25506.2.4.1.2.4.1.7.3 s 123senha \
1.3.6.1.4.1.25506.2.4.1.2.4.1.9.3 i 4

O Sistema irá retornar as seguintes informações:

iso.3.6.1.4.1.25506.2.4.1.2.4.1.2.3 = INTEGER: 4
iso.3.6.1.4.1.25506.2.4.1.2.4.1.3.3 = INTEGER: 1
iso.3.6.1.4.1.25506.2.4.1.2.4.1.4.3 = STRING: "passreset.cfg"
iso.3.6.1.4.1.25506.2.4.1.2.4.1.5.3 = IpAddress: 192.168.1.40
iso.3.6.1.4.1.25506.2.4.1.2.4.1.6.3 = STRING: "ftpuser"
iso.3.6.1.4.1.25506.2.4.1.2.4.1.7.3 = STRING: "123senha"
iso.3.6.1.4.1.25506.2.4.1.2.4.1.9.3 = INTEGER: 4

O comando snmpset permitirá que o Switch faça o download do arquivo passreset.cfg do FTP e assim aplicar as configurações na configuração corrente (memória RAM [current-configuration]) sem alterar as outras configurações do equipamento.

Nesse caso, será removida a autenticação da console, permitindo o acesso como adminsitrador ao Switch.

Para uma descrição completa das “MIBs” do fabricante (em inglês) acesse: http://www.h3c.com/portal/Products___Solutions/Technology/System_Management/Configuration_Example/200912/656452_57_0.htm#_Toc247357229

Abração e até o próximo artigo! ;)

Atualizando o Switch via TFTP com IPv6 em Switches HP 5120

Segue abaixo um script para atualização do Comware em um Switch HP 5120 utilizando o protocolo IPv6 como transporte. A atividade é bem simples (como em IPv4) e nos ajuda a desmistificar e nos encorajar a utilizar cada vez mais o “novo” serviço. O procedimento é o mesmo para a maioria dos Switches com o Sistema Operacional Comware (3com/H3C/HPN).

<Switch>system

[Switch] ipv6
[Switch] interface vlan 1
[Switch-Vlan-Interface-1]ipv6 address 2001:db8::2/64
[Switch-Vlan-Interface-1]quit
[Switch] quit

<Switch>
<Switch>tftp ipv6 2001:db8:1 put flash:/a5120ei-cmw520-r2208p01-s168.bin
! Fazendo backup da imagem antiga para o Servidor TFTP

<Switch>delete /unreserved a5120ei-cmw520-r2208p01-s168.bin
The contents cannot be restored!!! Delete flash:/a5120ei-cmw520-r2208p01-s168.bin?[Y/N]:y
! Devido a falta de espaçoo para manter a imagem nova e a velha nesse modelo de Switch, 
! iremos deletar a imagem mais antiga.
! O comando /unreserved deleta a imagem sem jogar na lixeira da memória flash

<Switch> tftp ipv6 2001:db8::1 get A5120EI-CMW520-R2220P02.bin
! Copiando a nova imagem para o Switch

<Switch>boot-loader file flash:/a5120ei-cmw520-r2220p02.bin slot all main
This command will set the boot file of the specified board. Continue? [Y/N]:y
! Configurando a nova imagem para "bootar" após o Switch reiniciar

<Switch>disp boot-loader
Slot 1
The current boot app is:  flash:/a5120ei-cmw520-r2208p01-s168.bin
The main boot app is:     flash:/a5120ei-cmw520-r2220p02.bin
The backup boot app is:   flash:/

<Switch>reboot
Start to check configuration with next startup configuration file, please wait.........DONE!
This command will reboot the device. Current configuration will be lost, save current configuration? [Y/N]:y
This command will reboot the device. Continue? [Y/N]:y
Reboot device by command.
! Reiniciando o Switch

<HP>display version
HP Comware Platform Software
Comware Software, Version 5.20.99, Release 2220P02
Copyright (c) 2010-2013 Hewlett-Packard Development Company, L.P.
HP A5120-48G EI Switch uptime is 0 week, 0 day, 0 hour, 2 minutes
! Validando o Upgrade

<HP>display boot-loader
Slot 1
The current boot app is:  flash:/a5120ei-cmw520-r2220p02.bin
The main boot app is:     flash:/a5120ei-cmw520-r2220p02.bin
The backup boot app is:

Pronto, imagem atualizada! ;)
O Software utilizado para copia da imagem foi o TFTPd64 by Ph. Jounin para Windows

 

Download de software para Switches e Roteadores HP

Pessoal, segue a dica com a URL para fazer o download de software (Sistema Operacional) dos equipamentos HPN.

https://h10145.www1.hp.com/downloads/ProductsList.aspx?lang=&cc=&prodSeriesId=

Para encontrar a versão correspondente do Comware para o seu equipamento, basta digitar o Part Number ou o modelo.

1 Download de software

Antes de baixar alguma versão, vale a pena ler as features disponíveis e erros corrigidos no release notes! ;)

Download de software

Abração

Receita de Bolo: Configurando usuário, senha, autenticação via SSH, Telnet e Console em Switches HP

Acesso Telnet SSH e Console

Dicas para usar o “display current-configuration”

Dicas para usar o “display current-configuration”

Navegando pela internet descobri em alguns blogs dicas interessantes para visualizar a configuração em equipamentos com o Comware (Switches e Roteadores 3Com, H3C e HPN). Como no site: http://configureterminal.com/hp-comware/

Fiz uma pequena adaptação em português para alguns comandos que podem ser bastante úteis.

 display this

O comando display this exibe a configuração baseado na “view” de acesso. Por exemplo, se estivermos aplicando a configuração em uma interface GigabitEthernet, o comando display this exibirá as configurações aplicadas na interface.

[HP]
[HP]interface  GigabitEthernet 1/0/1
[HP-Ethernet1/0/1]display this
#
interface GigabitEthernet1/0/1
 port link-mode route
 ip address 159.63.229.149 255.255.255.252
#

display current-configuration

O comando display current-configuration exibe  a configuração aplicada corrente na “memória RAM” do equipamento. É possível extrair algumas “dicas” do comando visualizando as opções:

[HP]disp current-configuration ?
  by-linenum     Display configuration with line number
  configuration  The pre-positive and post-positive configuration information
  exclude        Display current configuration without specified module
  interface      The interface configuration information
  |              Matching output

by-linenum

O “sufixo” by-lineum permite exibir a configuração numerada, como por exemplo, facilitando o troubleshooting remoto para identificar a linha que deseja demonstrar ao outro técnico.

[HP]display current-configuration by-linenum
    1:  #
    2:   version 5.20, Release 9101
    3:  #
    4:   sysname SW1
    5:  #
    6:   undo voice vlan mac-address 00e0-bb00-0000
    7:  #
    8:   domain default enable system
    9:  #
   10:   ip unreachables enable
   11:  #
   12:   lldp enable
   13:  #
   14:   rpr mac-address timer aging 100
   15:  #
   16:  vlan 1
   17:  #
   18:  domain system
   19:   access-limit disable
  ---- More ----

configuration

O “sufixo” configuration permite exibir a configuração de determinado processo…

[HP]disp current-configuration configuration ?
  attack-defense-policy  Display Attack-defense-policy configuration
  bgp                    Display Bgp configuration
  by-linenum             Display configuration with line number
  isp                    Display Isp configuration
  post-system            Display Post-system configuration
  route-policy           Display Route-policy configuration
  system                 Display System configuration
  ugroup                 Display Ugroup configuration
  user-interface         Display User-interface configuration
  wlan-rrm               Display Wlan-rrm configuration
  |                      Matching output

[SW1]display  current-configuration configuration bgp
#
bgp 65012
 import-route direct
 undo synchronization
 peer 172.16.0.2 as-number 65000
 peer 172.16.0.2 advertise-community
 peer 172.16.0.2 substitute-as
#
return

Pipe |

A utilização do “|” permite selecionarmos apenas parte da configuração para ser exibida , incluindo a utilização de algumas expressões regulares. O “include” exibe apenas parte da configuração que contêm a palavra selecionada, o “begin” exibe a configuração a partir da primeira palavra encontrada e o “exclude” exibe a configuração sem a palavra selecionada.

[HP]display current-configuration | ?
  begin    Begin with the line that matches
  exclude  Match the character strings excluding the regular expression
  include  Match the character strings including with the regular expression

No exemplo abaixo, utilizaremos o include para visualizar a parte da configuração que inclua a palavra “face”

[HP]display current-configuration | include face
interface NULL0
interface GigabitEthernet1/0/1
interface GigabitEthernet1/0/2
interface GigabitEthernet1/0/3
interface GigabitEthernet1/0/4
interface GigabitEthernet1/0/5
interface GigabitEthernet1/0/6
interface GigabitEthernet1/0/7
interface GigabitEthernet1/0/8
interface GigabitEthernet1/0/9
interface GigabitEthernet1/0/10
interface GigabitEthernet1/0/11
interface GigabitEthernet1/0/12
interface GigabitEthernet1/0/13
interface GigabitEthernet1/0/14
interface GigabitEthernet1/0/15
interface GigabitEthernet1/0/16
interface GigabitEthernet1/0/17
interface GigabitEthernet1/0/18
interface GigabitEthernet1/0/19
interface GigabitEthernet1/0/20
interface GigabitEthernet1/0/21
interface GigabitEthernet1/0/22
  ---- More ----

[HP]display  current-configuration | include ^v
vlan 1
vlan 2 to 4
vlan 10
vlan 20
vlan 30
vlan 40

Outros inumeros exemplos podem ser utilizados com expressões regulares para filtro de exibição da configuração.

A utilização do “begin” exibe a configuração a partir da primeira palavra encontrada (parte da palavra).

[HP]display current-configuration | begin Ten
interface Ten-GigabitEthernet1/0/25
 port link-type trunk
 port trunk permit vlan 1 20
#
interface Ten-GigabitEthernet1/0/26
#
interface Ten-GigabitEthernet1/0/27
#
interface Ten-GigabitEthernet1/0/28
#
user-interface aux 0
user-interface vty 0 15
#
return
[HP]

outros comandos interessantes para visualizar a configuração são os caracteres “/” or “+” or “-“:

/ o mesmo que “begin”
+ o mesmo que “include”
- o mesmo que “exclude”

O primeiro primeiro passo é digitar o ” display current”

[HP]display current-configuration
#
 version 5.20, Release 1110P05
#
 sysname HP
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
#
 domain default enable system
#
 telnet server enable
#
vlan 1
#
radius scheme system
 server-type extended
 primary authentication 127.0.0.1 1645
 primary accounting 127.0.0.1 1646
 user-name-format without-domain
#
domain system
 access-limit disable
  ---- More ----

Quando o “—More—” aparecer para a paginação da configuração, digite a tecla “/” mais a palavra para filtro da configuração. Em nosso exemplo usaremos “/Ten”:

/Ten
filtering...
interface Ten-GigabitEthernet1/0/25
 port link-type trunk
 port trunk permit vlan 1 10
#
interface Ten-GigabitEthernet1/0/26
#
interface Ten-GigabitEthernet1/0/27
#
interface Ten-GigabitEthernet1/0/28
#
ospf 1
 area 0.0.0.0
  network 10.1.1.1 0.0.0.0
  network 10.1.2.1 0.0.0.0
#
 load xml-configuration
#
user-interface aux 0
user-interface vty 0 15
#
return
[HP]

Utilize o “-” para não exibir parte da da configuração. Em nosso exemplo, “net”:

-net

filtering...
#
interface NULL0
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
#
 port link-mode bridge
  ---- More ----

Até logo! ;)