IRF em Switches HP 5500 (JG543A) utilizando módulo traseiro

Essa semana troquei alguns emails com o Samuel Alencar de Fortaleza/CE, sobre a configuração de um IRF em Switches HP 5500 (JG543A) utilizando o módulo traseiro com interfaces CX4 (JD360B).

Ele foi bastante gentil em compartilhar com o Blog o script final da configuração. Aproveitem!

IRF 5500

CONFIGURAÇÃO DO SWICTH A

PASSO 0

<HP> reset saved-configuration
<HP> reboot
! reinicie o switch e não salve a configuração.


PASSO 3

[HP] irf member 1 priority 32
[HP] int tengigabitethernet 1/1/1
[HP –Ten-GigabitEthernet1/1/1] shutdown

[HP] irf-port 1/1
[HP – irf-port] port group interface tem 1/1/1
[HP] int TenGigabitEthernet 1/1/1
[HP –Ten-GigabitEthernet1/1/1] undo shutdown
[HP] irf-port-configuration active
[HP] save

 

CONFIGURAÇÃO DO SWICTH B

PASSO 1

! Desconecte os cabos do IRF
<HP> reset saved-configuration
<HP> reboot
! reinicie o switch e não salve a configuração.

 

PASSO 2

[HP] irf member  1 renumber 2
[HP] quit
<HP> reboot


PASSO 4

[HP] irf member 2 priority 31
[HP] int tengigabitethernet 2/2/2
[HP –Ten-GigabitEthernet2/2/2] shutdown

[HP] irf-port 2/2
[HP – irf-port] port group interface tem 2/2/2
[HP] int TenGigabitEthernet 2/2/2
[HP –Ten-GigabitEthernet2/2/2] undo shutdown
[HP –Ten-GigabitEthernet2/2/2] quit
[HP] irf-port-configuration active
[HP] save
! Reconecte os cabos e se o switch não reiniciar automaticamente, digite
! o comando 'irf-port-configuration active'.

[HP]quit
<HP>reboot

Para outros artigos sobre IRF clique aqui http://www.comutadores.com.br/?s=irf

Abração

Configurando IRF em Roteadores HP MSR

Os novos Roteadores MSR da HP possuem suporte para a configuração em IRF. O IRF é uma tecnologia que permite transformarmos diversos Switches ou Roteadores físicos em um único equipamento lógico. Todos os equipamentos serão visualizados como uma única “caixa”, aumentando a disponibilidade da rede.

A recomendação é efetuar o IRF com equipamentos da mesma família e modelo, mas há dispositivos que suportam equipamento da mesma família, mas com diferentes modelos. É bom pesquisar caso a caso.

O cenário abaixo foi construído utilizando o simulador HCL utilizando 2 Roteadores em IRF conectando um Router-Aggregation com um Switch 5820.

MSR em IRF

Configurando o IRF

Segue abaixo o passo-a-passo da configuração:

1º altere o irf-member ID do segundo Roteador (por padrão o member ID é 1) e o priority de cada equipamento para eleição do Master (vence o maior valor).

R1
<ROUTER>system
[ROUTER]irf priority 31

R2
<ROUTER>system
[ROUTER]irf member 2
[ROUTER]irf priority 30

Configurando as IRF-port

R1
[ROUTER]irf-port 1
[ROUTER-irf-port1]port group interface GigabitEthernet 0/0
[ROUTER-irf-port1]quit

R2
[ROUTER]irf-port 2
[ROUTER-irf-port2]port group interface GigabitEthernet 0/0
[ROUTER-irf-port2]quit

Habilitando o IRF

R1
[ROUTER]chassis convert mode irf
The device will switch to IRF mode and reboot.
You are recommended to save the current running configuration and specify the configuration file for the next startup. Continue? [Y/N]:y
Do you want to convert the content of the next startup configuration file flash:/startup.cfg to make it available in IRF mode? [Y/N]:y
Now rebooting, please wait...

R2
[ROUTER]chassis convert mode irf
....

Comandos display

[ROUTER]display irf

MemberID   Role   Priority CPU-Mac       Description
*+1       Master 31       90eb-4082-0100 ---
2       Standby 30       94cc-d87d-0200 ---
--------------------------------------------------
* indicates the device is the master.
+ indicates the device through which the user logs in.
The Bridge MAC of the IRF is: 90eb-4082-0100
Auto upgrade               : yes
Mac persistent             : 6 min
Domain ID                   : 0
Auto merge                 : yes

 

[ROUTER]display irf configuration
MemberID NewID   IRF-Port1                    IRF-Port2
1       1       GigabitEthernet1/0/0         disable
2       2       disable                       GigabitEthernet2/0/0

 

Configurando o Router-Aggregation nos MSRs em IRF

[ROUTER]interface Route-Aggregation 1
[ROUTER-Route-Aggregation1]link-aggregation mode dynamic
[ROUTER-Route-Aggregation1]ipv6 address 2001:db8:1234::a 64
[ROUTER-Route-Aggregation1]disp this

#
interface Route-Aggregation1
link-aggregation mode dynamic
ipv6 address 2001:DB8:1234::A/64
#
return
[ROUTER-Route-Aggregation1]quit

[ROUTER]interface GigabitEthernet 1/0/1
[ROUTER-GigabitEthernet1/0/1]port link-aggregation group 1
[ROUTER-GigabitEthernet1/0/1]interface GigabitEthernet 2/0/1
[ROUTER-GigabitEthernet2/0/1]port link-aggregation group 1
[ROUTER-GigabitEthernet2/0/1]end

Configuração do Switch

#
interface Bridge-Aggregation1
link-aggregation mode dynamic
#
#
interface GigabitEthernet1/0/1
port link-mode bridge
combo enable fiber
port link-aggregation group 1
#
interface GigabitEthernet1/0/2
port link-mode bridge
combo enable fiber
port link-aggregation group 1
#
interface Vlan-interface1
ipv6 address 2001:DB8:1234::B/64
#
[Router]disp link-aggregation verbose
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected, I – Individual
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
D -- Synchronization, E -- Collecting, F -- Distributing,
G -- Defaulted, H -- Expired

Aggregate Interface: Route-Aggregation1
Aggregation Mode: Dynamic
Loadsharing Type: Shar
System ID: 0x8000, 90eb-4082-0100

Local:
Port             Status Priority Oper-Key Flag
--------------------------------------------------------------------------------
GE1/0/1         S       32768   1        {ACDEF}
GE2/0/1         S       32768   1         {ACDEF}
Remote:
Actor           Partner Priority Oper-Key SystemID               Flag
--------------------------------------------------------------------------------
GE1/0/1         3       32768   1         0x8000, 94de-65c3-0300 {ACDEF}
GE2/0/1         2       32768   1         0x8000, 94de-65c3-0300 {ACDEF}

 

[Router]ping ipv6 2001:db8:1234::b
Ping6(56 data bytes) 2001:DB8:1234::A --> 2001:DB8:1234::B, press CTRL_C to break
56 bytes from 2001:DB8:1234::B, icmp_seq=0 hlim=64 time=2.000 ms
56 bytes from 2001:DB8:1234::B, icmp_seq=1 hlim=64 time=1.000 ms
56 bytes from 2001:DB8:1234::B, icmp_seq=2 hlim=64 time=0.000 ms
56 bytes from 2001:DB8:1234::B, icmp_seq=3 hlim=64 time=1.000 ms
56 bytes from 2001:DB8:1234::B, icmp_seq=4 hlim=64 time=1.000 ms

--- Ping6 statistics for 2001:db8:1234::b ---
5 packets transmitted, 5 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 0.000/1.000/2.000/0.632 ms
[Router]%Jan 26 13:40:07:783 2016 Router PING/6/PING_STATISTICS: Ping6 statistics for
2001:db8:1234::b: 5 packets transmitted, 5 packets received, 0.0% packet loss, round-trip
min/avg/max/std-dev = 0.000/1.000/2.000/0.632 ms.

Até logo

 

IRF – Limitação da Topologia em Anel para alguns modelos

No mês de março/15 eu publiquei um post sobre o design de Switches em IRF, configurados em linha (cascateado) ou em anel na construção do IRF.

http://www.comutadores.com.br/irfv2-duvidas-na-configuracao-do-irf-port/

Esse mês a HP soltou uma notificação sobre a limitação de alguns modelos para a construção do IRF Fabric em anel com somente 2 Switches.

Type of Switch Is IRF Ring Topology Supported With Only Two Units?
3100V2_48 Yes
3600V2 Yes
5120EI Yes
5120SI Yes
5130EI Yes
5500SI Yes
5500EI Yes
5500HI Yes
5700 Yes
5800/5820X Yes
5830 Yes
5900/5920 Yes
5930 Yes
7500 No
7900 No
10500 No
11900 No
12500 No
12900 No

“Três ou mais unidades em IRF irão  sempre suportar uma configuração em anel .”

O documento original está em http://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c04706976

IRFv2: dúvidas na configuração do irf-port

Esses dias durante a implantação de  Switches HP 5900 em 2 diferentes Datacenters, configurei o IRF dos Switches de duas maneiras diferentes, mas ambas utilizando 4 portas 10Gb:

No Datacenter A a configuração de IRF entre os Switches foi executada com duas irf-port em cada Switch enquanto no Datacenter B a configuração de IRF foi executada com apenas uma irf-port por Switch.

Datacenter A:

irf-port 1/1
port group interface Ten-GigabitEthernet1/0/1
port group interface Ten-GigabitEthernet1/0/2
#      
irf-port 1/2
port group interface Ten-GigabitEthernet1/0/3
port group interface Ten-GigabitEthernet1/0/4
#
irf-port 2/1
port group interface Ten-GigabitEthernet2/0/3
port group interface Ten-GigabitEthernet2/0/4
#
irf-port 2/2
port group interface Ten-GigabitEthernet2/0/1
port group interface Ten-GigabitEthernet2/0/2
#
[5900-DC-A]display irf link 
Member 1
IRF Port    Interface                       Status
1            Ten-GigabitEthernet1/0/1        UP    
             Ten-GigabitEthernet1/0/2        UP    
2            Ten-GigabitEthernet1/0/3        UP    
             Ten-GigabitEthernet1/0/4        UP   
Member 2
IRF Port    Interface                       Status
1            Ten-GigabitEthernet2/0/3        UP   
             Ten-GigabitEthernet2/0/4        UP 
2            Ten-GigabitEthernet2/0/1        UP    
             Ten-GigabitEthernet2/0/2        UP    

Datacenter B:

irf-port 1/2
port group interface Ten-GigabitEthernet1/0/1
port group interface Ten-GigabitEthernet1/0/2
port group interface Ten-GigabitEthernet1/0/3
port group interface Ten-GigabitEthernet1/0/4
#
irf-port 2/1
port group interface Ten-GigabitEthernet2/0/1
port group interface Ten-GigabitEthernet2/0/2
port group interface Ten-GigabitEthernet2/0/3
port group interface Ten-GigabitEthernet2/0/4
#
[5900-DC-B]display irf link
Member 1
IRF Port    Interface                       Status
1           disable                         -
2           Ten-GigabitEthernet1/0/1         UP    
             Ten-GigabitEthernet1/0/2        UP    
             Ten-GigabitEthernet1/0/3        UP    
             Ten-GigabitEthernet1/0/4        UP   
Member 2
IRF Port    Interface                       Status
1           Ten-GigabitEthernet2/0/1         UP
             Ten-GigabitEthernet2/0/2        UP    
             Ten-GigabitEthernet2/0/3        UP   
             Ten-GigabitEthernet2/0/4        UP
 2           disable                         --    

Encaminhamos as seguintes questões para o time de HPN:

–          Qual a diferença na prática entre os 2 cenários?

–          Qual dos dois seria o mais recomendado?

Recebemos a seguinte recomendação:

De fato esta pergunta é muito comum, pois como criamos duas portas virtuais IRF (x/1 e x/2), sempre existe esta dúvida no caso de implementação de um par de switches. Bem, para um par de switches, não existe diferença lógica das duas implementações e também não existe benefícios de uma ou de outra, como o exemplo abaixo destas configurações:

IRF blocos 1

A diferença realmente ocorre quando você precisa configurar três ou quatro unidades, pois neste caso você precisa criar uma topologia em anel, conforme o desenho, e isso requer a configuração das portas 1 e 2 devidamente conectadas:

IRF blocos 2

Contudo, novamente, para um par de switches não tem diferença.

My cents

Script para configuração do IRFv2 em Switches HPN 5800

IRFv2 5800

 

Switches HP A7500 – IRF v2 MAD + BFD

O protocolo IRF v2 permite o “empilhamento” de Switches modulares e empilháveis, trazendo inúmeras vantagens como redundância, facilidade no gerenciamento, etc.

Como citado em outros posts, um dos problemas que o IRF pode trazer ocorre quando há uma quebra do Link 10G que mantém o IRF ativo, chamado de SPLIT. Cada caixa ira agir como se fosse o MASTER do IRF, duplicando alguns serviços e trazendo diversos conflitos na Rede.

Multi-Active Detection (MAD) + BFD (Bidirecional Forwarding Detection)

O MAD é uma das formas para os Switches do Stack detectarem o SPLIT no IRF colocando o Equipamento com o maior Member ID do IRF (não Master) em modo Recovery, bloqueando assim todas as suas portas.

Uma das técnicas para detecção do SPLIT é com é com a utilização do protocolo BFD, criando uma VLAN somente para gerenciamento do IRF com um IP primário e secundário para comunicação do protocolo e um meio físico para conexão das “caixas” (fibra ou UTP) independente da comunicação do IRF.

Configuração

A configuração abaixo deverá ser aplicada somente no Switch com o IRF versão 2 formado.

#
Vlan 900
#
interface Vlan-interface900
description Monitoracao IRFv2 (MAD + BFD)
mad bfd enable
!Ativando o MAD + BFD
mad ip address 192.168.0.1 255.255.255.252 member 1
! Configurando o IP do Switch “1”
mad ip address 192.168.0.2 255.255.255.252 member 2
! Configurando o IP do Switch “2”
#
Obs: cada Switch deverá ter uma porta na VLAN 900 para comunicação do BFD. 
As interfaces não participarão do STP.

Comandos Display

[S7500] display mad
MAD LACP enabled.

Comando display após SPLIT do IRF no Switch não Master
[S7500]display mad verbose
Current MAD status: Detect
! Em caso de SPLIT o Switch não-Master exibiria o status como Recovery
Excluded ports(configurable):
Excluded ports(cannot be configured):
Ten-GigabitEthernet1/8/0/1
Ten-GigabitEthernet1/9/0/2
Ten-GigabitEthernet2/8/0/1
Ten-GigabitEthernet2/9/0/2
MAD LACP disabled.
MAD BFD enabled interface:
Vlan-interface900
mad ip address 192.168.0.1 255.255.255.252 member 1
mad ip address 192.168.0.2 255.255.255.252 member 2

Switches HP A7500 – IRF v2 utilizando LACP com MAD

Uma das coisas bacanas da utilização do IRF é a possibilidade de transformarmos diversos Switches físicos em um único Switch lógico facilitando o modo de gerenciamento. Todos os equipamentos serão visualizados como uma única “caixa”. Na versão 2 do protocolo é possível efetuar o Stacking utilizando links de 10G ( como por exemplo fibra, cabo CX4, etc).

Uma das features que podem ser utilizadas nesse cenário é a utilização de Link Aggregation distribuído (Ditribuited Link Aggregation) entre os equipamentos do IRF com Switches de acesso (sem configuração adicional no Link Aggregation).

Se um Switch empilhado apresentar algum problema, como por exemplo, problemas elétricos, o(s) outro(s) Switches serão capazes de permitir a continuidade do encaminhamento em Camada 2 e 3 (incluindo processos de Roteamento Dinâmico).

Porém, um dos problemas que o IRF pode trazer é quando ocorre uma quebra do Link 10G que mantém o IRF ativo, chamado de SPLIT. Cada caixa ira agir como se fosse o MASTER do IRF, duplicando alguns serviços e trazendo diversos conflitos na Rede.

Multi-Active Detection (MAD)

O MAD é uma das formas para os Switches do Stack detectarem que houve o SPLIT no IRF colocando o Equipamento com o maior Member ID do IRF (não Master) em modo Recovery, bloqueando assim todas as suas portas.

Após restaurado o Link do IRF as portas serão vinculadas novamente o Stack e ao seu estado normal de encaminhamento.

Uma das formas utilizadas pelo MAD para detecção de falha é utilizando uma extensão do protocolo LACP ( Link Aggregation). No TLV do protocolo é inserido o ID do Switch membro do IRF. Nesse caso os Switches da outra ponta do Link Aggregation, encaminham de forma transparente os LACP’s para os Switches Membros do IRF.

Como no exemplo acima, se não há SPLIT no IRF, todas mensagens serão geradas pelo ID do MASTER.

Em caso de quebra do SPLIT as mensagens serão geradas com o ID de cada equipamento e nesse caso o bloqueio das portas do não-Master.

Após detecção as portas bloqueadas do IRF pelo LACP com MAD.

Configuração

A configuração abaixo deverá ser aplicada somente no Switch com o IRF versão 2 “já ativo”.

[S7500]interface bridge-aggregation 1
!Criando a Interface Bridge-Aggregation 1
[S7500-Bridge-Aggregation1] link-aggregation mode dynamic
! Ativando a troca do protocol LACP no Link Aggregation
[S7500-Bridge-Aggregation1] mad enable
! Ativando a extensão MAD no protocol LACP
[S7500-Bridge-Aggregation1] quit
[S7500] interface gigabitethernet 1/3/0/2
[S7500-GigabitEthernet1/3/0/2] port link-aggregation group 1
!Adicionando a interface ao Link Aggregation 1
[S7500-GigabitEthernet1/3/0/2] quit
[S7500] interface gigabitethernet 2/3/0/2
[S7500-GigabitEthernet2/3/0/2] port link-aggregation group 1
!Adicionando a interface ao Link Aggregation 1
[S7500-GigabitEthernet2/3/0/2] quit

Obs: Os switches de acesso conectados ao IRF pelo Link Aggregation não necessitam da configuração do MAD. Mas o fabricante sugere que esse Switch seja um equipamento H3C.

“Requires an intermediate switch, which must be an H3C switch that supports the extended LACP.”

Comandos Display

S7500] display mad
MAD LACP enabled.

Comando display após SPLIT do IRF no Switch não Master

[S7500]display mad verbose
Current MAD status: Recovery
! Switch não-Master em modo recovery após perceber o SPLIT no IRF
! (bloqueando todas as portas)
…………………………

MAD enabled aggregation port:
Bridge-Aggregation1

Obs: o modo Recovery também permite excluímos algumas portas para que continuem em estado de encaminhamento. Há também um segundo modo de utilizar o MAD para detecção de SPLIT utilizando o Protocolo BFD.

Referência:

http://www.h3c.com/portal/Technical_Support___Documents/Technical_Documents/Switches/H3C_S5800_…

Abraços a todos

Video: IRF – A technical white board session

A HP Networking tem criado alguns vídeos bem interessantes de tecnologia voltado as suas áreas de pesquisa e produtos. O vídeo abaixo foca na utilização do protocolo IRF em Switches HP para simplificar a topologia, melhorar a redundância, alta disponibilidade da rede e a distribuição dos Switches da LAN em camadas (infelizmente o conteúdo está em inglês mas vale a pena assistir – em caso de dificuldades ative o Close Caption). 😉

Até logo!

Switches HP A7500 – Configurando o IRF versão 2

Publicado originalmente em 8 DE OUTUBRO DE 2010

O IRF é uma tecnologia que permite transformarmos diversos Switches físicos em um único Switch lógico. Todos os equipamentos serão visualizados como uma única “caixa”, aumentando a disponibilidade da rede.

Uma das facilidades da versão 2 é a possibilidade de utilizarmos interfaces 10G para a construção IRF (sem a necessidade de cabos ou módulos específicos ) e a utilização de Switches Modulares para construção da topologia.

Configuração

A configuração do IRF é dividida nos passos abaixo ( utilizaremos[Sw1] e [Sw2] antes dos comandos para diferenciarmos os dispositivos):

1º Converta os 2 Switches no modo IRF

[Sw1]chassis convert mode irf
! Convertendo o Switch 1 no modo IRF

[Sw2]chassis convert mode irf
! Convertendo o Switch 2 no modo IRF

Após a conversão dos Chassis para modo IRF, reinicie os Switches. Os equipamentos subirão com a configuração dos módulos como 1/2/0/1 ( para a porta antes exibida na configuração como 2/0/2; e assim por diante)

2º Renumere o Segundo Switch 

[Sw2]irf member 1 renumber 2
! Forçaremos as portas do Switch 2 para exibirem no formato 2/2/0/x

Reinicie o Switch

3º Altere a prioridade do Switch Master

[Sw1]irf member 1 priority 32
! O Switch com maior prioridade será eleito o Master ( por default a prioridade de todos os Switches será 1)

4º Deixe as portas 10G que participarão do IRF em shutdown.

[Sw1] interface Ten-GigabitEthernet1/3/0/2
[Sw1-Ten-GigabitEthernet1/3/0/2] shutdown
! Configurando a porta 10G 1/3/0/1 do Switch 1 em shutdown

[Sw2] interface Ten-GigabitEthernet2/3/0/2
[Sw2-Ten-GigabitEthernet2/3/0/2] shutdown
! Configurando a porta 10G 2/3/0/1 do Switch 2 em shutdown

5º Crie a interface lógica para o IRF 

[Sw1] irf-port 1/2 
! Criando a interface lógica IRF 1/2
[Sw1-irf-port 1/2] port group interface Ten-GigabitEthernet1/3/0/2 mode enhanced
! Adicionando a porta 10G 1/3/0/2 do Switch 1 na interface IRF no modo enhanced

[Sw2] irf-port 2/1
! Criando a interface lógica IRF 2/1
[Sw2-irf-port 2/1] port group interface Ten-GigabitEthernet2/3/0/2 mode enhanced
! Adicionando a porta 10G 2/3/0/2 do Switch 1 na interface IRF no modo enhanced

Obs: O fabricante sugere a configuração das portas IRF em modo cruzado, como por exemplo, a porta IRF 1/2 do Switch 1 conectado na porta IRF 2/1 do Switch 2


6º Remova as portas 10G do Shutdown

[Sw1] interface Ten-GigabitEthernet1/3/0/1
[Sw1-Ten-GigabitEthernet1/3/0/2]undo shutdown


[Sw2] interface Ten-GigabitEthernet2/3/0/1
[Sw2-Ten-GigabitEthernet2/3/0/2] undo shutdown

Após removermos a porta do Switch 2 participante do IRF do shutdown, será exibida a seguinte mensagem:

IRF merge occurs and the IRF system needs a reboot.

Salve a configuração dos 2 Switches e reinicie o Segundo Switch ( o dispositivo não-Master). Espere os módulos subirem e os Switches tornarem-se um só!
Display

Para verificar o IRF podemos utilizar os comandos abaixo

[SW1]display irf configuration

MemberID NewID IRF-Port1 IRF-Port2

1 1 disable Ten-GigabitEthernet1/3/0/2
2 2 Ten-GigabitEthernet2/3/0/2 disable

[SW1]display irf topology

Topology Info
---------------------------------------

IRF-Port1 IRF-Port2

Switch Link neighbor Link neighbor Belong To
1 DIS -- UP 2 00e0-fc0a-15e0
2 UP 1 DIS -- 00e0-fc0a-15e0

Configuração final após o IRF concluído.

[SW1]display current-configuration
#
version 5.20, Release 6605P03
#
sysname SW1
#
irf mac-address persistent always
undo irf link-delay
irf member 1 priority 32
#
lldp enable
#
switch-mode standard chassis 1
switch-mode normal chassis 1 slot 2
switch-mode normal chassis 1 slot 3
switch-mode standard chassis 2
switch-mode normal chassis 2 slot 2
switch-mode normal chassis 2 slot 3
#
vlan 1
#
stp enable
#
interface GigabitEthernet1/2/0/1
#
interface GigabitEthernet1/2/0/2
#
interface GigabitEthernet1/2/0/3
#
interface GigabitEthernet1/2/0/4
#
interface GigabitEthernet1/2/0/5
#
interface GigabitEthernet1/2/0/6
#
interface GigabitEthernet1/2/0/7
#
interface GigabitEthernet1/2/0/8
#
interface GigabitEthernet1/2/0/9
#
interface GigabitEthernet1/2/0/10
#
interface GigabitEthernet1/2/0/11
#
interface GigabitEthernet1/2/0/12
#
interface GigabitEthernet1/2/0/13
#
interface GigabitEthernet1/2/0/14
#
interface GigabitEthernet1/2/0/15
#
interface GigabitEthernet1/2/0/16
#
interface GigabitEthernet1/2/0/17
#
interface GigabitEthernet1/2/0/18
#
interface GigabitEthernet1/2/0/19
#
interface GigabitEthernet1/2/0/20
#
interface GigabitEthernet1/2/0/21
#
interface GigabitEthernet1/2/0/22
#
interface GigabitEthernet1/2/0/23
#
interface GigabitEthernet1/2/0/24
#
interface GigabitEthernet1/2/0/25
shutdown
#
interface GigabitEthernet1/2/0/26
shutdown
#
interface GigabitEthernet1/2/0/27
shutdown
#
interface GigabitEthernet1/2/0/28
shutdown
#
interface GigabitEthernet1/2/0/29
shutdown
#
interface GigabitEthernet1/2/0/30
shutdown
#
interface GigabitEthernet1/2/0/31
shutdown
#
interface GigabitEthernet1/2/0/32
shutdown
#
interface GigabitEthernet2/2/0/1
#
interface GigabitEthernet2/2/0/2
#
interface GigabitEthernet2/2/0/3
#
interface GigabitEthernet2/2/0/4
#
interface GigabitEthernet2/2/0/5
#
interface GigabitEthernet2/2/0/6
#
interface GigabitEthernet2/2/0/7
#
interface GigabitEthernet2/2/0/8
#
interface GigabitEthernet2/2/0/9
#
interface GigabitEthernet2/2/0/10
#
interface GigabitEthernet2/2/0/11
#
interface GigabitEthernet2/2/0/12
#
interface GigabitEthernet2/2/0/13
#
interface GigabitEthernet2/2/0/14
#
interface GigabitEthernet2/2/0/15
#
interface GigabitEthernet2/2/0/16
#
interface GigabitEthernet2/2/0/17
#
interface GigabitEthernet2/2/0/18
#
interface GigabitEthernet2/2/0/19
#
interface GigabitEthernet2/2/0/20
#
interface GigabitEthernet2/2/0/21
#
interface GigabitEthernet2/2/0/22
#
interface GigabitEthernet2/2/0/23
#
interface GigabitEthernet2/2/0/24
#
interface GigabitEthernet2/2/0/25
shutdown
#
interface GigabitEthernet2/2/0/26
shutdown
#
interface GigabitEthernet2/2/0/27
shutdown
#
interface GigabitEthernet2/2/0/28
shutdown
#
interface GigabitEthernet2/2/0/29
shutdown
#
interface GigabitEthernet2/2/0/30
shutdown
#
interface GigabitEthernet2/2/0/31
shutdown
#
interface GigabitEthernet2/2/0/32
shutdown
#
interface M-Ethernet1/0/0/0
#
interface Ten-GigabitEthernet1/3/0/1
#
interface Ten-GigabitEthernet2/3/0/1
#
interface Ten-GigabitEthernet1/3/0/2
#
interface Ten-GigabitEthernet2/3/0/2
#
load xml-configuration
#
user-interface aux 1/0
user-interface aux 2/0
user-interface vty 0 4
#
irf-port 1/2
port group interface Ten-GigabitEthernet1/3/0/2 mode enhanced
#
irf-port 2/1
port group interface Ten-GigabitEthernet2/3/0/2 mode enhanced
#

 

Abraços

Switches HPN A5800- Comportamento do IRF após um SPLIT

O protocolo IRF v2 permite o “empilhamento” de Switches modulares e empilháveis (stackable), trazendo inúmeras vantagens como redundância, facilidade no gerenciamento, etc.

O IRF pode trazer problemas quando há a quebra do Link 10G que mantém o IRF ativo, essa quebra é chamada de SPLIT. Quando um equipamento percebe que o Master não está respondendo ele assume as suas funções, e nesse caso, com os 2 equipamentos funcionando, ocorrerá a duplicação de alguns serviços e trazendo diversos conflitos na Rede(lembrando que apenas a fibra que sincroniza as informações para o IRF foi danificada).

Publicamos alguns posts no blog com a configuração de proteção para que os equipamentos percebam quando ocorre um SPLIT e bloqueiem um dos equipamentos colocando-o em estado de Recovery, deixando todas as portas inutilizáveis.

É possível utilizar features como BFD e o LACP para monitoração do IRF v2 e escolher algumas interfaces mais críticas para continuarem encaminhando no caso de falha no cabo que conecta o IRF.

Um detalhe importante a ser percebido é que após a correção do SPLIT (com reparo do cabo 10G danificado) o Switch que estava em estado de Recovery reiniciará automaticamente para efetuar o merge (junção) novamente no IRF.
Segue abaixo as saídas após a quebra do IRF

[Switch]
#May 29 04:12:18:253 2000 Switch IFNET/4/INTERFACE UPDOWN:
Trap 1.3.6.1.6.3.1.1.5.3: Interface 11796529 is Down, 
ifAdminStatus is 1, ifOperStatus is 2
%May 29 04:12:18:254 2000 Switch IFNET/3/LINK_UPDOWN:
Ten-GigabitEthernet1/0/50 link status is DOWN.

System is busy with VIU configuration recovery, please wait a moment...

[Switch]disp mad verbose
Current MAD status: Recovery
Excluded ports(configurable):
Excluded ports(can not be configured):
Ten-GigabitEthernet1/0/50
MAD ARP disabled.
MAD LACP disabled.
MAD BFD enabled interface:
Vlan-interface10
mad ip address 192.168.1. 1 255.255.255.252 member 1
mad ip address 192.168.1. 2 255.255.255.252 member 2

! Após reconectarmos as portas do IRF o Switch reiniciará automaticamente 

%May 29 04:13:55:028 2000 Switch STM/6/STM_LINK_STATUS_UP:
IRF port 2 is up.