Monthly Archives: fevereiro 2013

Comando “screen-length disable”

O comado screen-length disable aplicado no modo user-view  < > possibilita a que as saídas para o comando “display”   não exibam o “more” para paginação dos outputs solicitados. Conforme exemplo abaixo sem o comando screen-length disable aplicado:

 

<SW1>disp current-configuration
#
version 5.20, Release 9101
#
sysname SW1
#
domain default enable system
#
vlan 1
#
vlan 2 to 4
#
vlan 99
#
domain system
access-limit disable
state active
---- More ----

A dica é útil para quem faz a coleta de informações em TXT por exemplo, e em programas de terminais como o Putty ou por script (o comando screen-length disable  exibirá a saída toda de uma só vez).

 

<SW1>screen-length disable
% Screen-length configuration is disabled for current user.

para remover utilize o undo:

<SW1>undo screen-length disable
% Screen-length configuration is recovered for current user.

Até logo!

Apagar uma VRF/VPN no HPN

Segue abaixo mais um post cedido pelo Paulo Roque. A dica é bastante útil para cenários com utilização de VRFs [(vpn-instance) que permitem a segmentação da tabela de roteamento de um Switch/Roteador] e que após a finalização dos testes ou remoção da configuração de um cliente, precisa ser removida da configuração do dispositivo…

Srs,

É possível apagar toda a config (IPs, rotas, address-family e VRRP) referente a uma vpn-instance no HPN com apenas um comando. Basta apagar a própria VRF. Pode ser útil na hora de elaborar o back-out (plano de volta) para remover as configurações. Isto também vale para o IOS (Cisco). Veja o exemplo.

#=====================================================

#DISPLAY CURRENT-CONFIG (only the important items).
#=====================================================
[rt01]display cur
#
version 5.20, Release 2105, Standard
#
ip vpn-instance TESTE-VRF
route-distinguisher 100:1
vpn-target 100:1 export-extcommunity
vpn-target 100:1 import-extcommunity
#
interface Ethernet0/0
port link-mode route
ip binding vpn-instance TESTE-VRF
ip address 192.168.1.1 255.255.255.0
vrrp vrid 100 virtual-ip 192.168.1.3
vrrp vrid 100 priority 110
undo vrrp vrid 100 preempt-mode
#
#
bgp 65000
undo synchronization
peer 192.168.1.2 as-number 65001
#
ipv4-family vpn-instance TESTE-VRF
import-route direct
import-route static
#
ip route-static vpn-instance TESTE-VRF 192.168.2.0 255.255.255.0 192.168.1.2
ip route-static vpn-instance TESTE-VRF 192.168.3.0 255.255.255.0 192.168.1.2
ip route-static vpn-instance TESTE-VRF 192.168.4.0 255.255.255.0 192.168.1.2
ip route-static vpn-instance TESTE-VRF 192.168.5.0 255.255.255.0 192.168.1.2
#
#===========================================================
# DELETE THE VPN CONFIG AND DISPLAY THE CURRENT CONFIG AGAIN
#===========================================================
#
[rt-01]undo ip vpn-instance TESTE-VRF
[rt-01]
[rt-01]dis cur | i TESTE-VRF
[rt-01]
#=====================================================
# NOTE THAT VRRP CONFIG WAS ALSO DELETED
#=====================================================
[rt-01]dis cur int e0/0
#
interface Ethernet0/0
port link-mode route
#

Proque

Até logo :)

OSPF – Roteador Designado (DR) e Roteador Designado de Backup (BDR)

Para o estabelecimento de uma adjacência no OSPF os Roteadores vizinhos devem se reconhecer para trocarem informações, encaminhando e recebendo mensagens Hello nas Interfaces participantes do OSPF; no endereço de Multicast 224.0.0.5.

Durante estabelecimento da Adjacência, serão trocadas informações dos Roteadores da Rede como a informação da área, prioridade dos Roteadores, etc. Após a sincronizarem as informações, os Roteadores da área terão a mesma visão da Topologia e rodarão o algoritmo SPF para escolha do melhor caminho para chegar ao Destino.

Os Roteadores (já) Adjacentes encaminharão mensagens Hellos ( verificação da disponibilidade), mensagens LSA com as atualizações da rede e mensagens a cada 30 minutos de refresh de cada LSA para certificar que os a tabela OSPF (LSDB) esteja sincronizada.

Durante a falha de um Link, a informação é inundada (flooded) para todos os Roteadores Adjacentes da Área. 

Em ambientes Multiacesso como redes Ethernet, os Roteadores OSPF elegem um Roteador Designado (DR) para formar Adjacência e encaminhar os LSA’s somente para ele. O Roteador DR reencaminha os updates recebidos por um vizinho para os outros Roteadores na mesma LAN.

Há também a eleição de um Roteador Desingnado de Backup (BDR) para assumir em caso de falha do DR.

O método de eleição do DR e BDR é bastante efetivo e confiável para estabelecimento de Adjacências e mensagens trocadas para manutenção do OSPF, economizando assim recursos conforme o crescimento da Topologia.

Atualização DR e BDR

 

Quando ocorre uma mudança na topologia o Roteador/Switch encaminha uma mensagem em Multicast para o endereço 224.0.0.6 que é destinada a todos Roteadores OSPF DR/BDR.

Após o recebimento do Update, o Roteador DR confirma o recebimento (LSAck) e reencaminha a mensagem para os demais roteadores da rede no endereço de Multicast 224.0.0.5; após o recebimento da atualização todos os roteadores deverão confirmar a mensagem ao Roteador Designado (LSAck), tornando o processo confiável.

Se algum Roteador estiver conectado à outras redes, o processo de flood é repetido!

Obs: O BDR não efetua nenhuma operação enquanto o DR estiver ativo!

Como é feita a eleição do DR e BDR? 

Durante o processo de estabelecimento de Adjacência é verificado o campo Priority na troca de mensagens Hello. O Roteador com maior valor é eleito o DR e o Roteador com segundo maior valor é eleito o BDR ( em cada segmento).

O valor default da prioridade de todos os Roteador é 1, no caso de empate, é escolhido o valor do ID do Roteador para desempate. Vence quem tiver o maior valor!

OSPF DR Priority

 

Obs: Se a prioridade for configurada como 0, o dispositivo nunca será um DR ou BDR. Nesse caso ele será classificado com DROther ( não DR e não BDR) 

Configurando
O valor da prioridade deverá ser configurado na Interface VLAN ou física (Ethernet, GigabitEthernet, etc) dos Switches/Roteadores com o processo de OSPF ativo:

interface Vlan-interface1
ip address 192.168.0.26 255.255.255.0
ospf dr-priority 3
!Configurando a Prioridade para eleição do DR/BDR com o valor 3

Porém….

A prioridade do DR e do BDR não é preemptiva, isto é, para manter a estabilidade da topologia se um dispositivo for eleito como DR e BDR, o mesmo não perderá esse direito até ocorrer algum problema no link ou no dispositivo eleito.

Conforme comando display abaixo, o Switch configurado com a prioridade 3 perde a eleição (de tornar-se o DR) para dispositivo com a prioridade 4 ( pelo fato de ser inserido na topologia posteriormente a eleição do DR/BR).

[7500]display ospf peer
OSPF Process 100 with Router ID 192.168.0.5
Neighbor Brief Information

Area: 0.0.0.0
Router ID Address Pri Dead-Time Interface State

192.168.0.13 192.168.0.13 0 38 Vlan1 Full/DROther
192.168.0.14 192.168.0.14 1 31 Vlan1 Full/DROther
192.168.0.20 192.168.0.20 1 34 Vlan1 Full/DROther
192.168.0.21 192.168.0.21 4 30 Vlan1 Full/DR
!Roteador DR com a prioridade 4
192.168.0.26 192.168.0.26 5 31 Vlan1 Full/DROther
! Roteador DROther com a prioridade 5 só será o DR na falha do DR e BDR
192.168.0.33 192.168.0.33 1 32 Vlan1 Full/BDR
! Roteador BDR com a prioridade 1
192.168.0.45 192.168.0.45 1 40 Vlan1 Full/DROther

O Switch com a Prioridade 5, irá tornar-se DR somente após falha no DR e no BDR.

Referencias:

Building Scalable Cisco Internetworks – Diane Teare/Catherine Paquet

Duvidas? Deixe um comentário!

Um grande abraço