Monthly Archives: fevereiro 2012

IPv6 – Introdução ao Endereçamento e Cabeçalho

Publicado originalmente em 7 DE AGOSTO DE 2010

Olá Pessoal, hoje inicio mais um artigo referente ao IPv6. Tenho certeza que grande maioria dos técnicos de informática já ouviram  bastante coisa sobre o tema e mesmo assim, há uma incerteza de como isso funcionará e/ou afetará a maneira como lidamos com os endereços de rede e serviços.

Nos últimos meses tenho lido bastante coisa sobre o tema e após alguns laboratórios com os endereçamentos IP versão 6, venho percebendo que o assunto não é um bicho de sete cabeças!

Como informação nunca é de mais, postarei um resumo do meu trabalho entregue na Universidade e a dica do site http://ipv6.br/que possui um curso bacana (grátis) em português sobre o assunto…

O IP versão 6, atende todas as necessidade propostas para melhora da versão anterior. Genericamente, o IPv6 não é compatível com o IPv4, mas é compatível com os outros protocolos auxiliares da Internet, como TCP, UDP, ICMP, IGMP, DNS, etc.

A principal modificação está relacionada ao endereçamento de128 bits, comparado aos 32 bits do IPv4. O aumento na quantidade de endereços oferecem um número ilimitado de endereços na Internet, melhora na confiabilidade de endereços, flexibilidade e facilidade de multihoming para diversos Provedores (ISP), auto-configuração de endereços de rede IPv6 e comunicação fim-a-fim sem a necessidade de NAT.

Devido ao tamanho dos endereços IPv6, tornou-se impraticável a representação da mesma maneira que os endereços IPv4, como resultado, 8 grupos de 16 bits separados por dois-pontos (“:”) são representados em formato hexadecimal:

  • 1234:5678:9ABC:DEF0:1234:5678:9ABC:DEF0

Tendo em vista a utilização de vários endereços contendo números zero, essa porção do endereço poderá ser omitida e representada por dois dois-pontos(“::”). De modo que 0987poderá ser escrito como 987. Um ou mais grupos de 16bits zero podem ser substituídos por um par de dois-pontos . Os pares de dois-pontos utilizados na abreviação podem ser utilizados somente uma vez, para eliminar ambigüidade.

Como exemplo a abreviação do endereço2001:0002:0000:0000:00A1:0CC0:0234:9876 poderá ser da seguinte forma:

  • 2001:2:0:0A1:CC0:234:9876
  • 2001:0002::00A1:0CC0:0234:9876
  • 2001:2::A1:CC0:234:9876

Para o uso de mais de um IP em um mesmo dispositivo, foram criados os seguintes esquemas:

Unicast: similar aos endereços unicast IPv4, um endereço unicast IPv6 é endereçado para uma única interface. Uma interface poderá ter vários endereços unicast. Os endereços em unicast podem ser global, link-local, unique local(ULA) e IPv4 compatible.

Multicast: neste esquema, um único dispositivo consegue identificar várias interfaces na rede, permitindo o envio individual de pacotes; Um pacote enviado para um endereço multicast é entregue para todas as interfaces identificadas com o endereço multicast.

Anycast: o endereço IPv6 pode estar atribuído a mais de uma interface/dispositivo, ao invés de uma individual. Todos os nós com o mesmo endereço unicast proverão serviços de maneira uniforme. Um exemplo de serviço anycast é o balanceamento de entrega de serviços de conteúdo.

No endereçamento IPv4, o broadcast resulta em inúmeros problemas, incluindo problemas na rede conhecidos como tempestade de broadcast que podem parar a LAN completamente. O Broadcast não existem nas redes IPv6, os broadcasts foram substituídos por endereços multicast e anycast.

O segundo aperfeiçoamento importante no IPv6 é a simplificação do cabeçalho. O cabeçalho IPv4 contem 12 campos básicos contra 7 do IPv6. Esta mudança permite aos roteadores encaminharem os pacotes com maior agilidade, melhorando o throughput e o retardo.

O cabeçalho IPv6 contem os seguintes campos:

Version: possui 4 bits, o mesmo que no IPv4. No IPv6 o campo contem o numero 6.

Traffic class: possui 8 bits e função similar ao campo IPv4 type of service (ToS). Este campo marca o pacote para diferenciação de Qualidade de Serviço dos pacotes IP (QoS).

Flow Label: este novo campo possui 20 bits e poderá ser utilizado para a marcação na origem para especificação do pacote como parte de um determinado fluxo. O fluxo pode ser configurado com antecedência e ter um identificador atribuído a ele e forçando aos Switches Multicamadas e Roteadores verificar nas tabelas internas que tipo de tratamento especial ele exigem, para melhor encaminhamento e desempenho.

Payload lenght: determina o numero de bytes que seguem o cabeçalho de 40bytes.

Next header: o valor de 8 bits determina o tipo de informação que segue o cabeçalho IPv6 básico.O cabeçalho pode ser simplificado porque existe a possibilidade de haver outros cabeçalhos de extensão(opcionais).

Hop limit: campo de 8 bits com função similar ao campo TTL da versão 4

Source address: Campo de 128 bits que identifica a origem do pacote.

Destination address: Campo de 128 bits que identifica o destino do pacote.

Extension headers: Esses cabeçalhos podem ser criados com a finalidade de oferecer informações extras para tornar o encaminhamento mais rápido e eficiente. Estes cabeçalhos extras permitem uma maior eficiência, devido ao tamanho do cabeçalho, que pode ser ajustado às necessidades. Os cabeçalhos devem ser utilizados de forma encadeada permitindo uma maior flexibilidade, porque podem ser sempre adicionados novos cabeçalhos para satisfazer novas especificações. As especificações actuais recomendam a seguinte ordem:

1. IPv6

2. Hop-By-Hop Options Header

3. Destination Option Header

4. Routing Header

5. Fragment Header

6. Authentication Security Payload Header

7. Destination Options Header

8. Upper-Layer Header

O cabeçalho de autenticação, pertencente ao extension headers, oferecendo um mecanismo pelo qual o receptor de um pacote pode ter certeza de quem enviou. A carga útil de segurança criptografada torna possível criptografar o conteúdo do pacote. Esses cabeçalhos utilizam técnicas criptográficas para alcançar os objetivos a que se propõem. O IPsec torna-se nativo ao IPv6 com o authentication header (AH), com o next-header com o valor igual 51 e o cabeçalho Encapsulating Security Payload (ESP), com o next-header com o valor igual 50 que poderão ser utilizados dentro do IPsec para providenciar autenticação, integridade e confidencialidade do pacote.

Muitas das alterações incorporadas ao IP versão 6 referem-se a melhora no desempenho no encaminhamento dos pacotes como a remoção do campo checksum ( presentes na camada de enlace e transporte, tornando-a redundante no cabeçalho IP) e melhora no processo de fragmentação.

Na prática, o espaço de endereços não será utilizado com eficiência, mas haverá na versão 6 uma inesgotável quantidade de endereços para PDAs, pen-tablets, celulares, carros, eletrodomésticos, edifícios inteligentes, monitoramentos médicos e etc. Devido a isso os dispositivos poderão ter mais de um endereço IP tornando possivel que certos serviços sejam executados simultaneamente numa mesma máquina e para cada um haverá uma conexão exclusiva.

Cadê a Máscara do IPv6? 

Os endereços IPv6 trabalham diretamente com os prefixos, similar a representação atual que fazemos nas redes IPv4 ( 192.168.1.0/24) que representam a os bits de rede e os bits de host.

Para as redes locais é sugerido a utilização de prefixos /64, então se quiséssemos configurar o primeiro endereço válido da rede 2001:0db8:0000:000:0000:0000:0000:0000/64 em um roteador, poderiamos configurar com o endereço IPv6 na interface como ipv6 address 2001:db8::1/64 ( fácil, fácil )!

E vocês, qual a sua experiência com endereços IPv6 (alguma, nenhuma)? Comentem!!

Bibliografia
Redes de Computadores – 4ª edição
Andrew S. Tanenbaum
Building Scalable Cisco Internetworks – 3ª edição
Diane Teare

Referências
http://www.infowester.com/ipv6.php
http://www.faqs.org/rfcs/rfc1550.html
http://ipv6.br/

 

 

Switches 3Com 4800G – RIPng

Publicado originalmente em 5 DE AGOSTO DE 2010

Olá amigos, hoje escreverei um artigo sobre o RIPng, o primeiro post de uma série sobre IPv6.

O RIPng é um protocolo de Roteamento dinâmico, IGP, de vetor de distancia que permite que Roteadores troquem informações sobre as suas rotas/prefixos IPv6 dentro do domínio RIPng, utilizando-se da contagem de saltos como custo para cada prefixo (rede).

Assim como no RIP versão 1 e 2 (redes IPv4), o RIPng utiliza a contagem de até 15 saltos, conforme os Roteadores vão repassando os prefixos para os vizinhos é adicionado o custo 1 ao prefixo declarado em cada Roteador , o 16º salto é considerado inalcançável(infinito).

 

O RIPng possui os mesmos temporizadores (timers), procedimentos e mensagens que o RIP versão 2 ( 30 segundos para atualizações, 180 para timeout, 120 para garbage-collection e 180 segundos para holddown).

Diferente do RIP versão 2, a autenticação fica a encargo do IPv6. O RIPng encaminha e recebe datagramas UDP na porta 521.

Configurando o RIPng

• O Switch 1 possui o a rede 2001:db8:90::/64
o A comunicação com o Switch 2 será pela rede 2001:db8:1::/64
o A comunicação com o Switch 3 será pela rede 2001:db8:2::/64

• O Switch 2 possui o a rede 2001:db8:20::/64
o A comunicação com o Switch 1 será pela rede 2001:db8:1::/64
o A comunicação com o Switch 3 será pela rede 2001:db8::/64

• O Switch 3 possui o a rede 2001:0db8:30::/64
o A comunicação com o Switch 2 será pela rede 2001:db8::/64
o A comunicação com o Switch 1 será pela rede 2001:db8:2/64

Switch 1

sysname SW1
#
vlan 1 
#
vlan 2
#
vlan 90
#
ipv6
! Ativando o IPv6 
#
interface Vlan-interface1
ipv6 address 2001:DB8:1::1/64
! Configurando o endereço IPv6 2001:0db8:1::1/64 
ripng 1 enable
! Ativando o RIPng processo 1 na interface VLAN 1
#
interface Vlan-interface2
ipv6 address 2001:DB8:2::2/64
! Configurando o endereço IPv6 2001:db8:2::2/64 
ripng 1 enable
! Ativando o RIPng processo 1 na interface VLAN 2 
#
interface Vlan-interface90
ipv6 address 2001:DB8:90::1/64
! Configurando o endereço IPv6 2001:db8:90::1/64
ripng 1 enable
! Ativando o RIPng processo 1 na interface VLAN 90
#
interface GigabitEthernet1/0/31
#
interface GigabitEthernet1/0/32
port link-type access
port access vlan 2
#

Switch 2

sysname SW2
#
vlan 1
#
vlan 3
#
vlan 20
#
ipv6
#
interface Vlan-interface1
ipv6 address 2001:DB8:1::2/64
ripng 1 enable
#
interface Vlan-interface3
ipv6 address 2001:DB8::1/64
ripng 1 enable
#
interface Vlan-interface20
ipv6 address 2001:DB8:20::1/64
ripng 1 enable
#
interface GigabitEthernet1/0/25
#
interface GigabitEthernet1/0/26
port link-type access
port access vlan 3
#

Switch 3

#
sysname SW3
#
vlan 1
#
vlan 2
#
vlan 3
#
ipv6
#
interface Vlan-interface2
ipv6 address 2001:DB8:2::1/64
ripng 1 enable
#
interface Vlan-interface3
ipv6 address 2001:DB8::2/64
ripng 1 enable
#
interface Vlan-interface30
ipv6 address 2001:DB8:30::1/64
ripng 1 enable
#
interface GigabitEthernet1/0/47
port link-type access
port access vlan 3
#
interface GigabitEthernet1/0/48
port link-type access
port access vlan 2
#

Comandos Display

[SW3]display ipv6 routing-table 

Routing Table :
Destinations : 11 Routes : 12

Destination: ::1/128 Protocol : Direct
NextHop : ::1 Preference: 0
Interface : InLoop0 Cost : 0

Destination: 2001:DB8::/64 Protocol : Direct
NextHop : 2001:DB8::2 Preference: 0
Interface : Vlan3 Cost : 0

Destination: 2001:DB8::2/128 Protocol : Direct
NextHop : ::1 Preference: 0
Interface : InLoop0 Cost : 0

Destination: 2001:DB8:1::/64
Protocol : RIPng NextHop : FE80::224:73FF:FEE0:8481 Preference: 100
Interface : Vlan2 Cost : 1 

Destination: 2001:DB8:1::/64
Protocol : RIPng NextHop : FE80::224:73FF:FEDC:4381 Preference: 100
Interface : Vlan3 Cost : 1 

Destination: 2001:DB8:2::/64
Protocol : Direct NextHop : 2001:DB8:2::1 Preference: 0
Interface : Vlan2 Cost : 0

Destination: 2001:DB8:2::1/128 Protocol : Direct
NextHop : ::1 Preference: 0
Interface : InLoop0 Cost : 0

Destination: 2001:DB8:20::/64 Protocol : RIPng
NextHop : FE80::224:73FF:FEDC:4381 Preference: 100
Interface : Vlan3 Cost : 1

Destination: 2001:DB8:30::/64 Protocol : Direct
NextHop : 2001:DB8:30::1 Preference: 0
Interface : Vlan30 Cost : 0

Destination: 2001:DB8:30::1/128 Protocol : Direct
NextHop : ::1 Preference: 0
Interface : InLoop0 Cost : 0

Destination: 2001:DB8:90::/64 Protocol : RIPng
NextHop : FE80::224:73FF:FEE0:8481 Preference: 100
Interface : Vlan2 Cost : 1

Destination: FE80::/10 Protocol : Direct
NextHop : :: Preference: 0
Interface : NULL0 Cost : 0

Um detalhe importante a ser percebido (grifado em vermelho) na visualização da tabela de Roteamento IPv6, são as rotas aprendidas dinâmicamente pelo RIPng. Repare que o endereço do NextHop (próximo salto) foi gerado dinamicamente pelo RIPng.

 

O endereço FE80::/10 é reservado para endereços chamados de Link-local que possuem escopo limitado e são utilizados para configuração automatica de endereços, descoberta de rotas e por diversos Protocolos de Roteamento.

No caso dos links Ethernet é utilizado a derivação do endereço MAC (48 bits) do Switch para gerar um endereço de 64 bits, por exemplo, o Switch 1 possui o endereço MAC 0024-73e0-8480. O NextHop para a rede 2001:db8:90::/64 mostrado na tabela de roteamento IPv6 do SW3 é :

Destination: 2001:DB8:90::/64 Protocol : RIPng
NextHop : FE80::224:73FF:FEE0:8481 Preference: 100

Note que é inserido 16 bits (FFFE) entre o endereço MAC para criação automática do endereço Link Local.

Obs: A especificação do próximo salto para o RIPng sempre será um Link local.

 

[SW3]display ripng 1 route
Route Flags: A - Aging, S - Suppressed, G - Garbage-collect
----------------------------------------------------------------

Peer FE80::224:73FF:FEDC:4381 on Vlan-interface3
Dest 2001:DB8::/64,
via FE80::224:73FF:FEDC:4381, cost 1, tag 0, A, 19 Sec
Dest 2001:DB8:20::/64,
via FE80::224:73FF:FEDC:4381, cost 1, tag 0, A, 19 Sec
Dest 2001:DB8:1::/64,
via FE80::224:73FF:FEDC:4381, cost 1, tag 0, A, 19 Sec

Peer FE80::224:73FF:FEE0:8481 on Vlan-interface2
Dest 2001:DB8:2::/64,
via FE80::224:73FF:FEE0:8481, cost 1, tag 0, A, 17 Sec
Dest 2001:DB8:90::/64,
via FE80::224:73FF:FEE0:8481, cost 1, tag 0, A, 17 Sec
Dest 2001:DB8:1::/64,
via FE80::224:73FF:FEE0:8481, cost 1, tag 0, A, 17 Sec

Aos poucos irei adicionando outros posts sobre IPv6.

Espero que tenham gostado!

Abraços

 

 

Switches 3Com 4800G – IGMP Snooping

Publicado originalmente em 3 DE OUTUBRO DE 2010

O Protocolo IGMP permite que hosts registrem-se a um Grupo Multicast encaminhando/ respondendo mensagens IGMP ao Roteador da LAN. Roteadores e Switches de Camada 3 escutam as mensagens IGMP para encaminhar o fluxo para o segmento solicitante.
 Após o Switch Core receber o tráfego Multicast do Servidor, ele precisa decidir sobre o encaminhamento do tráfego Multicast nos links Ethernet (após satisfazer as seguintes questões):
  • Existe algum usuário conectado em meus links Ethernet que está interessado em receber o tráfego Multicast?
  • Se nenhum host está interessado em receber o tráfego Multicast, haveria necessidade de encaminhar o tráfego e consumir banda?
  • Se existe um host interessado em receber o tráfego, onde ele está localizado?

Em cima dessas questões, o IGMP foi desenvolvido para estabelecer encaminhamento do tráfego Multicast entre o Roteador e/ou Switch de Camada 3 e as máquinas com as mensagens Join, Query e Leave.

JOIN
Antes de o computador receber o tráfego Multicast, ele necessita efetuar um “Join” no grupo Multicast encaminhando um IGMP Report ao Roteador. O Roteador IGMP encaminha mensagens IGMP Query periodicamente esperando a resposta IGMP Report de algum host para continuar encaminhando tráfego Multicast.

Obs: O computador pode encaminhar um Join antes sem esperar a mensagem IGMP Query do Roteador!

LEAVE
A partir do IGMP versão 2, os hosts que não querem receber o trafego Multicast encaminham uma mensagem IGMP Leave. O Roteador Multicast, encaminha uma nova mensagem IGMP Query questionando se há mais algum computador na rede interessado no tráfego, se não houver resposta, o tráfego Multicast não será encaminhado para o segmento.

IGMP Snooping
Por default, após o Join de um host ao grupo Multicast, o tráfego é inundado para todas as portas dos Switches de acesso que pertencem a VLAN que efetuou a requisição.

  1. O Servidor da VLAN 10 inicia a transmissão do tráfego Multicast
  2.  ALGUNS Hosts da VLAN 192, encaminham uma mensagem IGMP Report (Join) para recebimento de tráfego do Grupo Multicast 239.1.1.1
  3.   O Fluxo Multicast é encaminhado para todas as portas da VLAN 192, incluindo as portas das máquinas que não estão interessadas no conteúdo.

Para evitar a inundação do tráfego Multicast ( transformando o comportamento do tráfego em Broadcast), a feature IGMP-Snooping monitora as mensagens IGMP Report, Query e Leave para adicionar somente as interfaces que desejam receber o fluxo na tabela CAM.

Dessa forma o IGMP Snooping permite aos Switches encaminhar o tráfego Multicast somente para os grupos Multicasts desejados, evitando desperdício de banda e otimizando os Recursos.

 

Comandos do Switch 4800G

#
igmp-snooping
!Habilitando o IGMP-Snooping globalmente

vlan 192
 igmp-snooping enable
!Habilitando o IGMP-Snooping na VLAN 192.

Display

 [4800G] display igmp-snooping group vlan 192
  Total 1 IP Group(s).
  Total 1 IP Source(s).
  Total 1 MAC Group(s).
 Port flags: D-Dynamic port, S-Static port, C-Copy port
  Subvlan flags: R-Real VLAN, C-Copy VLAN
  Vlan(id):1.
    Total 1 IP Group(s). Router port(s):total 1 port.
            GE1/0/48              (D)
! Interface identificada como Porta de conexão com o Roteador,
onde as mensagens Query são geradas
    Total 2 IP Source(s).
    Total 1 MAC Group(s).
    IP group(s):the following ip group(s) match to one mac group.
!Interfaces que efetuaram a solicitação para recebimento de fluxo Multicast
      IP group address:239.1.1.1
        (0.0.0.0, 239.1.1.1):
          Host port(s):total 2 port.

            GE1/0/34              (D)
            GE1/0/38              (D)
    MAC group(s):
          Host port(s):total 2 port.
            GE1/0/34
            GE1/0/38
      MAC group address:0100-5e01-0101
!Endereço MAC do Grupo Multicast e tabela de encaminhamento

Obs: Para configuração do Roteamento Multicast entre VLANs, consultem os tópicos Multicast do Blog ou deixem um comentário!

Abraços a todos!

Referência; CCIE Routing and Switching Exam Certification Guide, 4rd Edition [Odom, Healy, Mehta]

 

 

Switches 3Com 5500 – Configurando Roteamento Multicast com PIM DM

Publicado originalmente em 10 DE SETEMBRO DE 2010

Durante um evento na sala de reunião da Empresa X, a Diretoria solicitou a equipe de TI que a reunião fosse retransmitida e para o departamento de Marketing da Empresa.

Como solução para a solicitação os Analistas decidiram utilizar o Roteamento Multicast para exibir o vídeo somente para os funcionários do departamento interessados, ao invés de encaminhar o vídeo para toda a empresa!

Para exibição do Stream (Fluxo)de Vídeo foi utilizado o endereço de Multicast Privado 239.1.1.1. Os Hosts da VLAN Marketing que estiverem interessados em visualizar o conteúdo precisarão buscar o endereço informado.

Segue abaixo a configuração do cenário:

#
multicast routing-enable
! Habilitando o Roteamento Multicast no Switch L3
#
vlan 10
#
vlan 172
#
vlan 192
#
interface Vlan-interface10
ip address 10.0.0.1 255.255.255.0 pim dm
! Configurando a Interface VLAN para encaminhar mensagens Multicast
utilizando o protocolo de Roteamento Multicast PIM Dense Mode
#
interface Vlan-interface172
ip address 172.31.1.1 255.255.255.0
igmp enable
! O Protocolo IGMP é responsável por identificar se os hosts da VLAN 172
querem ou não visualizar o vídeo Multicast
pim dm
! Configurando a Interface VLAN 172 para encaminhar mensagens Multicast
utilizando o protocol de Roteamento Multicast PIM Dense Mode

Comando Display

display multicast routing-table
Multicast Routing Table
Total 1 entry
(10.0.0.100, 239.1.1.1)
! O host 10.0.0.100 gera o fluxo com o endereço Multicast 239.1.1.1
Uptime: 00:22:15, Timeout in 285 sec
Upstream interface: Vlan-interface10(10.0.0.1)
Downstream interface list:
Vlan-interface172(172.31.1.1) 
.....

Pronto, roteamento Multicast funcionando!

 

 

Switches 3Com 4800G- Utilização de alias …

Publicado originalmente em 27 DE ABRIL DE 2010

Hoje postarei mais uma dica apresentada pelo grande Fernando Quintino, que é a utilização de alias para facilitar a administração dos Switches 4800G da 3Com por CLI (linha de comando).

O artigo de hoje é focado para os administradores que possuem uma Rede com equipamentos de diversos fabricantes e sempre se confundem com os comandos digitados na hora da configuração/troubleshooting.

command-alias enable
! ativando a utilização de alias
command-alias mapping display show
! mapeando a utilização do comando "show" para funções "display"
command-alias mapping undo no
! mapeando utilização do comando "no" para funções "undo"
command-alias mapping quit exit
! mapeando utilização do comando "quit" para funções "exit"

Na prática poderiamos digitar o comando show version ou invés de display version, no shutdown ao invés de undo shutdown e quit ao invés de exit.

As alterações ficarão ao gosto do cliente…. :)

abraços

 

 

Switches 3Com 4500G – Upgrade via FTP

Publicado orignalmente em 26 DE ABRIL DE 2010

O post de hoje sugerido pelo Fernando Quintino ensinará como efetuarmos a cópia de arquivos para a memória Flash do Switch 4500G.

No exemplo abaixo o Servidor 1.1.1.2 com o Serviço FTP ativo ( com usuário anonymous e senha em branco) servirá de repositório para o Switch efetuar o download da imagem para a memória Flash do Switch, incluíndo a configuração para o equipamento iniciar com o novo arquivo.

Cópia de aqruivos via FTP

Configuração

 <4500G>ftp 1.1.1.2
! Conexão do Switch no Servidor FTP
user: anonymous
password: [Senha em Branco]
[ftp]ls
! listagem dos arquivos do diretório do FTP
[ftp] get s3q05_02_00s56p12.app
! o comando get efetuará o download do arquivo no repositório
[ftp] get s3r05_03.btm
[ftp]quit
! o comando efetuará logoff do servidor FTP

Obs: Após efetuarmos o download do arquivo .app e .btm poderemos configurar no Switch a inicialização da imagem no próximo boot

<4500G>boot-loader file s3q05_02_00s56p12.app main
!O comando boot-loader define qual imagem será escolhida como principal e backup na
inicialização do Switch.
 <4500G>bootrom update file s3r05_03.btm
!No documento de liberação da imagem s3q05_02_00s56p12.app, a H3C/3Com solicita o upgrade do bootrom.

Após efetuar as configurações, reinicie o equipamento.

 <4500G>reboot

Até a próxima! ;)

 

 

 

Switches 3Com 5500 – Configurando XRN

O XRN é uma tecnologia proprietária da 3Com que permite a diversos Switches de Camada 3 o comportamento de um único dispositivo de comutação lógico chamado Fabric.

O gerenciamento desses dispositivos aparecem na CLI (linha de comando) como um único dispositivo para informações e configuração de Camada 2 e Camada 3.

O XRN oferece ao Fabric alta disponibilidade e melhor performance para os Switches da pilha

Empilhamento pelas portas de UpLink GigabitEthernet

Empilhamento pelas portas traseirsas com o cabo XFB

 

Configurando XRN via portas de UpLink em 2 Switches 5500-EI de 28 portas 

Para evitarmos confusão chamaremos os Switches de A e Switch B.

A 3Com recomenda efetuarmos o empilhamento em Switches da mesma Familia e mesma versão de Sistema Operacional.

Switch A
system-view
fabric-port GigabitEthernet 1/0/25 enable
#
change unit-id 1 to 1
#
set unit 1 name Switch1
#
sysname Switch_Core
#
xrn-fabric authentication-mode simple senha 

Switch B
system-view
fabric-port GigabitEthernet 1/0/26 enable
#
change unit-id 1 to 2
#
set unit 2 name Switch2
#
sysname Switch_Core
#
xrn-fabric authentication-mode simple senha

Segue abaixo alguns commandos display

display xrn-fabric
Fabric name is Switch_Core, system mode is L3.
Unit Name Unit ID
Switch1 1(*)
Switch2 2

display xrn-fabric portGigabitEthernet1/0/25
Fabric peer: GigabitEthernet2/0/26
Fabric Status: Active
Fabric mode: Auto-speed(1000M), Auto-duplex(Full)
input: 22944 packets, 2089000 bytes, 0 input errors
output: 26381 packets, 2572664 bytes, 0 output errors
GigabitEthernet2/0/26
Fabric peer: GigabitEthernet1/0/25
Fabric Status: Active
Fabric mode: Auto-speed(1000M), Auto-duplex(Full)
input: 25903 packets, 2523607 bytes, 0 input errors
output: 22676 packets, 2060448 bytes, 0 output errors

Verificação do Spanning-tree

É interessante verificarmos que mesmo com a existência da conexão física entre o Switch A pela porta Giga 1/0/25 e o Switch B com a porta Giga1/0/26 (no Fabric 2/0/26), as portas não são tratadas como uma conexão entre duas Bridges distintas, isto é, o cabo que interliga os dois Switches atua como um barramento “rudimentar” para comunicação e sincronização de informação entre os dois equipamentos.

Para testes, configuramos a VLAN 2 nas portas Ethernet 1/0/1 e Ethernet 2/0/1 e efetuamos o teste de PING com 2 máquina na mesma subrede. A Comunicação entre os dois hosts foi efetuado com sucesso. Com o comando display interface nas portas de empilhamento é possível visualizar o tipo da porta como stack e a comunicação de todas as VLANs configuradas no Fabric, mesmo sem configurarmos explicitamente as portas com permissão para todas as VLANs.

 

display interface g1/0/25 
GigabitEthernet1/0/25 current state : UP
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 001e-c1f0-b35b
Media type is twisted pair, loopback not set
Port hardware type is 1000_BASE_T_AN_SFP
1000Mbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Flow-control is not enabled
The Maximum Frame Length is 1522
Broadcast MAX-ratio: 100%
Unicast MAX-ratio: 100%
Multicast MAX-ratio: 100%
Allow jumbo frame to pass
PVID: 1Mdi type: auto
Port link-type: stack
Tagged VLAN ID : all
Untagged VLAN ID : none
Last 300 seconds input: 0 packets/sec 49 bytes/sec
Last 300 seconds output: 0 packets/sec 62 bytes/sec
Input(total): 25839 packets, 2341344 bytes
89 broadcasts, 4565 multicasts, 0 pauses
Input(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Input: 0 input errors, 0 runts, 0 giants, - throttles, 0 CRC
0 frame, - overruns, 0 aborts, 0 ignored, - parity errors
Output(total): 29543 packets, 2838020 bytes
582 broadcasts, 4622 multicasts, 0 pauses
Output(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Output: 0 output errors, - underruns, - buffer failures
0 aborts, 0 deferred, 0 collisions, 0 late collisions
0 lost carrier, - no carrier

Configuração final

#
sysname Switch_Core
#
vlan 1
#
vlan 2
#
interface Ethernet1/0/1
port access vlan 2
#
interface GigabitEthernet1/0/25
#
fabric-port GigabitEthernet1/0/25 enable
xrn-fabric authentication-mode simple 123456
#
interface Ethernet2/0/1
port access vlan 2
#
interface GigabitEthernet2/0/26
#
fabric-port GigabitEthernet2/0/26 enable
xrn-fabric authentication-mode simple 123456
#
return
[Switch_Core]

abração! ;)

 

 

 

 

Switches 3Com 4800G – Filtro de prefixos e ASes no BGP

Pessoal, estou compartilhando um segundo script sugerido pelo Meeeeeestre Denis Albuquerque sobre a utilização de filtros para o tamanho dos prefixos incluíndo filtros baseados em ASes. O post serve como continuidade ao post anterior sobre configuração básica do BGP.

Comentario Geral sobre o Script
O BGP permite a configuração regras baseadas em prefixos, ASes, metricas de entrada, saída,etc. A route-policy SAIDA servirá para controlarmos as redes que serão injetadas no proximo AS, como por exemplo, para proteção do próprio AS 65535 não servir de trânsito em caso de conexão direta com outros ASes. A route-policy SAIDA limitará o recebimento de prefixos para SOMENTE os prefixos interessantes.

Configuração

#
interface Vlan-interface10
ip address 10.0.0.1 255.255.255.252
! Interface para estabelecimento de peering eBGP
#
interface Vlan-interface11
ip address 11.0.0.1 255.255.255.252
! Interface para estabelecimento de peering iBGP
#
bgp 65535
undo synchronization
peer 10.0.0.2 as-number 65530
! formação de peering eBGP
peer 11.0.0.2 as-number 65535
! formação de peering iBGP
peer 10.0.0.2 description eBGP
peer 11.0.0.2 description iBGP
peer 10.0.0.2 route-policy SAIDA export
! a route-policy declarará prefixos da regra SAIDA
peer 10.0.0.2 route-policy ENTRADA import
! a route-policy receberá prefixos da regra ENTRADA
peer 10.0.0.2 route-limit 1000
! desfaz o peering se o limite de prefixos recebidos for atingido
peer 10.0.0.2 password simple SENHA
peer 11.0.0.2 next-hop-local
! inclui o Switch como next-hop das rotas encaminhadas. 
#
route-policy ENTRADA permit node 10
if-match ip-prefix FILIAIS
! a route-policy permitirá os prefixos do ip-prefix FILIAIS
route-policy SAIDA permit node 10
if-match as-path 1
! a route-policy permitirá somente os ASes do AS-path 1
#
ip ip-prefix FILIAIS index 10 permit 172.17.0.0 16 greater-equal 16 less-equal 32
! a regra ip-prefix FILIAIS permitirá somente o anuncio da rede 172.17.0.0/16 até /32 , prefixos diferentes ou menores que /16 não serão recebidos
#
ip as-path 1 permit ^$
! a expressão regular ^$ representa somente as rotas locais do próprio AS

Até mais…

 

 

 

 

Switches 3Com 4800G – Configuração básica do BGP

O Protocolo BGP é considerado o mais robusto Protocolo de Roteamento para redes IP. Sua complexidade permite a conexão de múltiplos Sistemas Autônomos, chamados de AS (Autonomous systems), permitindo o Roteamento Dinâmico na Internet.

A Internet consiste em redes Comerciais conectadas por Provedores (ISP’s) como Telefônica,Embratel, Oi, CTBC e etc. Cada rede comercial ou Provedor deve ser identificado pelo Número do seu Sistema Autônomo (ASN) sobre controle do IANA .

A função primária de um sistema BGP é trocar informação de acesso à rede, inclusive Informações sobre a lista das trajetórias dos ASs, com outros sistemas BGP. Esta informação pode ser usada para construir uma rede de conectividade dos ASes livre de loops de roteamento.

O BGP é considerado um Protocolo de Vetor de Distância avançado utilizando-se de vetores para contagem de saltos para cada destino. A contagem de saltos para o BGP é baseada em AS.

Os Roteadores BGP são configurados com informações dos vizinhos para formação de uma conexão TCP confiável para transporte das informações de Roteamento e Sistemas Autônomos. Após estabelecimento da sessão, a conexão TCP continua aberta até a percepção de falha no link ou encerramento explicito da sessão via configuração. O estabelecimento de uma sessão indica a formação de um peer BGP.

O controle para administração de prefixos possibilita a utilização do BGP em diversos ambientes Corporativos fora da Internet. Há diversos cenários que necessitam de flexibilidade e controle que protocolos de Roteamento como OSPF e EIGRP não permitem.

O range de numero de AS 64512 a 65535 permitem a criação de AS’s para uso privado.

Abaixo exemplificaremos a configuração entre Roteadores de diferentes AS.

Configuração
Switch 4800G pertencente ao AS 64512 (Matriz)
#
interface Vlan-interface2
ip address 172.31.1.1 255.255.255.0
#
interface Vlan-interface41
ip address 192.0.2.41 255.255.255.252
#
bgp 64512
!Ativando o BGP no Switch. O número do AS é 64512
network 172.31.1.0 255.255.255.0
! Anunciando o prefixo no BGP
undo synchronization
! Desabilitando a Sincronização (habilitado por default)
peer 192.0.2.42 as-number 64515
! identificando um vizinho BGP
peer 192.0.2.42 password simple senha
! Configurando a autenticação com a senha “senha”
#

Switch 4800G pertencente ao AS 64515 (Filial)
#
interface Vlan-interface42
ip address 192.0.2.42 255.255.255.252
#
interface Vlan-interface180
ip address 180.0.0.1 255.255.255.0
#
bgp 64512
network 180.0.0.0 255.255.255.0
undo synchronization
peer 192.0.2.42 as-number 64515
peer 192.0.2.42 password simple senha
#

Display

[Matriz]display ip routing-table
Routing Tables: Public
Destinations : 7 Routes : 7

Destination/Mask Proto Pre Cost NextHop Interface

127.0.0.0/8 Direct 0 0 127.0.0.1 InLoop0
127.0.0.1/32 Direct 0 0 127.0.0.1 InLoop0
172.31.1.0/24 Direct 0 0 172.31.1.1 Vlan2
172.31.1.1/32 Direct 0 0 127.0.0.1 InLoop0
180.0.0.0/24 BGP 255 0 192.0.2.42 Vlan41
192.0.2.40/30 Direct 0 0 192.0.2.41 Vlan41
192.0.2.41/32 Direct 0 0 127.0.0.1 InLoop0

[Matriz] disp bgp routing-table
Total Number of Routes: 3
BGP Local router ID is 192.168.0.41
Status codes: * - valid, > - best, d - damped,
h - history, i - internal, s - suppressed, S - Stale
Origin : i - IGP, e - EGP, ? - incomplete
Network NextHop MED LocPrf PrefVal Path/Ogn

*> 172.31.1.0/24 0.0.0.0 0 0 i
*> 180.0.0.0/24 192.0.2.42 0 0 64515i

[Matriz]display bgp peer
BGP local router ID : 192.168.0.42
Local AS number : 64512
Total number of peers : 1 Peers in established state : 1

Peer AS MsgRcvd MsgSent OutQ PrefRcv Up/Down State
192.0.2.42 64515 9 10 0 1 00:07:02 Established

Até logo! :)

 

 

 

Switches 3Com 4800G – Redistribuição seletiva de rotas estáticas e interfaces diretamente conectadas no OSPF com Route Policy

Amigos, gostaria de compartilhar um script  elaborado pelo Denis Albuquerque. O script possui uma sofisticação muito bacana para redistribuição seletiva de interfaces diretamente conectadas e rotas estáticas no OSPF.

Quando falamos de Redistribuição, o processo faz referência a interconexão de diversos protocolos de Rotamento (OSPF, RIP, etc), rotas estáticas e interfaces diretamente conectadas no processo de Roteamento dinâmico. Como por exemplo injetar, rotas estáticas em um domínio OSPF ou fazer a redistribuição de Rotas entre uma rede Rodando RIP e a outra rede rodando OSPF.

Segue abaixo os comandos para redistribuição de Rotas estáticas e Interfaces VLAN:

#
ospf 1
default-route-advertise type 1 
import-route direct type 1 route-policy REDIST_CONNECTED 
import-route static type 1 route-policy REDIST_STATIC
silent-interface all
undo silent-interface [interface vlans para adjacência]
area 0.0.0.0
authentication-mode md5
network [ip das interfaces vlan ou routed ]
#

route-policy REDIST_STATIC permit node 10
if-match tag 10
route-policy REDIST_CONNECTED permit node 10
if-match interface [interfaces VLAN para anuncio no OSPF]
#
interface Vlan-interface [id vlan de adjacência]
ospf authentication-mode md5 1 cipher [senha]
ospf dr-priority 255 
! prioridade para eleição do DR

Abraços a todos!